2.8 crd cherokee rough idle after timing belt and water pump done - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 12-05-2012, 11:34 AM Thread Starter
pjbaby
Registered User
 
Join Date: Nov 2012
Posts: 9
2.8 crd cherokee rough idle after timing belt and water pump done

Had my timing belt water pump done week ago now rough idling and rough starting. Changed glow plugs as it was the first thing I though of when rough starting but no change. So then changed fuel filter but nope still same now thinking injectors anyone got/had same problem or have any ideas what it might be its a 2.8 crd cherokee

pjbaby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome