2.5 to 4.0 swap issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Engines & Drivetrain > 2.5 to 4.0 swap issues

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 10-13-2013, 03:09 PM   #1
jeepbowtie
Registered User
 
Join Date: Oct 2011
Location: Boonsboro, MD
Posts: 7
2.5 to 4.0 swap issues

I am currently doing the swap in a 1993 yj 2.5 to a 4.0 out of a 90 Cherokee with 95 computer this motor ran b4 putting it after putting the motor would not start would lope when turning over and had blow by. Bought a 95 Cherokee with running 4.0 that was running perfect in the Cherokee. Took straight out of Cherokee right into the yj. Hooked up the wires and motor started but it acted like the exhaust was going out the throttle body. Shut engine off and jeep would only start every onv in a while and did the me thing getting spark and fuel and compression. Had a 95 computer swapped to a 91 computer still not working also took the 2. Harness and swapped in the injector 5 and 6 wires to the pcm into ports 38 & 58 on the pcm bulkhead. Pin outs are the same form the 2.5 pcm as to the 4.0 besides the 5-6 injector wires. Any help would b appreciated.

Thanks

jeepbowtie is offline   Reply With Quote
Unread 10-13-2013, 08:48 PM   #2
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,898
Did you remove the distributor? Did you use the 4.0 cps?
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote
Unread 10-13-2013, 09:05 PM   #3
jeepbowtie
Registered User
 
Join Date: Oct 2011
Location: Boonsboro, MD
Posts: 7
No and yes
jeepbowtie is offline   Reply With Quote
Unread 10-14-2013, 10:51 AM   #4
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla, florida
Posts: 1,898
Start with testing the cps, I can't find the link but its easy to Google it.
Also check the fuel pressure.
It sounds like timing to me. Maybe there's a bad ground somewhere or bad vacuum.
__________________
http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.