post #1 of Old 02-23-2013, 05:03 PM Thread Starter
Smurfjeep
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Patchogue
Posts: 23
1999 jeep cherokee no heat

I flushed radiator clean as a whistle now changed thermostate filled over flow resivior checked radiator still full no air in there the door opens and closes for heat under dash car hangs around 200-210 but doesn't over heat and still no heat any ideas?

Smurfjeep is offline  
post #2 of Old 02-23-2013, 05:08 PM Thread Starter
Smurfjeep
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Patchogue
Posts: 23
Okay actually let it sit at an ideal and it over heated it if I drive it its stays fine is there a fan I need to check
Smurfjeep is offline  
post #3 of Old 02-23-2013, 07:50 PM
67dartgt
Registered User
1998 XJ Cherokee 
 
Join Date: Jun 2011
Location: carpinteria
Posts: 16
It sounds like there isn't enough coolant in the system. It's good to let the car cool down completely before adding coolant again.
If that Doesn't fix it, maybe try back flushing the heater core. There's several instructional videos on YouTube that were pretty helpful to me when my 98 xj had similar problems.
67dartgt is offline  
post #4 of Old 02-23-2013, 07:52 PM
redding1327
Registered User
1997 XJ Cherokee 
 
Join Date: Nov 2010
Location: seymour
Posts: 283
You may have flushed the radiator but if you didn't flush the heater core you will still not have heat. Flush the heater core, worked for me.
redding1327 is offline  
post #5 of Old 02-23-2013, 09:04 PM Thread Starter
Smurfjeep
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Patchogue
Posts: 23
Flushed both someone told me take the heater core hose off with the heat turned on start the jeep up and see if the water pump is pumping first he said take thermostat sensor out by housing and see of it is filled he said there might still be an air pocket in the head gonna try that tomorrow and see where I end up
Smurfjeep is offline  
post #6 of Old 02-25-2013, 05:14 PM Thread Starter
Smurfjeep
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Patchogue
Posts: 23
All good was water pump
Smurfjeep is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome