09 grand cherokee 4.7 4x4 at slips bad DTC P0841 - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 09-20-2017, 07:55 PM Thread Starter
wyowalsh
Registered User
2009 WK 
 
Join Date: Sep 2015
Location: casper
Posts: 107
09 grand cherokee 4.7 4x4 at slips bad DTC P0841

So I just inherited a 2009 Jeep Grand cherokee. its a 4.7 L 4x4, when shifting into reverse long pause and hard shift, long delay but does get going and not so bad when driving.
check engine lamp on and
DTC P0841 - trans fluid PSI sensor switch A circuit range performance
P0732 - gear 2 incorrect ratio
P0731 - gear 1 incorrect ratio
p0876 - trans fluid PSI sensor switch D circuit range performance

I am thinking about starting with a fluid flush and new fluid, replacing internal and external filters and replace TFPS Sensor !!!

would this be worthy or is trans smoked ? I can do all the work myself, I'm just trying to repair it VS new salvage unit........

thoughts ???
I am an XJ fan, this is a whole new beast.............

what are common reasons this happens ????

wyowalsh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome