post #1 of Old 07-27-2012, 08:44 AM Thread Starter
Cross6969
Registered User
 
Join Date: Jul 2012
Posts: 2
Ac problem

I have a 93 jeep

Cross6969 is offline  
post #2 of Old 07-27-2012, 09:25 AM
ajmorell
Registered User
 
ajmorell's Avatar
 
Join Date: Jan 2006
Location: Santa Fe
Posts: 7,144
mmk
ajmorell is offline  
post #3 of Old 07-27-2012, 09:50 AM Thread Starter
Cross6969
Registered User
 
Join Date: Jul 2012
Posts: 2
Ok..... Hi everyone I have a. 93 jeep grand Cherokee 6cyl 4.0. I replace the condensor, compressor, ac relay switch, accumulator/ drier. The car get cold when it not hummus, but when it hits 80 or better it gets hot. What am I missing to correct problem !
Cross6969 is offline  
post #4 of Old 12-11-2012, 06:48 PM
gumby_144
Registered User
2004 TJ Wrangler 
 
Join Date: Oct 2012
Location: hamilton
Posts: 326
are you sure that the refrigerant charge is correct. also check to make sure there isnt a drier in the system that is pluged or that the metering device isnt pluged.
gumby_144 is offline  
post #5 of Old 12-19-2012, 04:42 PM
crcycle44
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2012
Location: panama city
Posts: 4
There's several different factors that could be your problem.Did you have a compressor failure,if not why did you replace Compressor?
crcycle44 is offline  
post #6 of Old 12-20-2012, 08:57 PM
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes
Posts: 6,414
was a vacuum pulled on the system before it was charged?
narnwv is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome