Ac problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Street Jeep Forum > Ac problem

Artec Holiday Sale!Bead Lock Wheels! Raceline, Trail Ready, & Trail-GearROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 07-27-2012, 09:44 AM   #1
Cross6969
Registered User
 
Join Date: Jul 2012
Posts: 2
Ac problem

I have a 93 jeep

Cross6969 is offline   Reply With Quote Quick reply to this message
Unread 07-27-2012, 10:25 AM   #2
ajmorell
Registered User
 
Join Date: Jan 2006
Location: Santa Fe, New Mexico
Posts: 7,144
mmk
ajmorell is offline   Reply With Quote Quick reply to this message
Unread 07-27-2012, 10:50 AM   #3
Cross6969
Registered User
 
Join Date: Jul 2012
Posts: 2
Ok..... Hi everyone I have a. 93 jeep grand Cherokee 6cyl 4.0. I replace the condensor, compressor, ac relay switch, accumulator/ drier. The car get cold when it not hummus, but when it hits 80 or better it gets hot. What am I missing to correct problem !
Cross6969 is offline   Reply With Quote Quick reply to this message
Unread 12-11-2012, 07:48 PM   #4
gumby_144
Registered User
2004 TJ Wrangler 
 
Join Date: Oct 2012
Location: hamilton, il
Posts: 186
are you sure that the refrigerant charge is correct. also check to make sure there isnt a drier in the system that is pluged or that the metering device isnt pluged.
gumby_144 is offline   Reply With Quote Quick reply to this message
Unread 12-19-2012, 05:42 PM   #5
crcycle44
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2012
Location: panama city, fl
Posts: 4
There's several different factors that could be your problem.Did you have a compressor failure,if not why did you replace Compressor?
crcycle44 is offline   Reply With Quote Quick reply to this message
Unread 12-20-2012, 09:57 PM   #6
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,247
was a vacuum pulled on the system before it was charged?
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.