Sway bar link...disappeared? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 03-04-2013, 08:44 PM Thread Starter
PlaySmart
Registered User
1999 XJ Cherokee 
 
Join Date: Aug 2009
Location: Allendale, Michigan
Posts: 331
Sway bar link...disappeared?

Heard some clunking the other day, so I crawled around to find the source of it today. Found the source, and am now wondering where it went, and how it fell off. Besides driving through the snow all winter, I haven't done anything intensive or even Jeep worthy, not even driving over a curb.
Has anyone else had parts just....disappear? And any thoughts to how this happened?



Jacob
PlaySmart is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-04-2013, 09:33 PM
aguelzo89
Registered User
1995 XJ Cherokee 
 
Join Date: Oct 2012
Location: Holland
Posts: 153
Mine did the same thing!!! I figure just rusted and got brittle then snapped.
aguelzo89 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome