off idle grinding sound? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ/MJ Cherokee Non-Technical Forum > off idle grinding sound?

BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!XJ Rail Sale!

Reply
Unread 07-11-2013, 10:52 PM   #1
RABBIDCOW55
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 76
off idle grinding sound?

99 xj 4.0 with AC. Every time the rpms are around 800-1200 it makes like a grinding, vibrating sound. I thought it was the PS pump so I switched it out for an autozone one cause the bearing felt loose...wrong. replaced both idlers...wrong. checked U joint but I am certain it is rpm based. All the other pullies feel tight and don't make noise when I spin them. I can't for the life of me figure it out but it is driving me crazy. Belt tension feels good and everything looks to be right. Maybe my oil pump is dying? Great pressure though, always at least 60 lbs.....help?

RABBIDCOW55 is offline   Reply With Quote Quick reply to this message
Unread 07-12-2013, 12:17 AM   #2
Muddy97Cherokee
Senior Member
 
Muddy97Cherokee's Avatar
1997 XJ Cherokee 
 
Join Date: Aug 2011
Location: Mustang, Oklahoma
Posts: 647
Is it a grinding sound or squealing sound? I noticed that on mine the mechanical fan is hitting what i think is the A/C line(not sure since I don't feel like looking at it now). Could check that.
__________________
1997 XJ Sport
6.5" with 31's
Built to CRAWL
BUILD THREAD

-ZACK
Muddy97Cherokee is offline   Reply With Quote Quick reply to this message
Unread 07-12-2013, 12:46 AM   #3
RABBIDCOW55
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 76
I thought the same thing, or maybe rubbing on the shroud but it's clear. I'll take a video tomorrow and post it for review.
RABBIDCOW55 is offline   Reply With Quote Quick reply to this message
Unread 07-12-2013, 09:33 AM   #4
BassMasterCHS
Registered User
1993 XJ Cherokee 
 
Join Date: Aug 2009
Location: Tampa, Florida
Posts: 846
The motor mounts are probably bad, causing the fan to rub the shroud. Check the transmission mount as well.
__________________
3 Inch lift, 30" BFG AT's, Walmart lights up front.
BassMasterCHS is offline   Reply With Quote Quick reply to this message
Unread 07-19-2013, 03:04 PM   #5
RABBIDCOW55
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2013
Posts: 76
Sorry for the long wait. Turns out it was the fan clutch on its way out. I checked it before and it seemed tight but went out today after working 14 days in a row and it's loose. Thanks for the help fellas
RABBIDCOW55 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.