New(to me) xj! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 01-21-2013, 05:55 PM Thread Starter
wj_jeep92
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Birmingham
Posts: 282
New(to me) xj!

Well I finally sold my vw gti and found a super rad deal on a 92 xj 4door. I paid 800 bucks for a red cherokee sport 4.0/ax15 with 186k on the clock. It's definitely in below excellent condition but it runs, shifts, blows hot air, and has a working tc, so I can't be to upset at the work it needs. It's leaks about 1/4 quart of oil everyday(neighbors and dad LOVE that) and needed a new valve cover gasket. I decided that the rust on the rear quarters and bottoms of the doors was to much an eyesore for me to look at everyday so I had a long weekend. Saturday was spent painting the rockers, bottoms of doors, and the quarters, as well as the center cowl piece between the windshield and good. Sunday I tackled the vcg and it was a lot easier then I thought it would be. I ended up breaking a plastic nipple off the coolant distribution tree thing, so replaced that as well. I think I'm going to have some fun with this one!

Now to change my username...


1998 ZJ 5.9L
wj_jeep92 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-21-2013, 05:58 PM Thread Starter
wj_jeep92
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Birmingham
Posts: 282
Pictures(hopefully they work, I'm using the iphone app)



image-3791823542.jpg



image-355615030.jpg



image-133203079.jpg



image-592200399.jpg

1998 ZJ 5.9L
wj_jeep92 is offline  
post #3 of 5 Old 01-21-2013, 09:38 PM
MOBBiN
Mall Crawler Level 3
 
MOBBiN's Avatar
2001 XJ Cherokee 
 
Join Date: Mar 2010
Location: Palmer
Posts: 1,229
Looks good so far.

2001 Silverstone Metallic Classic XJ
Build Thread
April 2014 & 2015 COTM
MOBBiN is offline  
post #4 of 5 Old 01-22-2013, 06:14 PM Thread Starter
wj_jeep92
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Birmingham
Posts: 282
Quote:
Originally Posted by MOBBiN
Looks good so far.
Thanks man, hopefully it turns into the worthy weekend warrior I want it to be.

1998 ZJ 5.9L
wj_jeep92 is offline  
post #5 of 5 Old 01-22-2013, 06:20 PM Thread Starter
wj_jeep92
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Birmingham
Posts: 282
I think I'm going to try to turn this into a build thread so I don't clutter up the feed with mindless posts.

Two issues arose yesterday

1) the vacuum canister on the coolant tree(I'm not sure what its called, will grab a pic tomorrow) has a rod that controls what I believe to be the heater core. When it's up(AC on) I don't get heat. When it's down(AC off) I do. The problem I'm havin is the valve not going to "off" when I turn the heat on. So I let my jeep warm up and the heat is still icy cold(10* today). Now regardless to the fact that I know what it is and it's as easy as flipping a switch, I would still like for it to function as it should. Any thoughts?

2) the e brake wasn't working at all when I got it. Got underneath it Sunday to look for rust and figure the problem out and found a couple good things. Since the jeep is originally from Delaware, it's been under coated so there is very little rust except the drivers floorboard bein non existent. And the other thing is the cables just needed tightened. So I did that and low n behold the ebrake now holds. But(there's always a catch), it only holds if it rolls forward. Going backward it's like there isn't any stopping force at all. Thought?

D

1998 ZJ 5.9L
wj_jeep92 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome