post #1 of Old 06-14-2013, 11:01 AM Thread Starter
boomup73
Registered User
 
Join Date: Jun 2013
Location: indio
Posts: 2
No dash lights,guages,radio....

Okay. We just picked up a 89 jeep. It has an issue though. The Guages on the dash are not working at all, except the speedo is working. No dash lights, no wipers and no turn signals or wipers. The hazards do work though. Checked the fuses and they appear to be good. Where should i start?

boomup73 is offline  
post #2 of Old 06-14-2013, 12:18 PM
Rproject
Registered User
1987 YJ Wrangler 
 
Join Date: Aug 2008
Location: Sandwich, IL
Posts: 2,759
That's a whole bunch of unrelated items to have not working.

The gauge package, the right of the steering wheel (from the driver's perspective) has a circuit board which is prone to failure. Primarily due to water getting behind the dash. This may be your issue with some of your gauges.

Since your hazards work, you may simply have a bunch of bad bulbs in your dash that need changing.

One last gauge you haven't mentioned - the tach. Is that working?

1996 White ZJ
1987 Maroon YJ (sideways build)
1996 Forest Green XJ

The "sideways" build thread: http://www.jeepforum.com/forum/f22/r...hread-2164793/
Rproject is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome