Test drove a WJ overland/ some issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Jeep Forums > Jeep Buying Forum > Test drove a WJ overland/ some issues

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Stainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 05-07-2014, 01:38 PM   #1
an3esh
Registered User
 
Join Date: May 2014
Location: Q-town, Dubai
Posts: 1
Test drove a WJ overland/ some issues

Hello guys, I'm new to jeeps and SUV's in general.
Ok so I test drove a wj overland and it had problems from the startup itself, it took about 5-7 seconds of cranking the first time I started it. After it finally fired up the rpm needle kept vibrating. It was not surging like up and down 1000rpms, but just vibrating up and down maybe 50-100rpms. It is also throwing the p0174 code. What could be the issue? I turned it off and then started again, this time it fired right up.
Also with the engine in neutral I can move the 4wd selector from 4hi to n. Then when I try to move from n to 4lo it's a bit difficult. Also when I move it to 4hi from n it crunches a little.
Another problem is when I put the transmission from n to d it takes about 1 second to engage. And when I go from d to n it makes a thump.
Are all these serious issues or can be fixed easily.

an3esh is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.