VT or ME Jeep Jamboree - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 03-05-2008, 05:20 PM Thread Starter
JeepinMass
Member
 
JeepinMass's Avatar
2008 JK Wrangler 
 
Join Date: Aug 2004
Location: Western Mass
Posts: 416
VT or ME Jeep Jamboree

Who went to these last year? I may have to work during the VT jambore but i'd like to get out to the ME one. Trail rating is 3-9 from what I was told. Any feedback?


--Ben--
74CJ5 and 08JK
JeepinMass is offline  
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Jeep Jamboree - Cullman, AL Jason D South East USA 13 06-15-2009 09:44 PM
Who wants the Jeep Jamboree to come to the PNW? BRICKTOP2 Washington Jeep Forum 43 05-15-2009 07:53 PM
2 more Jeep Jamboree Video JeepTales Great Lakes USA 3 10-20-2008 11:59 PM
OZ Jeep Jamboree poohead Mexico/International 0 05-24-2008 04:19 AM
Pa jeep jamboree wildchild North East USA 18 03-12-2008 06:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome