post #1 of Old 11-11-2001, 12:06 PM Thread Starter
TDanks76
Registered User
1979 CJ7 
 
Join Date: Nov 2001
Location: Grand rapids Mi
Posts: 220
transfer case lowering kit?

I'm looking at a 2.5 lift kit for my 95 yj. And I was wondering if you need a transfer case lowering kit for it. Also if you know of any good 2.5 lifts out there please let me know.


CJ 7, with the good stuff.
TDanks76 is offline  
post #2 of Old 11-11-2001, 04:54 PM
bob91yj
Registered User
 
Join Date: Oct 2001
Location: Santee, CA
Posts: 313
Springs and possibly shocks are all you really need for a 2.5" lift. You may want to move your brake lines under the frame, or get extended lines if you disconnect for off roading.
My Jeep had Skyjacker 2.5" Softrides on it when I bought it. They had sagged before I went SOA, and are really sagged now. Skyjackers warranty seems to pretty much suck too. They are some nice riding springs tho. I've heard that the Rancho 2.5" add-a-leaf (fuul length) is a decent option as well, and much cheaper.

Bob
91YJ Sahara, SOA, 4.88's, 35's, Locked
bob91yj is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transfer Case Lowering Kit Raider 19 Engines & Drivetrain 2 01-05-2008 02:57 AM
2?-speed with 305/70 16 . . . transfer case lowering kit 99wrangler4x4 Tires & Wheels 2 08-18-2007 12:00 AM
2" BB and auto transfer case lowering. MeGAMoE General Jeep & Off-Road Equipment 3 09-02-2006 04:28 PM
Do I Need Transfer Case Lowering Kit? darringj Tires & Wheels 0 03-13-2006 10:21 AM
t-case lowering kit? 93jeepyj2.5 Tires & Wheels 12 05-21-2002 07:50 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome