Zj ideling and hesitating problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 05-11-2011, 04:49 PM Thread Starter
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg
Posts: 79
Zj ideling and hesitating problems

I have a 1993 zj with a 4.0l and I've had the jeep for about a year and a half. Ever since I bought it , it has done this sputtering and hesitating. I've done alot of searching around the Internet about my problem and can't find what the problem. I cleaned my throttle body out perfecty and the problem got a little better but it's still not perfect. I don't know what else to do?! Help?!


..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-11-2011, 05:34 PM
melk
Registered User
1996 ZJ 
 
Join Date: Sep 2009
Location: Charlotte
Posts: 2,890
Seafoam the engine. $5

Plugs, wires, brass cap n rotor. $50
MSD Ignition Coil $50

NGK (not Bosch) O2 sensors $50
Hi-flow cat $90
melk is offline  
post #3 of 7 Old 05-11-2011, 05:58 PM Thread Starter
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg
Posts: 79
i did do seafoam and nothing worked. it has a new distributor i put in it. new wires. new plugs. but i havnt tried the O2 sensors. and i do not have a cat on it.

..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline  
post #4 of 7 Old 05-11-2011, 06:08 PM
TallyZJ
Registered User
1996 ZJ 
 
Join Date: Nov 2008
Location: Tallahassee
Posts: 1,140
Quote:
Originally Posted by nick93ZJ View Post
I have a 1993 zj with a 4.0l and I've had the jeep for about a year and a half. Ever since I bought it , it has done this sputtering and hesitating. I've done alot of searching around the Internet about my problem and can't find what the problem. I cleaned my throttle body out perfecty and the problem got a little better but it's still not perfect. I don't know what else to do?! Help?!
Does it always hesitate and sputter? Every time? Does it hesitate and sputter when its cold engine or hot engine?

Do you have a Check Engine Light on?

Have you ever had the fuel pressure checked?

Does it have shifting problems? Jerking or bucking as you accelerate?

Does it ever just shut off on you?

1996 Jeep Grand Cherokee Laredo 4x4 - 4.0L

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TallyZJ is offline  
post #5 of 7 Old 05-11-2011, 06:13 PM Thread Starter
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg
Posts: 79
Quote:
Originally Posted by TallyZJ View Post
Does it always hesitate and sputter? Every time? Does it hesitate and sputter when its cold engine or hot engine?

Do you have a Check Engine Light on?

Have you ever had the fuel pressure checked?

Does it have shifting problems? Jerking or bucking as you accelerate?

Does it ever just shut off on you?
every time yes

hot and cold

never checked the fuel pressure

check engine light not on

shifts fine

never shuts off

..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline  
post #6 of 7 Old 05-11-2011, 06:57 PM Thread Starter
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg
Posts: 79
[IMG][/IMG]

..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline  
post #7 of 7 Old 05-11-2011, 07:35 PM
no5son1962
Registered User
1995 ZJ 
 
Join Date: Aug 2010
Location: Colorado
Posts: 238
My 95 ZJ had a simular problem until I replaced the TPS. I removed the TPS and tested it. It had dead spots. Installed a new one and it ran great.

95 ZJ 4.0L 3 inch Lift
99 XJ 4.0L 4 inch Lift
no5son1962 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome