Zj ideling and hesitating problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Zj ideling and hesitating problems

Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiClayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank Skid

Reply
Unread 05-11-2011, 03:49 PM   #1
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg, Illinois
Posts: 78
Zj ideling and hesitating problems

I have a 1993 zj with a 4.0l and I've had the jeep for about a year and a half. Ever since I bought it , it has done this sputtering and hesitating. I've done alot of searching around the Internet about my problem and can't find what the problem. I cleaned my throttle body out perfecty and the problem got a little better but it's still not perfect. I don't know what else to do?! Help?!

__________________
..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline   Reply With Quote
Unread 05-11-2011, 04:34 PM   #2
melk
Registered User
1996 ZJ 
 
Join Date: Sep 2009
Location: Charlotte, NC
Posts: 2,891
Seafoam the engine. $5

Plugs, wires, brass cap n rotor. $50
MSD Ignition Coil $50

NGK (not Bosch) O2 sensors $50
Hi-flow cat $90
melk is offline   Reply With Quote
Unread 05-11-2011, 04:58 PM   #3
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg, Illinois
Posts: 78
i did do seafoam and nothing worked. it has a new distributor i put in it. new wires. new plugs. but i havnt tried the O2 sensors. and i do not have a cat on it.
__________________
..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline   Reply With Quote
Unread 05-11-2011, 05:08 PM   #4
TallyZJ
Registered User
1996 ZJ 
 
Join Date: Nov 2008
Location: Tallahassee, Florida
Posts: 1,140
Quote:
Originally Posted by nick93ZJ View Post
I have a 1993 zj with a 4.0l and I've had the jeep for about a year and a half. Ever since I bought it , it has done this sputtering and hesitating. I've done alot of searching around the Internet about my problem and can't find what the problem. I cleaned my throttle body out perfecty and the problem got a little better but it's still not perfect. I don't know what else to do?! Help?!
Does it always hesitate and sputter? Every time? Does it hesitate and sputter when its cold engine or hot engine?

Do you have a Check Engine Light on?

Have you ever had the fuel pressure checked?

Does it have shifting problems? Jerking or bucking as you accelerate?

Does it ever just shut off on you?
__________________
1996 Jeep Grand Cherokee Laredo 4x4 - 4.0L
Capital City Jeepers
Build Thread Here
TallyZJ is offline   Reply With Quote
Unread 05-11-2011, 05:13 PM   #5
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg, Illinois
Posts: 78
Quote:
Originally Posted by TallyZJ View Post
Does it always hesitate and sputter? Every time? Does it hesitate and sputter when its cold engine or hot engine?

Do you have a Check Engine Light on?

Have you ever had the fuel pressure checked?

Does it have shifting problems? Jerking or bucking as you accelerate?

Does it ever just shut off on you?
every time yes

hot and cold

never checked the fuel pressure

check engine light not on

shifts fine

never shuts off
__________________
..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline   Reply With Quote
Unread 05-11-2011, 05:57 PM   #6
nick93ZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Galesburg, Illinois
Posts: 78
[IMG][/IMG]
__________________
..,=====,o00o
//__l_l_,\____\,__
l_---\_l__l---[]lllllll[]
_(o)_)__(o)_)--o-)_)___
nick93ZJ is offline   Reply With Quote
Unread 05-11-2011, 06:35 PM   #7
no5son1962
Registered User
1995 ZJ 
 
Join Date: Aug 2010
Location: Colorado
Posts: 238
My 95 ZJ had a simular problem until I replaced the TPS. I removed the TPS and tested it. It had dead spots. Installed a new one and it ran great.
__________________
95 ZJ 4.0L 3 inch Lift
99 XJ 4.0L 4 inch Lift
no5son1962 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.