ZJ excitement on my way to work - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 11-05-2009, 08:43 AM Thread Starter
Thelt
Registered User
2005 KJ Liberty 
 
Join Date: Jan 2006
Location: Lenoir, NC
Posts: 604
ZJ excitement on my way to work

I was going along and heard and felt a thump under the Jeep. Then a smoke screen of steam came out from under it and trailed behind me down the road. It was like something from a James Bond movie. I pulled over and had it towed to the shop. I am hoping for a freeze plug but who knows. If you pour water in the radiator it pours back out somewhere near the back of the engine.

Thelt is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 11-05-2009, 10:23 AM
300grand
Registered User
1995 ZJ 
 
Join Date: Dec 2007
Location: Warren, MI
Posts: 82
What motor?

Tom
1995 ZJ, 4.0L, auto, 231, 3.73

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
300grand is offline  
post #3 of 7 Old 11-05-2009, 10:50 AM
JesseOR
Registered User
1993 ZJ 
 
Join Date: Oct 2009
Location: Eugene
Posts: 1,621
Sounds like a freeze plug. Or you blew a hole in the block! lol

-Jesse-
GO DUCKS!

www.facebook.com/jesse.whitehargrove
JesseOR is offline  
post #4 of 7 Old 11-05-2009, 01:19 PM Thread Starter
Thelt
Registered User
2005 KJ Liberty 
 
Join Date: Jan 2006
Location: Lenoir, NC
Posts: 604
It is the inline 6. It turned out to be a freeze plug. I do not think it did any damage to the motor. It put on a nice show when it did it though.
Thelt is offline  
post #5 of 7 Old 11-05-2009, 02:29 PM
Virmagicus
Moderator
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,440
Spyhunter FTW

Jeff







To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Virmagicus is offline  
post #6 of 7 Old 11-05-2009, 02:36 PM
JesseOR
Registered User
1993 ZJ 
 
Join Date: Oct 2009
Location: Eugene
Posts: 1,621
Hahaha!!! I miss spyhunter!

-Jesse-
GO DUCKS!

www.facebook.com/jesse.whitehargrove
JesseOR is offline  
post #7 of 7 Old 11-05-2009, 03:54 PM
solomon8718
Registered User
1998 ZJ 
 
Join Date: Sep 2009
Location: St. Paul, MN
Posts: 497
oh shenanigans
solomon8718 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
How do i work my 4x4 jeepunlimited ZJ Grand Cherokee Forum 20 12-18-2006 10:27 PM
95 ZJ Power Window issues... work.. don't work... slgunnel ZJ Grand Cherokee Forum 7 11-30-2006 05:05 PM
Will this BB work?? Sure Shot ZJ Grand Cherokee Forum 8 10-29-2006 07:05 PM
After work fun! Hondahemp ZJ Grand Cherokee Forum 17 10-27-2006 04:17 PM
My backup lights don't work or work intermittently. moabster ZJ Grand Cherokee Forum 0 12-23-2002 01:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome