ZJ Electrical issue/Engine surge? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > ZJ Electrical issue/Engine surge?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 07-28-2011, 02:04 AM   #1
source69er
Registered User
 
Join Date: Jun 2011
Location: Calgary, Alberta
Posts: 10
ZJ Electrical issue/Engine surge?

Hey guys, I have a 1996 Jeep Grand Cherokee and recently I've been having not one, but TWO problems with the ZJ. First off, when driving at night sometimes my dash lights (and shifter area lights) dim A LOT almost as if their shorting out or something, and then sometimes over bumps they turn back on. Quite a hassle since it's hard to see my speed! haha. My Blinker lights are 100% un-effected by this though? Also my headlights and aftermarket stereo deck are un-effected? Could it just be a loose wire somewhere? Any ideas where this wire could even be connected?
And the second issue is sometimes when I turn my car on and drive for ~10 seconds? (Just a guess, its fairly quick) my power in my ZJ almost like ... surges? The power just stays constant for ~2 seconds. I can add more gas and it just .. stays at the same rpm and speed. I havent checked what speed / rpm exactly, or if it even happens for the same speed/rpm every time. Its completely intermittent so its hard to recreate (unlike my Death Wobble thats slowly comming back. EXACTLY at 80KM/H and slowing down haha) Any ideas why my ZJ might be doing this? It does NOT happen every time I start it, or doesnt happen at lights / stopping. Only randomly after I start it and move like half a blockish..?
Thanks guys. Any ideas are always appreciated.

source69er is offline   Reply With Quote Quick reply to this message
Unread 07-28-2011, 04:06 AM   #2
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
1 headlight switch solder joints.
2. Probably the map sensor or tps.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 07-28-2011, 01:10 PM   #3
source69er
Registered User
 
Join Date: Jun 2011
Location: Calgary, Alberta
Posts: 10
Heh oh yeah? How hard is it to get to the joints? Would I have to take apart my entire dash to get behind the switch?
And oh? There has NOT been a CEL Or anything either. Im not sure if its even a "Surge", it just . . . stops accelerating and everything for roughly 2 seconds. then goes again. Absolutely no other problems?
But thanks for the response.
source69er is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.