ZJ 4.0 rebuild, Won't start, has spark, has fuel. - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 29 Old 02-14-2012, 01:29 AM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Okay so playing around with the distributor has had some effect; have tried the "textbook" 4 oclock, 430 and 5. At 5 it was a no run. Vehicle will run but very rough, and progressively gets worse. Header/down pipe became red hot as unburnt fuel burnt there.

Does anyone have a second idea?? Haha


1995 ZJ 370,000km
Jared_bc is offline  
Sponsored Links
Advertisement
 
post #17 of 29 Old 02-14-2012, 01:45 AM
TheHalfWit
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Alexandria
Posts: 695
Just a thought, I remember seeing someone having troubles after swapping their intake manifold. Is it possible that you didn't get the intake fully seated against the block? Because if that isn't seated that could be a contributing factor if not the cause.

Calm. C.

If a week goes by without needing to replace something, pinch me because I must be dreaming.
TheHalfWit is offline  
post #18 of 29 Old 02-14-2012, 03:20 AM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
SOLVED

Write up will be added shortly. Biggest mind ***k possible. Maybe with the info I have Someone can decifer....

1995 ZJ 370,000km
Jared_bc is offline  
post #19 of 29 Old 11-05-2012, 06:15 PM
sayerabner
Registered User
1996 ZJ 
 
Join Date: Oct 2012
Location: amherst
Posts: 24
I am having the same problems you are talking about. what did it end up being? I could not find a Write up.
sayerabner is offline  
post #20 of 29 Old 02-12-2013, 09:22 AM
DirtDodd
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Rome
Posts: 52
It's been a year, I don't think we're gonna get that write-up...
DirtDodd is offline  
post #21 of 29 Old 02-13-2013, 09:03 PM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Wow! Totally right, maybe i should follow through with a write up. To anyone who has wasyed there time waiting for this; I am sorry. So here is at least an answer while I writwwrite something up.

So after much frustration and many tantrums... Using the problem solving method of elemination it cme down to timing. The distributor had been set ever which way possible, following the jeep manual, than the jeep manual 'correct' version, than 2 otherways discribed by others online. Finally was able to get the jeep to start on the 5th postion but she ran VERY rough. At this moment I thought 'holy **** it runs so theres hope'. Judging by the muffler getting red hot I figured it was firing real late so I turned the dist cap the smallest increment possible and tried again. Once again fred up, still rough. Again rotated the cap and again still rough. So one last rotation and BAM! Fired up happy and healthy. Still baffled though over how it ran fine the very first night when I fired it up. Than all this crapp. Anyways glad its overwith... Motor has been great ever since.

1995 ZJ 370,000km
Jared_bc is offline  
post #22 of 29 Old 02-14-2013, 08:31 AM
DirtDodd
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Rome
Posts: 52
Thanks man! I wasn't trying to be a smart-a or anything, I just happened upon this older thread and thought it sounded really close to my issues. I'm trying to get a ZJ running I traded for, and I got it firing and pumping fuel, but it just pops and blurps in the exhaust when cranking it over, never really hitting or trying to crank, like it's way out of time...? I checked it at TDC on #1 compression stroke, and the rotor is sittin right on 5 o'clock like it's supposed to, so I'm kind of stumped where to turn to next, and I can't find much of anything on here regarding diagnosing a timing problem, because every thread says get it set at 5 o'clock and the computer sets the timing...

Can I ask what exactly you mean by 5th position, and how do you set it there? Pull the distributor, turn the motor some, and then put it back in?

Thanks! And glad to hear you've been running strong since!
DirtDodd is offline  
post #23 of 29 Old 02-16-2013, 01:11 PM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Hi there DirtDodd,

I am going to take some pictures of the dist cap this afternoon for reference as i have all the positions marked.

This problem does sound very similar (almost/possibly identical). Just as you've done (finding TDC and checking dist location) I too was only gettng pops in the exhaust. Now since I was getting fuel and spark it came down to timing. Many people told me it was the crank shaft position sensor, but I dont think you would get spark if this were so. Anyways so once i had TDC i checked its position (5o'clock or so) now from there the only real way to play with the timing is to pull the dist unit an manually rotate it. Now i had an issue where the cheapo after market dist had these little tabs that didnt allow much play or manual setting of it (the dist) but there was still enough to accomplish the task.

Sorry if this is hard to follow, i am typing on a very small smart phone.
Okay so you have fuel spark and TDC 1 compression stroke. Wont fire. Now pulling the dist unit out you can rotate clockwise or counter clock. One retards and one advances the t

1995 ZJ 370,000km
Jared_bc is offline  
post #24 of 29 Old 02-16-2013, 01:28 PM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Grrr.... Alright trying again. So basically it sounds like it is firing (sparking) way to late or way to early. So by rotating the dist you can advance or tard the timing. The reason you cant just rotate the crank shaft to locate/change the timing is cause the crankshaft sensor senses this movement and corrects the timing (beauty of computers...) so doing it by the dist os the only way.
Getting to the point. Try rotating the dist by 30mins or half an hour. In my case it was getting spark wayyyy to late so i advanced?? Haha cannot remember which way advancea or retard ..??? the dist so it would spark a little earlier. Thats when she fired up. Very roughly but it fired! So once again turned the dist 30mins and now o was firing even better. And so again i rotates the dist. Until it was no longer sparking so late but rather on time. Same issue can occur if your spark is to soon. ... It sparks than squirts fuel. The pops could be the spark igniting the fuel that was just exhausted into your exhaust.

Anyways one kinda all over the place with my writing here. So feel free to ask for clarification. I will try to add some pictures and use a real computer so i can put together sothing proper. Cheers,

1995 ZJ 370,000km
Jared_bc is offline  
post #25 of 29 Old 02-16-2013, 01:36 PM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Hmmm may also be worthy to note that smaller micro adjustments other than 1 hour or 1/2 hour adjustments maybe ness. Also am by no means a mechanic and yea. So cheers everyone and bear with me.

1995 ZJ 370,000km
Jared_bc is offline  
post #26 of 29 Old 02-16-2013, 08:06 PM Thread Starter
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake
Posts: 22
Okay so a quick correction on wording. The dist cap is fixed in position. So to play with the timing on your gc jeep you are actually removing your dist (whole unit) and rotating it one notch or gear tooth at a time. This is the only way i know of in which you can 'play' with the timing. Again it has been a year since this issue... But it does remain etched somwheres up there.

1995 ZJ 370,000km
Jared_bc is offline  
post #27 of 29 Old 02-16-2013, 10:20 PM
Pugulis
Registered User
1996 ZJ 
 
Join Date: Aug 2010
Location: Long Island
Posts: 1,190
Try starting a new thread, you'll get more responses.

[_][]☺[][][]☺[][_] 96' Grand Cherokee Laredo 265,000 miles and still going strong.
Pugulis is offline  
post #28 of 29 Old 02-18-2013, 09:53 AM
DirtDodd
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Rome
Posts: 52
Thanks for the info Jared! Very good details. My dad is a diesel mechanic of 30 years, so when he was over at the house last night he helped me take a better look at it. We double checked the timing and found it to actually be set on the exhaust stroke of #1! So we basically did what you said, pulled the distributor up just enough to spin it, put it back in, finally got it to start hitting, just a little early it seemed, so pulled it and turned it a little more, and it started up and ran great for several minutes! Working on someone elses mistakes are always fun...

Thanks again for the replies, even after a year! At least that shows the longevity of your fix
DirtDodd is offline  
post #29 of 29 Old 02-18-2013, 09:56 AM
DirtDodd
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Rome
Posts: 52
Quote:
Originally Posted by Pugulis View Post
Try starting a new thread, you'll get more responses.
Thanks for the advice, and you're absolutley right, but I already had another thread started from when I couldn't get it to fire, so I didn't want to be one of those guys that "shot-guns" a bunch of threads to try and get the most "help" when really they're just cluttering things up. It sounded like Jared had encountered a problem very close to mine, so I was just hoping to get his specific advice anyway.
DirtDodd is offline  
Reply

Tags
problems , won't start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Crank, Spark, Fuel?-NO START??? TurnerXJ ZJ Grand Cherokee Forum 53 02-09-2012 04:25 PM
5.2 no start..has fuel and spark straight-pipe ZJ Grand Cherokee Forum 12 12-29-2011 12:51 PM
ZJ no start has spark and fuel pressure greentank ZJ Grand Cherokee Forum 23 02-25-2011 08:30 PM
96 grand cherokee w/ good spark and fuel but won't start trh4989 ZJ Grand Cherokee Forum 7 02-14-2010 06:28 PM
Fuel pressure, spark, no start dirt machine ZJ Grand Cherokee Forum 23 02-24-2007 09:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome