XJ to ZJ - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 17 Old 04-02-2013, 09:30 PM Thread Starter
1950willysPU
Registered User
1950 J-Series Truck 
 
Join Date: Jun 2012
Location: Fargo
Posts: 64
XJ to ZJ

Hey, Just traded my crashed 90 XJ 4.0 laredo for a $400 95 5.2 ZJ laredo. Im new to the ZJ's so if I could get some help thatd be awesome. First off the main problem is the tranny, it only has first gear, no reverse no nothin, it has to be in neutral to start , has fluid, shifter feels loosely connected sort of and I'm not sure if the TV cable is properly adjusted. Next off, it has 285XXX miles, the engine seems to want to die when waiting at lights but no knocks or ticks. electric locks dont work and the doors dont seem to be in there straight. There also isnt power steering mainly because there isnt any fluid in the pump but im wondering what could cause the leak. Then theres a lot of oil in the airfilter. Help?



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My truck's thread yo
Current Jeeps:1949/50 Willys Truck 2.2 L
Past Jeeps: 1990 XJ Laredo 4.0, 1994 ZJ Limited V8, 1995 ZJ Laredo V8
1950willysPU is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 04-02-2013, 10:54 PM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
door lock actuators are probably shot. very common.

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
post #3 of 17 Old 04-02-2013, 11:01 PM
McCloudsZJ
Because RaceJeep
 
McCloudsZJ's Avatar
1998 ZJ 
 
Join Date: Sep 2011
Location: Roanoke
Posts: 2,729
Trannys shot, NSS is broken, TPS isn't working, plenum is leaking... And door lock actuators.

Sent from my iPhone 6 using JeepForum

March 2014 GCOTM. 1998 Deep Slate 5.9
On the Jeep:Hot intake, 52mm TB, Summit 8mm wires, catch can, 703s, insulated fuel rails, indexed Champions, Bilstein 4600s, Eibach lowering springs, Moog SS, Ironman mounts, Lotek 2GP, lots of gauges, sparkly paint.
In the garage: M1 4bbl
In the works: Addco/Hellwig sway bars, nitrous, full polly bushings, full exhaust, data logging, billet UD pulleys
McCloudsZJ is offline  
post #4 of 17 Old 04-02-2013, 11:11 PM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
probably be cheaper to find another ZJ with less problems. id part this one out

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
post #5 of 17 Old 04-02-2013, 11:17 PM
xcaliber81
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 3,926
would all the actuators have gone on it? might be gremlins.
xcaliber81 is offline  
post #6 of 17 Old 04-02-2013, 11:55 PM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
Quote:
Originally Posted by xcaliber81 View Post
would all the actuators have gone on it? might be gremlins.
all of mine were bad except the drivers door and the rear hatch.

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
post #7 of 17 Old 04-02-2013, 11:56 PM
misfit77
Registered User
1996 ZJ 
 
Join Date: Sep 2012
Location: tucson
Posts: 878
go to the junkyards...nearly everyone will have broken actuators or ebay fixes.
misfit77 is offline  
post #8 of 17 Old 04-03-2013, 12:12 AM
xcaliber81
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 3,926
Quote:
Originally Posted by dnuccio View Post
all of mine were bad except the drivers door and the rear hatch.
But the op is saying the electric locks arent working as in all of them arent working. Im thinking there might be something else up but I dont know.
xcaliber81 is offline  
post #9 of 17 Old 04-03-2013, 09:06 AM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
Could be. Sounds like his jeep has bigger problems than the power locks not working

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
post #10 of 17 Old 04-03-2013, 09:10 AM
xcaliber81
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 3,926
Quote:
Originally Posted by dnuccio View Post
Could be. Sounds like his jeep has bigger problems than the power locks not working
Yea I know.
xcaliber81 is offline  
post #11 of 17 Old 04-03-2013, 09:42 AM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
Quote:
Originally Posted by xcaliber81 View Post

But the op is saying the electric locks arent working as in all of them arent working. Im thinking there might be something else up but I dont know.
Sounds like the Driver Door Module is bad. Sisters Jeep needed that replaced, now all her windows and locks work. Brand new part was around $400, said the dealer...of course that's who did the work also.

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
post #12 of 17 Old 04-08-2013, 07:54 AM Thread Starter
1950willysPU
Registered User
1950 J-Series Truck 
 
Join Date: Jun 2012
Location: Fargo
Posts: 64
Alright i bought a 94 limited 5.2 yesterday, already has nice newish OME 1.5" lift and bout 100k miles less than the silver one but the prvious ower changed the injectors and they leaked causing a fire, the drivers side bank of the engines wiring harness is done as with all the vac lines and such. How easy would it be to swap the wiring from one jeep to another? Im parting the first one out so if yall need parts let me know.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My truck's thread yo
Current Jeeps:1949/50 Willys Truck 2.2 L
Past Jeeps: 1990 XJ Laredo 4.0, 1994 ZJ Limited V8, 1995 ZJ Laredo V8
1950willysPU is offline  
post #13 of 17 Old 04-08-2013, 09:43 AM
xcaliber81
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Prince George
Posts: 3,926
I can't see it being to hard. take lots of pics if you can.
xcaliber81 is offline  
post #14 of 17 Old 04-08-2013, 11:03 AM
Mickey_D
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: 40 3'42.36"N 112 2'16.73"W
Posts: 6,867
The wiring should be all the same. I would just take the entire engine bay harness from the firewall connector forward and swap it. Gonna be a PITA to get it all around everything, but the end result might be worth it.

You're going to notice something about the ZJ versus the XJ : It is far superior to the XJ in all aspects except turning radius. More interior room, more cargo room, more power, more comfort. I guess the XJ has a little more head room and it fits in a slightly smaller parking spot, but that's about it.

1997 ZJ 5.2 Orvis, Baby!
1953 Willys M100 trailer Tagalong
________________
[_][][][][][][][][_]



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
#4
Mickey_D is offline  
post #15 of 17 Old 04-09-2013, 07:51 AM Thread Starter
1950willysPU
Registered User
1950 J-Series Truck 
 
Join Date: Jun 2012
Location: Fargo
Posts: 64
I was trying to trace the harness back but i keep losing it, anyone know where it clips on the firewall?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My truck's thread yo
Current Jeeps:1949/50 Willys Truck 2.2 L
Past Jeeps: 1990 XJ Laredo 4.0, 1994 ZJ Limited V8, 1995 ZJ Laredo V8
1950willysPU is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome