WTF! i just changed spark plugs and now it idles really rough - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > WTF! i just changed spark plugs and now it idles really rough

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRubicon Express Suspensions from CCOR 706-207-4140Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 06-02-2009, 10:04 PM   #16
MEinSoCal
Registered User
2001 WJ 
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 1,410
okay another UPDATE:

i finally got around to replacing the TPS with a new one. i also left the battery disconnected for about an hour to clear previous settings. the jeep started up fine, idle seemed okay, but definitely a noticable lack of power AND what sounded like misfiring. i continued to take it for a test drive to let the engine warm up and get the speed up. after a while on the freeway, the CEL comes on -- P0302: misfire cylinder #2

also, keep in mind, i discovered a crack in my exhaust manifold/header, so yes i'm also dealing with an exhaust leak which is very loud

__________________
Meh...
MEinSoCal is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.