WTF!!! Everything was fine.. THEN - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 09-12-2012, 08:36 PM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
WTF!!! Everything was fine.. THEN

Jeep running decent, i go get some gas and come home to add a small clock to the spot my VIC was. So im done with the job and i start her up and now the piston slap or what ever is 5 times louder and i think its the start of a knock and the motor i running like *** and missing bad, like it loping up and down, then its fine then its bad, it drives fine and has all the same power but the piston slap is hideous when starting it up and it jeep is running rough as hell, sounds like crap. I'M so pissed of an angry. What is the deal!!! Sure the sound gets less when it warmed up but its whack when it first starts. This SUCKS! Nothing was done other than adding a clock. Yesterday i cleaned the throttle body and had to used blue RTV on the IAC body but after it cured it ran better than ever. Ran mint all day today to put 70 miles in her.

Then like i say, i came home parked it, put that clock in then ate dinner had a beer then this BS.. UGH!

1995 JZ 4.0 185K

MarsZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 09-12-2012, 09:03 PM
96zedjay
Registered User
1996 ZJ 
 
Join Date: Jun 2012
Location: Cincinnati
Posts: 423
Bad Gas?
96zedjay is offline  
post #3 of 17 Old 09-12-2012, 10:13 PM
errorcode3
Registered User
1998 ZJ 
 
Join Date: Nov 2010
Location: Hutch
Posts: 493
so are you saying that it was knocking prior to this whole incident? And then it suddenly got louder/worse after you filled up?
Yeah bad gas may cause problems, but if you had issues prior it was just a matter of time before it gets worse.

98 - Slate 5.niner. minor mods
02 - Silver Liberty (wives mall crawler)
errorcode3 is offline  
 
post #4 of 17 Old 09-12-2012, 10:25 PM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
It was more like piston slap and it gets less when it warms up, I don't know
Its crazy
MarsZJ is offline  
post #5 of 17 Old 09-13-2012, 01:00 AM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
One thing I should also add is since the new water pump and hoses, tstat and tstat housing the temp rarely guests above 1/4 of the way up since its been in the 50's at night here.
MarsZJ is offline  
post #6 of 17 Old 09-13-2012, 01:03 AM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
Heat works fine and oil pressure is 22 at idle and 40+ when driving
MarsZJ is offline  
post #7 of 17 Old 09-13-2012, 04:43 AM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,997
Knee jerk recommendation - Fuel treatment and 190* thermostat... installed correctly.

If it is actually piston slap you are hearing, nothing you can do without tearing into the engine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is offline  
post #8 of 17 Old 09-13-2012, 06:54 AM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
Quote:
Originally Posted by MarsZJ View Post
One thing I should also add is since the new water pump and hoses, tstat and tstat housing the temp rarely guests above 1/4 of the way up since its been in the 50's at night here.
You have a bad thermostat.

You also, "didn't have problems then suddenly, bam."
Piston slap is a problem, and will just all of a sudden go boom! Stop driving it and rebuild the motor before it throws a rod or scores the cylinder too badly.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ratmonkey is offline  
post #9 of 17 Old 09-13-2012, 10:20 AM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
Due to severe back injury a motor rebuild is out of the question. But one thing using a stethoscope I can say the sound comes from below the head but above the crank, its from I think the #3 or #4 piston its self so that bad. But it also is not 100% constant, for every 10 times it skips one, it gets less under load and goes almost silent after a long drive.
MarsZJ is offline  
post #10 of 17 Old 09-13-2012, 03:04 PM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
dupe post / sorry
MarsZJ is offline  
post #11 of 17 Old 09-13-2012, 03:06 PM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
MarsZJ is offline  
post #12 of 17 Old 09-13-2012, 03:11 PM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
sounds more like rod knock.

and your thermostat is either stuck open or your temp sender is bad.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ratmonkey is offline  
post #13 of 17 Old 09-13-2012, 03:47 PM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
The sound is much worse on the drivers side its like 70% more
MarsZJ is offline  
post #14 of 17 Old 09-14-2012, 10:41 AM Thread Starter
MarsZJ
Registered User
1995 ZJ 
 
Join Date: Aug 2012
Location: Long Island
Posts: 54
Anyone else?
MarsZJ is offline  
post #15 of 17 Old 09-14-2012, 06:16 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,997
Quote:
Originally Posted by MarsZJ View Post
Anyone else?
If you mean does anyone else think you'll ruin it if you keep driving it, yes i think so.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Warranty Fine Print diver110 WK Grand Cherokee & XK Commander Forum 5 03-14-2012 11:32 AM
97 zj slips between 1st and 2nd but when im in 4th and it kicks down to 3rd its fine? aforce ZJ Grand Cherokee Forum 3 03-04-2012 08:43 PM
Sounds like bad CV Joints, but they are fine. Shadowless127 ZJ Grand Cherokee Forum 0 12-24-2011 01:51 PM
help, cant fine thread/links xj 98/yj 94 ZJ Grand Cherokee Forum 2 10-22-2007 07:45 PM
Ok fine, call me gay.... SteelBlue_WJ ZJ Grand Cherokee Forum 45 05-20-2006 01:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome