WJ still overheating - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 25 Old 09-21-2009, 07:01 PM Thread Starter
G-Wagon00
Registered User
2000 WJ 
 
Join Date: Feb 2008
Location: Scottsville, Virginia
Posts: 236
WJ still overheating

I did all the steps that you guys had told me to try and it fixed it but not completely. I flushed the fluid, put a new thermostat in it, and put in a new fan relay switch. I still overheat though. Not badly just gets a little hot and will cool back down when i start moving again. It loses a little bit of fluid here and there and doesnt seem to be getting into the oil. Any thoughts on what it could be?


Looking for 04 Limited Grille, Tow Hooks for WJ(Rustys or OEM),.
nightcrew # 81
G-Wagon00 is offline  
Sponsored Links
Advertisement
 
post #2 of 25 Old 09-21-2009, 09:07 PM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by G-Wagon00 View Post
I did all the steps that you guys had told me to try and it fixed it but not completely. I flushed the fluid, put a new thermostat in it, and put in a new fan relay switch. I still overheat though. Not badly just gets a little hot and will cool back down when i start moving again. It loses a little bit of fluid here and there and doesnt seem to be getting into the oil. Any thoughts on what it could be?
how badly is badly? Stock 4.0L run 210 to 215 e-fan kicks on at 220

or could have air in the system.

mechanical fan clutch could also be bad.

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #3 of 25 Old 09-21-2009, 09:10 PM
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
have you pulled up the codes?
SwayzePDX89 is offline  
post #4 of 25 Old 09-21-2009, 09:19 PM
dougy147
Registered User
2007 JK Wrangler 
 
Join Date: Jan 2005
Posts: 652
Have you confirmed that the e-fan is working?

The Past
95 ZJ Laredo 4.0
00 WJ Laredo 4.0 & 4.7
08 WK Laredo 4.7 (traded for tin can)
The Present
07 JK Unlimited Sahara
dougy147 is offline  
post #5 of 25 Old 09-21-2009, 09:24 PM
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
If the fan is not working cause of relays.... and you wanna stop dealing with the pain of replacing fan relays 50 bucks a pop. I installed a switch and have step by step thread of how i did it. My jeep is free of any issues.
SwayzePDX89 is offline  
post #6 of 25 Old 09-21-2009, 09:25 PM
-cAcHe-
Registered User
 
-cAcHe-'s Avatar
1996 ZJ 
 
Join Date: Nov 2007
Location: Holtville CA,
Posts: 2,513
sounds like a fan issue...the highway air cools it down...so its pointing to the fan... maybe try and wire it up manually, thats how i have mine setup and its great.

www.desert-hooligans.webs.com


Quote:
Originally Posted by CarolinaWK View Post
I like happy endings :2thumbsup:
RIP Troy Edwards (bigbluezj94)
-cAcHe- is offline  
post #7 of 25 Old 09-21-2009, 11:32 PM
owenswj
Registered User
2000 TJ Wrangler 
 
Join Date: Dec 2008
Location: Mississippi
Posts: 165
Yeh, but if his fan is coming on it may not be pulling enough air through. Maybe install a mechanical fan/clutch combo. I know the electric fan here in Vegas doesn't work worth a crap when its 100+ outside.
owenswj is offline  
post #8 of 25 Old 09-22-2009, 05:24 AM
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,807
Could be a bad fan motor. I recently changed mine and took the old one apart. I had four brushes in the motor but one was worn down so much that it was not touching the stator. My fan would come on, but not spin fast enough to cool the engine.

Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline  
post #9 of 25 Old 09-22-2009, 07:18 AM
00RedWJ
Registered User
2006 WK 
 
Join Date: Dec 2007
Location: Long Island, NY
Posts: 524
Quote:
Originally Posted by michiganmaveric View Post
Could be a bad fan motor. I recently changed mine and took the old one apart. I had four brushes in the motor but one was worn down so much that it was not touching the stator. My fan would come on, but not spin fast enough to cool the engine.
I had the exact same problem. The fan was spinning but not fast enough to move air through the radiator and the car would overheat in traffic. Replaced the fan motor 2 years ago and the temp needle has never moved past dead center since. When the fan kicks on now you can feel the hot air being drawn through the radiator.

I believe these bad fan motors are drawing too much current and either frying the relays and burning up the plug that connects to the relay.

2000 Red Laredo WJ
4.0 with Selec-trac - Sold
2006 Black Laredo WK
3.7 with 95,000 Miles
00RedWJ is online now  
post #10 of 25 Old 09-22-2009, 07:30 AM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by 00RedWJ View Post
I had the exact same problem. The fan was spinning but not fast enough to move air through the radiator and the car would overheat in traffic. Replaced the fan motor 2 years ago and the temp needle has never moved past dead center since. When the fan kicks on now you can feel the hot air being drawn through the radiator.

I believe these bad fan motors are drawing too much current and either frying the relays and burning up the plug that connects to the relay.
i hate that i get of my jeep with the a/c onand get a 120F blast of hot air lol

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #11 of 25 Old 09-22-2009, 07:49 AM Thread Starter
G-Wagon00
Registered User
2000 WJ 
 
Join Date: Feb 2008
Location: Scottsville, Virginia
Posts: 236
It doesn't overheat all the time just everyonce and a while. Someone told me it was the head gasket or the heater core. Would that be a idea?

Looking for 04 Limited Grille, Tow Hooks for WJ(Rustys or OEM),.
nightcrew # 81
G-Wagon00 is offline  
post #12 of 25 Old 09-22-2009, 08:02 AM
00RedWJ
Registered User
2006 WK 
 
Join Date: Dec 2007
Location: Long Island, NY
Posts: 524
Quote:
Originally Posted by G-Wagon00 View Post
It doesn't overheat all the time just everyonce and a while. Someone told me it was the head gasket or the heater core. Would that be a idea?
Does it happen when you stop at a light? or sit idling in traffic?

2000 Red Laredo WJ
4.0 with Selec-trac - Sold
2006 Black Laredo WK
3.7 with 95,000 Miles
00RedWJ is online now  
post #13 of 25 Old 09-22-2009, 08:09 AM Thread Starter
G-Wagon00
Registered User
2000 WJ 
 
Join Date: Feb 2008
Location: Scottsville, Virginia
Posts: 236
No not usally. It hasn't done that since I replaced the fan relay switch

Looking for 04 Limited Grille, Tow Hooks for WJ(Rustys or OEM),.
nightcrew # 81
G-Wagon00 is offline  
post #14 of 25 Old 09-22-2009, 08:18 AM Thread Starter
G-Wagon00
Registered User
2000 WJ 
 
Join Date: Feb 2008
Location: Scottsville, Virginia
Posts: 236
No not usally. It hasn't done that since I replaced the fan relay switch

Looking for 04 Limited Grille, Tow Hooks for WJ(Rustys or OEM),.
nightcrew # 81
G-Wagon00 is offline  
post #15 of 25 Old 09-22-2009, 11:40 AM
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
Have we thought about pulling codes when it over heats yet? X2
SwayzePDX89 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
01 wj 4.0 overheating still!!! Nburns24 ZJ Grand Cherokee Forum 21 04-02-2009 11:35 AM
overheating dude979 ZJ Grand Cherokee Forum 7 03-20-2009 09:49 PM
Overheating ben98zj ZJ Grand Cherokee Forum 5 03-06-2009 02:05 PM
My wj is overheating. Forbidinworks ZJ Grand Cherokee Forum 5 03-02-2009 12:40 PM
Overheating JForestZ34 ZJ Grand Cherokee Forum 4 10-20-2005 05:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome