WJ Burning threw ELE-FAN RELAY'S!!! HELP! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 07-19-2009, 01:34 PM Thread Starter
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
WJ Burning threw ELE-FAN RELAY'S!!! HELP!

I have a 03 WJ and randomly my check engine light came on. Checked the codes "P1491" and said it was the electric fan relay So i replaced it...and engine light turned off and Fan turned on. Then 3 miles down the Road Engine light turns on...and Fan is not working. Someone please tell me whats going wrong here. THANKS!

SwayzePDX89 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 07-19-2009, 01:56 PM
MEinSoCal
Registered User
2001 WJ 
 
Join Date: Sep 2007
Location: Los Angeles
Posts: 1,515
MEinSoCal is offline  
post #3 of 10 Old 07-19-2009, 02:23 PM Thread Starter
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
Quote:
Originally Posted by MEinSoCal View Post
maybe you need a new fan as well
yeah i am Semi getting frusterated since the relays are a pricey 49.99 a pop. So i might take it back to the dealer and ask them to take a look at it. I was just curious if there is somthing i am doing wrong.
SwayzePDX89 is offline  
post #4 of 10 Old 07-19-2009, 02:59 PM
MEinSoCal
Registered User
2001 WJ 
 
Join Date: Sep 2007
Location: Los Angeles
Posts: 1,515
supposedly some have said that the placement and location of the fan relay is not ideal because it doesn't seem to get enough cooling, thus leading to lots of relay failures. i went through 3 in about year, until i completely replaced my fan with a custom fan using bosch relays in a better location
MEinSoCal is offline  
post #5 of 10 Old 07-19-2009, 05:19 PM Thread Starter
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
Quote:
Originally Posted by MEinSoCal View Post
supposedly some have said that the placement and location of the fan relay is not ideal because it doesn't seem to get enough cooling, thus leading to lots of relay failures. i went through 3 in about year, until i completely replaced my fan with a custom fan using bosch relays in a better location
Where did you Re-mount your relay.
SwayzePDX89 is offline  
post #6 of 10 Old 07-19-2009, 06:50 PM
MEinSoCal
Registered User
2001 WJ 
 
Join Date: Sep 2007
Location: Los Angeles
Posts: 1,515
Quote:
Originally Posted by SwayzePDX89 View Post
Where did you Re-mount your relay.
in the engine bay, up high on the firewall towards the passenger side. keep in mind, its not the same relay either. at least these relays are cheaper too!
MEinSoCal is offline  
post #7 of 10 Old 07-19-2009, 11:32 PM Thread Starter
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
Quote:
Originally Posted by MEinSoCal View Post
in the engine bay, up high on the firewall towards the passenger side. keep in mind, its not the same relay either. at least these relays are cheaper too!
Well i have only had the jeep for a 6 days and bought the car from a Toyota Dealership....you think i should take it back to the dealership and hassle them to fix it themselves or should i move on and start asking you what are the parts number for your fan and relays lol
SwayzePDX89 is offline  
post #8 of 10 Old 07-19-2009, 11:38 PM
the88thpianoman
Registered User
2003 WJ 
 
Join Date: Apr 2008
Location: Tampa
Posts: 5,251
Quote:
Originally Posted by SwayzePDX89 View Post
Well i have only had the jeep for a 6 days and bought the car from a Toyota Dealership....you think i should take it back to the dealership and hassle them to fix it themselves or should i move on and start asking you what are the parts number for your fan and relays lol
Dealership first. Raise hell and they'll probably fix it.

2003 WJ in Jeep Green Metallic, 4.0/242/4.10's. 4" Teraflex springs w/ RE monotube shocks and IRO short arms, cheap intake w/ amsoil filter, 2.5" hi flow cat and back exhaust, lots of lights and other misc crap.

Check out my build thread here: Life lessons and budget build
the88thpianoman is offline  
post #9 of 10 Old 07-20-2009, 12:09 AM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by the88thpianoman View Post
Dealership first. Raise hell and they'll probably fix it.
x2 i did that before i even found jeep forum my check engine light came on the day after i bought it NT went up there raised hell my power mirrors didnt work ethier i got those fixed free also

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
post #10 of 10 Old 07-20-2009, 12:22 AM Thread Starter
SwayzePDX89
Registered User
2003 WJ 
 
Join Date: Jul 2009
Location: Portland
Posts: 267
thanks guys...ill be up early tomorrow and put my game face on and see what i can do...ill let you guys know how it turns out...
SwayzePDX89 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
CEL....threw these codes... CaribouLouWJ ZJ Grand Cherokee Forum 3 03-30-2009 01:56 PM
Threw a code hike4it ZJ Grand Cherokee Forum 2 03-30-2009 01:38 PM
WJ Threw 5 codes- CKP or CMP? JayIV ZJ Grand Cherokee Forum 9 12-20-2008 08:03 AM
threw rod on 5.2? 2nd engine need help?!!! jeepinjarron94 ZJ Grand Cherokee Forum 5 12-05-2008 08:58 PM
Threw a rod! Inavacuum ZJ Grand Cherokee Forum 27 05-22-2008 10:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome