wiper help please - JeepForum.com
 
LinkBack Thread Tools
post #1 of 15 Old 03-08-2010, 08:47 PM Thread Starter
iggypimp
Registered User
2004 WJ 
 
Join Date: Feb 2008
Location: memphis
Posts: 34
wiper help please

about a month ago durring an ice storm i cranked up my wj and forgot that i had left the wipers in the on position. my wipers were froze to the window and then there was a brief dimming of all the lights in the jeep. i managed to get them unstuck but they would not work. 5-10 minutes later they came back on but will only work on low and high they will not return to the nest position.when set on intermittent they wind up all over the place. i have been searching but most info seems to be for zjs. any help would be nice.thanks

iggypimp is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 03-11-2010, 04:46 PM Thread Starter
iggypimp
Registered User
2004 WJ 
 
Join Date: Feb 2008
Location: memphis
Posts: 34
if someone could give me a hint it would be nice. is there an official thread for this topic?
iggypimp is offline  
post #3 of 15 Old 03-11-2010, 05:07 PM
gomes512
Registered User
1994 ZJ 
 
Join Date: Nov 2005
Location: Des Plaines, IL
Posts: 1,143
There is a thread for the rear wiper the front wiper I'm not so sure about.

When you say they are all over the place do you mean they stop at any location on the return trip? Never had the front wiper mechanism apart before but it sounds like some part of the drive system might have gotten busted up when the motor was trying to unstick the frozen wipers (dimming of lights).

I'm surprised a fuse didn't blow instead, I wonder if I can use the wipers to winch out my rig in a jam.
gomes512 is offline  
 
post #4 of 15 Old 03-11-2010, 05:15 PM Thread Starter
iggypimp
Registered User
2004 WJ 
 
Join Date: Feb 2008
Location: memphis
Posts: 34
they will work fine on low and high but not return to the nest position when turned off. when on intermittent they will go up and return about half way down and then stop in the middle of the windshield.
iggypimp is offline  
post #5 of 15 Old 03-11-2010, 05:32 PM
Wheelin98TJ
JEEP FREAK
 
Wheelin98TJ's Avatar
1998 TJ Wrangler 
 
Join Date: Apr 2004
Posts: 26,287
You probably need to replace the wiper motor.

I've never dealt with this in a WJ, but TJs have the same no-park symptom when the wiper motor starts to go out.
Wheelin98TJ is offline  
post #6 of 15 Old 03-12-2010, 10:21 AM
gomes512
Registered User
1994 ZJ 
 
Join Date: Nov 2005
Location: Des Plaines, IL
Posts: 1,143
Fortunately it appears that removing the wiper/linkage assembly isn't to bad of a job.

Involves removing the black cover by the hood and being sure to disconnect the plumbing and wiring.
gomes512 is offline  
post #7 of 15 Old 03-12-2010, 10:33 AM
volvite
Registered User
1999 WJ 
 
Join Date: Mar 2009
Location: Aviano Air Base
Posts: 1,939
I believe you messed up the gears in the wiper motor. Pull another from a junkyard and see if that helps you.
volvite is offline  
post #8 of 15 Old 03-12-2010, 06:35 PM Thread Starter
iggypimp
Registered User
2004 WJ 
 
Join Date: Feb 2008
Location: memphis
Posts: 34
i will try to replace the motor this weekend and let you guys know what happens.
iggypimp is offline  
post #9 of 15 Old 03-12-2010, 09:12 PM
GeorgeofGeorgia
Registered User
 
Join Date: Aug 2006
Location: Gainesville, GA
Posts: 6
You could check to see if the "park" wire is going hot when you shut off the wipers, if so, it's probably the motor.
GeorgeofGeorgia is offline  
post #10 of 15 Old 03-13-2010, 07:13 AM
fastfreddie
Registered User
 
Join Date: Dec 2007
Posts: 628
what are the chances of the wiper arms having slipped/spun on their shafts? isn't it a spline mount? maybe take 'em off and see if they're stripped?
fastfreddie is offline  
post #11 of 15 Old 03-19-2010, 10:25 PM
Optimus
Registered User
 
Join Date: Aug 2004
Posts: 16
So what did you ever find out? What was causing the possesed wipers?
Optimus is offline  
post #12 of 15 Old 03-19-2010, 10:29 PM
QuadraTokn
Registered User
 
QuadraTokn's Avatar
1930 WJ 
 
Join Date: Dec 2006
Location: Chicago, IL
Posts: 4,957
I've got a motor I can sell you.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


NEW Dana 44a Axle Truss and Skid !
WJ Grand Cherokee Tube Doors For Sale !
ZJ Grand Cherokee Tube Doors For Sale !
PARTS FOR SALE from 10 WJ Grand Cherokees ! !
QuadraTokn is offline  
post #13 of 15 Old 01-17-2011, 02:17 AM
CLNinja
Registered User
 
CLNinja's Avatar
1993 ZJ 
 
Join Date: Apr 2007
Location: Denver, CO
Posts: 6,977
i just started having this problem on my zj.. they work fine but will not park.. i havr to turn them off when the wipers get to the park spot for them to stop there

Matt


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

**September 2009 Grand Cherokee Of The Month**

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CLNinja is offline  
post #14 of 15 Old 01-17-2011, 05:26 AM
BlueDevil
Registered User
1995 ZJ 
 
Join Date: May 2006
Location: Croatia
Posts: 680
There's a post/thread here somewhere about ZJ and wiper control module that's located (93-95 ZJ, dunno about others) in the driver's left-hand side kick panel. It's a black box, that needs to be disconnected, opened, and there's one burned connection that needs to be resoldered. I did it in like 20 minutes, including disconnecting and reconnecting the box to the ZJ, soldering (and I don't know how to do it) and it works ever since.

Here, check the 1st post here, and then the link there is. That's all there is to it, at least in 93-94-95 ZJ:
http://www.jeepforum.com/forum/f13/z...ocated-990825/

Beauty is in the eye of the beer holder
* 1994 ZJ (by VIN) with a 1995 engine (PO knows why)
BlueDevil is offline  
post #15 of 15 Old 03-03-2017, 04:29 PM Thread Starter
iggypimp
Registered User
2004 WJ 
 
Join Date: Feb 2008
Location: memphis
Posts: 34
It turned out to be in the motor itself. Once i opened up the back of the wiper motor there were three metal prongs. I just bent them down so they would make contact with the metal surface on the disc inside. Works like new
iggypimp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Wiper ???'s j_dennis13 Grand Cherokee General Discussion 6 04-11-2010 05:21 PM
WJ Wiper Problem jbooth22 ZJ Grand Cherokee Forum 3 02-10-2009 02:25 PM
Wiper Fix Dillonzj ZJ Grand Cherokee Forum 17 02-02-2008 12:29 PM
Wiper will not go down by itself mz3bo ZJ Grand Cherokee Forum 3 09-14-2007 10:36 AM
rear wiper jeep1212 ZJ Grand Cherokee Forum 13 02-12-2005 12:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome