Windows don't work, doesn't turn over. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Windows don't work, doesn't turn over.

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 04-20-2013, 01:27 PM   #1
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
Windows don't work, doesn't turn over.

My friend is struggling with her 97 4.0L ZJ Laredo. The windows don't go up or down and every time she goes to start it, literally nothing happens. No gauges, doesn't even turn over. I fiddled around with the BCM (09AE) and everything clicked back on and I started it right up, then while running, everything went dead again. I swapped out four different BCM and not a single one worked. I picked up another 09AE from the bone yard and that had no results. For ****s and giggles I tried two different 09AF modules and obviously, nothing. I then lastly tried the 09AE from my 98 ZJ and even still got no results in hers. Both her factory BCM and the 09AE I have started my Jeep, but it then kicked off, probably because of my alarm system, I'm guessing. (Hers has no alarm system)

So, with all this I'm lead to believe it isn't her BCM but maybe a wire shorted or the plug? Anything else it could be?

Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2013, 02:16 PM   #2
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
Anybody?
Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2013, 03:55 PM   #3
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Clean/tighten battery both cable connections on BOTH ends. Make sure grounds are clean/tight.

How old is battery? Had it tested?
KoreaZJ is offline   Reply With Quote Quick reply to this message
Unread 04-20-2013, 05:22 PM   #4
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
I cleaned the terminals and checked the ground. I get power to everything but the radio, windows and gauges. It just doesn't turn over... Nothing happens when I turn the key.
Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2013, 11:02 PM   #5
jabba974
Registered User
1996 ZJ 
 
Join Date: Mar 2013
Location: Ionia, MI
Posts: 246
Have you tried the ignition switch?
jabba974 is offline   Reply With Quote Quick reply to this message
Unread 04-21-2013, 09:07 AM   #6
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
Quote:
Originally Posted by jabba974 View Post
Have you tried the ignition switch?
Would that really prevent the gauges, windows and radio from working? Could it be a relay under the hood?
Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-22-2013, 06:12 AM   #7
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
Anybody?
Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-22-2013, 06:13 AM   #8
Shane7
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Lakewood, Ohio
Posts: 72
Quote:
Originally Posted by jabba974 View Post
Have you tried the ignition switch?
I'm going to try it today I think... won't I need a matching key for it? I'm new to this stuff..
Shane7 is offline   Reply With Quote Quick reply to this message
Unread 04-24-2013, 08:19 PM   #9
jabba974
Registered User
1996 ZJ 
 
Join Date: Mar 2013
Location: Ionia, MI
Posts: 246
I believe the ignition switch is sperate from the key/lock tumbler....you'll need a set of tamper resistant torx bits to take it out... It could affect the other electronics from working if power isnt supplied to the accesories...and it should be cheap enough to replace.. Good luck!
jabba974 is offline   Reply With Quote Quick reply to this message
Unread 06-24-2013, 02:02 PM   #10
zjsean
Registered User
1996 ZJ 
 
Join Date: Mar 2009
Location: Port Deposit, MD
Posts: 88
Just had the same problem. Don't know if you figured out your problem yet. But, to make a long story short, I found frayed wires in the dash. Had to take the entire dash pad out to find it. The wires run down from the radio and out underneath the passanger air bag. There were about 5 wires that were frayed and fried together were they run out of the dash.
zjsean is offline   Reply With Quote Quick reply to this message
Unread 06-24-2013, 02:18 PM   #11
ZJNewbi3
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Milwaukee, Wisconsin
Posts: 785
Did you check all relays and fuses?
ZJNewbi3 is offline   Reply With Quote Quick reply to this message
Unread 01-16-2014, 09:42 PM   #12
DawnC
Registered User
1997  
 
Join Date: Jan 2014
Location: Nyssa, Oregon
Posts: 5
Quote:
Originally Posted by zjsean
Just had the same problem. Don't know if you figured out your problem yet. But, to make a long story short, I found frayed wires in the dash. Had to take the entire dash pad out to find it. The wires run down from the radio and out underneath the passanger air bag. There were about 5 wires that were frayed and fried together were they run out of the dash.
I also found 5 wires behind glove compartment that were frayed on 97 laredo.
DawnC is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.