Why has my gas mileage dropped so much since my intake plenum fix ? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Why has my gas mileage dropped so much since my intake plenum fix ?

Dan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 05-24-2013, 05:52 AM   #1
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Why has my gas mileage dropped so much since my intake plenum fix ?

So why my gas mileage is so bad... Like I litterally can barely push 10mpg.... My overhead use to be soo easy to get 12-13mpg.. like easy easy.. Now i can barely push past 9.9mpg.. Its terrible... I also checked with the fill it up completetly method.. then drive and fill up and divide that by miles driven... and i was getting 10.6mpg.. I drove only 114 miles on HALF A TANK.. thats bad because from full to half is around 13-14 gallons and half to empty is 8-10 gallons.. Since I filled it up a few days ago i have driven only 60 miles and my gas tank has already used a quarter of a tank.. I can only drive 200 miles or so in the city on a tank now.. Something isnt right... I should be getting around 300 miles.. Not 200

Im not burning coolant, the level hasnt dropped in 700 miles, and my oil level has stayed the same as well hasnt dropped one bit... I did switch from Castrol GTX conventional oil to Valvoline Max Life synthetic blend... Could the oil switch be causing the gas mileage drop ? I doubt it.... Was burning oil actually giving me good gas mileage lol ?? Uhg I dont understand..... Or maybe I have leaky injectors now ? I did get brake cleaner on them when cleaning the intake manifold with the injectors still on it.. I doubt thats the reason... Or could it be ?? I dunno... Im just telling you guys something isnt right.... I have never gotten 9-10mpg on this Jeep in the 3 years I have owned it..

Its deff running so much better, more power, tailpipe is clean as a whistle now.. Usually after 700 miles i have already burned a quarter of a quart of oil.. My oil level is still right on the max line of the dipstick.. or slightly above it actually.. so im confused..

__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-24-2013, 06:04 AM   #2
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken, SC
Posts: 1,700
I average 10 in the city with my stock 5.2L since my Plenum fix.....but I do have 6 slightly leaking injectors.

I'm literally in the same boat with the 200miles a tank. If I run it on the interstate, I'll push 360miles to a tank.
__________________
94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is online now   Reply With Quote
Unread 05-24-2013, 06:28 AM   #3
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
I also noticed when I park.. if i get in the Jeep the next day the gas in the tank isnt on the same mark i had it prior... its almost like something is leaking.. I dont remember it doing this before either
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-24-2013, 06:37 AM   #4
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken, SC
Posts: 1,700
Quote:
Originally Posted by Candymancan View Post
I also noticed when I park.. if i get in the Jeep the next day the gas in the tank isnt on the same mark i had it prior... its almost like something is leaking.. I dont remember it doing this before either
All I see is that it drinks gas wayy too much.
__________________
94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is online now   Reply With Quote
Unread 05-24-2013, 07:23 AM   #5
a70eliminator
Registered User
 
Join Date: Dec 2004
Location: Kent Ohio
Posts: 864
200 mi to a tank is right on with what I'm getting mix between city and rural.
I noticed the last tank went really fast only because I was charging my ac compressor along with some other troubleshooting that required the engine running all at 0 mpg!
a70eliminator is offline   Reply With Quote
Unread 05-24-2013, 08:40 AM   #6
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral, FLORIDA
Posts: 1,050
Definitely seems like something's out of whack. I'm almost completely stock and getting just under 13, mostly city driving.
zj97ltd is offline   Reply With Quote
Unread 05-24-2013, 08:46 AM   #7
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
i know there are going to be people saying its a 5.9 what do you expect... but liek is aid right after i did this plenum fix my gas mileage dropped alot
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-24-2013, 11:01 AM   #8
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,810
Mine increased so check the injectors. I popped mine out still attached to the fuel rail the other day to check for leakers. I had my wife cycle the key to prime the pump to see if any leaked. I also put a long wooden dowel on each injector while it was running to listen to them.

How are your 02 sensors and cat?
PolkaPower is online now   Reply With Quote
Unread 05-24-2013, 01:02 PM   #9
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,324
Quote:
Originally Posted by PolkaPower View Post
Mine increased so check the injectors. I popped mine out still attached to the fuel rail the other day to check for leakers. I had my wife cycle the key to prime the pump to see if any leaked. I also put a long wooden dowel on each injector while it was running to listen to them.

How are your 02 sensors and cat?
x2

When I did my '703 swap, I tested all the injectors this way. You can also do quick and dirty leak down test by putting some paper towels under the injectors and let them sit for about an hour. If you come out and can see gas stains or smell it on the towels then you have an injector dripping.

I had one injector that was completely stuck open and would drain the fuel rail in about 90 seconds

Between the plenum fix and the '703 injectors, I've picked up about 2 MPG running around town, done by hand, and yes I fill up at the same gas pump everytime as well.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote
Unread 05-24-2013, 02:02 PM   #10
tirus89
Registered User
1993 ZJ 
 
Join Date: Sep 2007
Location: Boise, Idaho
Posts: 1,219
I get roughly 300 miles to a tank in mine. With a BB and 31 Cooper's AND the plenum fix. Seems something is outta wack...
__________________
Im a college graduate and employed and have a Haynes.

//93 ZJ//5.2L//NP249//K&N Fipk Gen II//2" BB w/BD AT Shocks//4.10's//31" Cooper Discovery STT's//Cstm Frnt Bmpr//Custom Rear Tube Bmpr//3" Magnaflow exhaust w/high flow cat//500RMS Pioneer Amp//600RMS 12" JL Audio Sub//
tirus89 is offline   Reply With Quote
Unread 05-24-2013, 02:55 PM   #11
9859limited
Registered User
1998 ZJ 
 
Join Date: May 2011
Location: Woburn, Ma
Posts: 209
After my plenum fix I've gotten better mileage. (Provided I can keep the foot out of the gas cuz how she runs.)
9859limited is offline   Reply With Quote
Unread 05-27-2013, 01:15 PM   #12
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Anyone have any idea's my gas mileage seems to be getting worse its now at like 9mpg..
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 05-27-2013, 01:39 PM   #13
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 309
Quote:
Originally Posted by Candymancan View Post
I also noticed when I park.. if i get in the Jeep the next day the gas in the tank isnt on the same mark i had it prior... its almost like something is leaking.. I dont remember it doing this before either

Bad gas cap causing fuel to evaporate?
StPaul59 is offline   Reply With Quote
Unread 05-27-2013, 02:06 PM   #14
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 309
That hole in your evap line wont help either.
StPaul59 is offline   Reply With Quote
Unread 05-27-2013, 07:35 PM   #15
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Yea I fixed that put a new hose on it, but that wasnt the issue.. as it was getting good gas mileage before the plenum fix.. then right after its getting bad gas mileage.. I disconnected my oil catch can on the pcv im wondering if that is causing it.. Gonna reset the PCM and see
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.