Whirling sound coming from front end - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 07-15-2013, 08:49 AM Thread Starter
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee
Posts: 763
Whirling sound coming from front end

Hey guys...for awhile now, I have had a "whirling" sound (best description) coming from my front end. It gets a bit more pronounced when accelerating.
I believe it started when I got my General Grabber's put on, but just not all that positive.
Any idea what is causing this? Anything I can check?
Thanks SO much for the help.


2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-15-2013, 10:17 AM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
I wouldn't be surprised if it was a hub bearing.
zj97ltd is offline  
post #3 of 6 Old 07-15-2013, 10:53 AM Thread Starter
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee
Posts: 763
Quote:
Originally Posted by zj97ltd View Post
I wouldn't be surprised if it was a hub bearing.
Thanks...can I check a hub bearing out to see if that's the case?

2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline  
post #4 of 6 Old 07-15-2013, 11:06 AM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
You can jack up the front end and see if you can wiggle the wheels. But when mine went bad there was no play in them, just a grinding sound that got louder the faster I went.
zj97ltd is offline  
post #5 of 6 Old 07-15-2013, 12:34 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,092
Hub bearing or power steering pump is where I'd look first.

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
post #6 of 6 Old 07-15-2013, 07:25 PM
Kevinyj95
Registered User
1995 ZJ 
 
Join Date: Jun 2012
Location: Presque Isle
Posts: 756
This couldn't just be the new tread on the road could it? Beefy tires have a nice hum to them. Is this your first time with the generic brand of bfgs?
Kevinyj95 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome