when starting engine...... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 10-05-2003, 04:52 PM Thread Starter
pygocentrus
Registered User
 
Join Date: Aug 2003
Posts: 220
when starting engine......

when i start my engine in the morning, i hear water rushing somewhere, what the hell is it? my carpets are dry

pygocentrus is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-06-2003, 01:17 AM
whitevette
Registered User
 
whitevette's Avatar
 
Join Date: Jul 2003
Location: Phoenix, AZ
Posts: 268
Coolant running through your heater core.

Darkness is deaths ignorance, and the Devils time.
'96 Grand Cherokee Laredo
'93 Taurus SHO
'77 Corvette L-48
'74 Land Cruiser FJ40
whitevette is offline  
post #3 of 5 Old 10-06-2003, 09:55 AM Thread Starter
pygocentrus
Registered User
 
Join Date: Aug 2003
Posts: 220
is that normal? is that bad?

98 GC limited 5.2 4x4

mods: 3 chamber magnaflow

upcoming mods: throttle body, intake, and headers, 3" lift, tires, and system (if I can save enough $)
pygocentrus is offline  
post #4 of 5 Old 10-06-2003, 02:12 PM
Harald
Registered User
 
Join Date: Aug 2003
Posts: 133
Quote:
Originally Posted by pygocentrus
when i start my engine in the morning, i hear water rushing somewhere, what the hell is it? my carpets are dry
Or refridgerant running through the cooling core. I don't hear anything in my Jeep, but I have a similar sound on my Ford. Check if you have air in engine cooling liquid.
Harald is offline  
post #5 of 5 Old 10-06-2003, 02:21 PM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,320
Check the things listed above and you aren't hurting anything.


Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.366
Texas ZJ1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Engine Starting Problems Airbird ZJ Grand Cherokee Forum 1 05-12-2009 07:10 AM
Engine starting problems. PurpleSplat ZJ Grand Cherokee Forum 4 10-18-2008 12:32 AM
Engine starting ats1968 ZJ Grand Cherokee Forum 5 10-05-2005 09:17 AM
97 GC 4.0 Engine Stumble After Starting mtnrunner ZJ Grand Cherokee Forum 5 07-29-2005 01:58 PM
Problem starting engine lvl2pimp WJ Grand Cherokee Forum 5 12-10-2001 03:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome