What have you broken on your ZJ - Page 4 - JeepForum.com

LinkBack Thread Tools
post #46 of 46 Old 07-15-2013, 12:45 PM
Registered User
1998 ZJ 
Join Date: Jun 2013
Posts: 103
Originally Posted by mrclark25 View Post

my story is quite a bit different... the door has saged since i got the jeep, and i never did anything about it. because of that, i slammed it one day and the bolts holding the latching mechanism to the inside of the door pulled through the door.

it was an interesting 6 mile drive back home.

picture shows how i fixed it.
Nice. My original drivers door had something like what the pic shows but instead of plates of steel, the guy used big washers on the bolts. The bolts would start to come out randomly too. My Junk Yard door is perfect though, It was the only one there so I got really lucky. 96 Laredo door on a 98 Limited,lol. Im also lucky that all of the panel switches were the same. I kept the orignal panel and put it on the 96 door.

Area11 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome