What did you do to your ZJ today? - Page 671 - JeepForum.com

 102Likes
 
LinkBack Thread Tools
post #10051 of 44879 Old 04-04-2012, 08:03 AM
psychwarfare
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: pine hill
Posts: 25
Well yesterday the Jeep was left at the local Wawa after I came out from inside to see it spewing oil right below the engine...only happens while running and appears to be related to the oil filter adapter considering I see no fresh oil above the filter and see plenty on the underside of the filter and further down...looks like it is dripping down to the bell housing and then the ground...couldn't get a good look as I was dressed for work...

It is leaking at nearly a stream pace...so that's concerning...

I'll get a few quarts of oil in her tonight and drive her around the corner to a residential area that I can work on her in...

psychwarfare is offline  
Sponsored Links
Advertisement
 
post #10052 of 44879 Old 04-04-2012, 11:06 AM
csouers
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2008
Location: Bloomington
Posts: 2,031
Quote:
Originally Posted by psychwarfare View Post
Well yesterday the Jeep was left at the local Wawa after I came out from inside to see it spewing oil right below the engine...only happens while running and appears to be related to the oil filter adapter considering I see no fresh oil above the filter and see plenty on the underside of the filter and further down...looks like it is dripping down to the bell housing and then the ground...couldn't get a good look as I was dressed for work...

It is leaking at nearly a stream pace...so that's concerning...

I'll get a few quarts of oil in her tonight and drive her around the corner to a residential area that I can work on her in...
If you just changed the oil, the old filter oring could still on the adapter. Also, the adapter seals could be bad which is likely what it is. Pretty simple thing to fix, just messy.

1998 Bright Platinum ZJ 5.9 Limited - 5.9l, 46RE, NV-242, D30/44a (Trac-Loc) w/3.73s - The DD
1999 White XJ Sport - 4.0l, AW4, NP-231, D30/8.25 w/3.55s - The Rig

My Photography
csouers is offline  
post #10053 of 44879 Old 04-04-2012, 11:39 AM
gabrod72
Registered User
1993 ZJ 
 
Join Date: Jan 2007
Location: Austin
Posts: 1,395
Quote:
Originally Posted by csouers View Post
If you just changed the oil, the old filter oring could still on the adapter. Also, the adapter seals could be bad which is likely what it is. Pretty simple thing to fix, just messy.
Agreed on this being messy, and I ended up having to use a pipe wrench on the stupid adapter bolt to get it loose. Clean everything with brake parts cleaner to see that the bolt head has a large ring on it that you can grab onto without grabbing the adapter itself. The o-ring kit is around $5 at the dealership... I still have some oil leaking from the pan bolt and possible rear main seal, but at least it's much more manageable now that I replaced the O-rings in the adapter.

Lookey here:
http://www.lunghd.com/Tech_Articles/...nt_O-Rings.htm
gabrod72 is offline  
post #10054 of 44879 Old 04-04-2012, 12:47 PM
psychwarfare
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: pine hill
Posts: 25
Thank you much for the heads-up and pointers...I'll post back once I resolve the issue...
psychwarfare is offline  
post #10055 of 44879 Old 04-04-2012, 02:18 PM
roughknight69
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Jamestown ny
Posts: 1,904
Replaced my front drivers side wheel bearing today. Was so simple and easy compared to alot of other people, who have trouble with it. The axle nut came loose an the first try, then used the bolt trick to pop the bearing itself off.


Edit: also my illumination relay in the glove box is buzzing, is there any other relays similar to this one? So I can swap them to see if it's the relay?
roughknight69 is offline  
post #10056 of 44879 Old 04-04-2012, 02:43 PM
ZJMTL
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Montreal
Posts: 1,251
New trans fluid, removed plastic bumper and painted the metal one black, as well as the rad support.
ZJMTL is offline  
post #10057 of 44879 Old 04-04-2012, 02:44 PM
gabrod72
Registered User
1993 ZJ 
 
Join Date: Jan 2007
Location: Austin
Posts: 1,395
Quote:
Originally Posted by roughknight69 View Post
Replaced my front drivers side wheel bearing today. Was so simple and easy compared to alot of other people, who have trouble with it. The axle nut came loose an the first try, then used the bolt trick to pop the bearing itself off.


Edit: also my illumination relay in the glove box is buzzing, is there any other relays similar to this one? So I can swap them to see if it's the relay?
Did you follow up with a little anti seize for the next time you need to get in there? I did that and it makes getting them back off a breeze.
gabrod72 is offline  
post #10058 of 44879 Old 04-04-2012, 02:55 PM
roughknight69
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Jamestown ny
Posts: 1,904
Quote:
Originally Posted by gabrod72 View Post
Did you follow up with a little anti seize for the next time you need to get in there? I did that and it makes getting them back off a breeze.

Of Course!

Lathered it on everything I could lol

Hopefully after a few winters, if it needs replaced it will come out just as easy.

(I can hope can't I?)
roughknight69 is offline  
post #10059 of 44879 Old 04-04-2012, 02:58 PM
roughknight69
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Jamestown ny
Posts: 1,904
I also went with moog instead of timken this time. Due to being able to get the moog for $66 front advance auto
roughknight69 is offline  
post #10060 of 44879 Old 04-04-2012, 02:58 PM
ZJMTL
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Montreal
Posts: 1,251
Pic of my front bumper
ZJMTL is offline  
post #10061 of 44879 Old 04-04-2012, 03:04 PM
roughknight69
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Jamestown ny
Posts: 1,904
Quote:
Originally Posted by ZJMTL View Post
Pic of my front bumper
I like it

any close up pics?
roughknight69 is offline  
post #10062 of 44879 Old 04-04-2012, 03:08 PM
ZJMTL
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Montreal
Posts: 1,251
Quote:
Originally Posted by roughknight69 View Post
I like it

any close up pics?
Will take some good pics with a real camera soon, for now it's in the garage drying
ZJMTL is offline  
post #10063 of 44879 Old 04-04-2012, 03:21 PM
pincheburro956
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Brownsville
Posts: 997
Made some rear upppers with some 1" square tubing and some IRO bushing housings. Now my rear pinion angle is good, no more vibes and no more clunks from the old busted bushing..


"Not a single **** shall be given."

99 WJ, 2" BB, 245/75/16 Falken Rocky Mountain ATS.
pincheburro956 is offline  
post #10064 of 44879 Old 04-04-2012, 04:06 PM
xxxxxxxxranger_1999
Guest
1998 ZJ 
 
Join Date: Mar 2011
Location: Forest City
Posts: 515
Found some more out about my camber being off...apparently they make offset balljoints? And those may resolve the problem ..as well needing to bend my draglink to clear the sway bar mounts..jeez jeep fund is available ..lol
Spending a lot here lately ...

Wondering what this pop is i keep hearing? Now wondering if the stock steering has to go..i will probably go with a beefier tie rod and ends, instead of OTK. I hear some bad things about it and reaming out an already thin ream seems outa the question.
xxxxxxxxranger_1999 is offline  
post #10065 of 44879 Old 04-04-2012, 04:29 PM
Dyn0mitemat
Registered User
1998 ZJ 
 
Join Date: Dec 2010
Location: BC
Posts: 1,307
Picked up some big boy tires
35/12.5/15 Goodyear MTR Kevlars

Should be a nice upgrade




Headed upto Summit racing either tomorrow or this weekend to pick up a set of soft 8 or d-window wheels for them

09 Rubi 2dr:MetalCloak2.5", 37"MTZ's/Slabs, EVO Stff, ORFab Cage, Chromo's, Driveshafts etc
Dyn0mitemat is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 40 08-12-2016 07:36 AM
Let me tell you what I did not do today husker_zj ZJ Grand Cherokee Forum 9 03-19-2013 01:09 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM
Have you had your V-8 today?? Myrtle Beach ZJ Grand Cherokee Forum 12 04-30-2005 01:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome