What did you do to your ZJ today? - Page 538 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > What did you do to your ZJ today?

XJ Rail Sale!The Ruffstuff NOT Universal 4 Link Kit!Vanco Big Brake Kit Promotion!

Reply
Unread 02-08-2012, 03:15 AM   #8056
AzPinstriped
Junior Member
 
AzPinstriped's Avatar
1994 ZJ 
 
Join Date: May 2010
Location: Orange County, CA
Posts: 10
1)
running like crap on way home from groceries. Failed to start following morning. Cranked and cranked...no codes. Can hear pump run on key turn. Stuck my fingernail in the shrader valve on the fuel rail and had 0 pressure. dropped the tank and confirmed 2nd fuel pump fail in a year. Pump had rotation, but did not make pressure even when immersed. Autozone replaced pump under warranty.
Pump replaced.

2)completely emptied gas tank, and taped a broom handle to a johnny mop. Poured in a mix of hot water and simple green and ******d the tank. Tank was terrible. I found a use for wife's blow dryer.
tank cleaned

3) while i was at it, I bought a Ford inline external (part e2000) pump as an emergency spare.
got a spare pump

4) I cut an access hole in the rear deck for the sender/pump. I was lucky to be near empty this time.. I will make a hatch out of some clear treated plexi.

AzPinstriped is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 12:00 PM   #8057
Uniblurb
Web Wheeler
 
Uniblurb's Avatar
1996 ZJ 
 
Join Date: Jan 2012
Location: Central, Ohio
Posts: 3,833
Quote:
Originally Posted by AzPinstriped View Post
1)
running like crap on way home from groceries. Failed to start following morning. Cranked and cranked...no codes. Can hear pump run on key turn. Stuck my fingernail in the shrader valve on the fuel rail and had 0 pressure. dropped the tank and confirmed 2nd fuel pump fail in a year. Pump had rotation, but did not make pressure even when immersed. Autozone replaced pump under warranty.
Pump replaced.

2)completely emptied gas tank, and taped a broom handle to a johnny mop. Poured in a mix of hot water and simple green and ******d the tank. Tank was terrible. I found a use for wife's blow dryer.
tank cleaned

3) while i was at it, I bought a Ford inline external (part e2000) pump as an emergency spare.
got a spare pump

4) I cut an access hole in the rear deck for the sender/pump. I was lucky to be near empty this time.. I will make a hatch out of some clear treated plexi.
Interesting work-around installing an additional fuel pump and good idea.

I've had a couple fuel pump type problems with my 96 ZJ w/192,000 miles but haven't had to replace it yet. Fuel gauge quit working and found out the sensor is part of the pump and the whole unit needs replaced. Found a squirrel had chewed the wires almost at the tank and repaired them. Same thing happened a month later and this time no fuel pumping. Repaired the chewed wires again.

Then last year no fuel pressure again but this time it was the PCM and replaced it with an aftermarket one.

Question: I've been told not to use an aftermarket fuel pump but someone told me the dealer wants $800! Wow! If my pump goes out is it worth buying an aftermarket one if you have to drop the tank a couple times? Not sure if I'd trust a junk yard one though.

Once in a while I get a short stutter or my Jeep won't start. Have a new crank sensor and 1 year old PCM. Could the fuel position sensor (original) be causing this or more likely the pump itself? I was told with the aftermarket PCM it wouldn't hold codes what the problem is unless it happens right at the time of testing.

Thanks for any input.
Uniblurb is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 02:03 PM   #8058
Erek.Smith
Registered User
1995 ZJ 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 355
I did this the other day....

Washed and waxed it. It needs far more than a wax job...

Whipped out my inverter and computer speakers and ghetto rigged the sub. I'm using a Y splitter for the signal, so the music (Ipod) plays through my Jeep speakers and the sub. I just need a more powerful inverter OR to get my amp fixed. Hmm...
__________________
White 2WD 1995 ZJ 4.0
Jesus the Christ is my Lord and Savior. I know Him, do you?
Future Mods: get it working correctly
Essential gear for America's heroes
Erek.Smith is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 04:34 PM   #8059
niles6284
Registered User
2001 WJ 
 
Join Date: Aug 2010
Location: Marion, Ohio
Posts: 325
Picked up her shoes a little bit ago. She is quite excited as am I.
__________________
98 ZJ 4.0 Lifted with stuff
2001 WJ not lifted no stuff
Firefighter/Paramedic
IAFF Local 379
niles6284 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 05:26 PM   #8060
95_ZJ_Limited
Registered User
1995 ZJ 
 
Join Date: Sep 2010
Location: Orlando, Florida
Posts: 613
Checked and filled my blinker fluid
__________________
Build Thread: http://www.jeepforum.com/forum/f197/college-students-cheap-daily-driver-build-1363666
Built not Bought # 529
RIP Ratmonkey-5/27/13.
95_ZJ_Limited is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 05:31 PM   #8061
TheMadMike
Registered User
1987 XJ Cherokee 
 
Join Date: Feb 2010
Location: Cleveland, Ga
Posts: 132
Cleaned her up so hopefully the guy coming this weekend will buy it.

Took it for a drive and wouldn't you know it the front drive shaft u-joint seized so I pulled the front drive-shaft on the side of the road. U-joint was replace 6 months ago and all 4 caps are bone dry. Going to replace the u-joint on Friday so the 4WD will work for the new owner.
TheMadMike is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 06:46 PM   #8062
pincheburro956
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Brownsville, Tx
Posts: 950
Changed the rear brake pads on her today. Also, noticed that I have a trans fluid leak AFTER i changed the fluid/filter. Thinking about removing the gasket and putting "good ol'" silicone...
__________________
"Not a single **** shall be given."

99 WJ, 2" BB, 245/75/16 Falken Rocky Mountain ATS.
pincheburro956 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 07:02 PM   #8063
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, Italy
Posts: 16,353
Quote:
Originally Posted by pincheburro956 View Post
Changed the rear brake pads on her today. Also, noticed that I have a trans fluid leak AFTER i changed the fluid/filter. Thinking about removing the gasket and putting "good ol'" silicone...
Did you put a new gasket in? I have a small leak around two bolts after I put the new gasket in but I just keep tightening them down. One of the bolts stopped leaking so far. I would avoid the silicone.
PolkaPower is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 07:33 PM   #8064
E-rok
Registered User
1996 ZJ 
 
Join Date: Dec 2011
Location: , WA
Posts: 620
cleaned my interior to find my pass side carpet wet AGAIN!

I really hope it isnt the heater core, I dont seem to lose coolant and I have rubber floormats and they are dry, so the moisture is getting under it somehow. ugh
__________________
2011 WK2 Laredo X Hemi
2013 Ram 2500 Cummins
E-rok is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 08:16 PM   #8065
pincheburro956
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Brownsville, Tx
Posts: 950
Quote:
Originally Posted by PolkaPower View Post
Did you put a new gasket in? I have a small leak around two bolts after I put the new gasket in but I just keep tightening them down. One of the bolts stopped leaking so far. I would avoid the silicone.
i put the rubber gasket that came with the filter. its leaking from the drivers side , there are 2 bolts that look "wet". might tighten them down, and see what happens... thanks polka..
__________________
"Not a single **** shall be given."

99 WJ, 2" BB, 245/75/16 Falken Rocky Mountain ATS.
pincheburro956 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 08:42 PM   #8066
Devanzj
Registered User
1997 ZJ 
 
Join Date: Dec 2010
Location: PEI, Canada
Posts: 244
Got death wobble going down a road at 60km/hr and tore a control arm mount off the front axle, then my passenger tire folded under the jeep and I proceeded to drive directly into the snowbank on the side of the road.
Great night.............
__________________
97 ZJ 5.2L, NP231, 6"ish lift, 33" KM2s, hp30, IRO front long arms, Clayton rear long arms, JKS quick discos, BDS Shocks, Flowmaster Super 10 Series muffler, KOR style bumper
Build Thread - [url]http://www.jeepforum.com/forum/f22/blacked-out-zj-low-budget-1159489/index2.html[/url]

On the way/waiting to go on: ford 8.8, 4.88s
Devanzj is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 10:29 PM   #8067
moggie99
Registered User
1996 ZJ 
 
Join Date: Sep 2011
Location: Al Ain, Abu Dhabi
Posts: 623
Went through 240,000km (150,000 miles):


Had a set of these wheels fitted too (15" x 9"):


Crappy mobile phone picture:
__________________
Richard Moss
1996 Grand Cherokee 4L Laredo, 1995 Cherokee XJ 4L manual and 2002 Jaguar S-Type 4L
Back in the UK: 1969 MGC GT and SAAB 900 convertible
moggie99 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 10:48 PM   #8068
brady1604
Registered User
1996 ZJ 
 
Join Date: Oct 2010
Location: pell city, alabama
Posts: 57
built a bumper and started framing up a mesh grille

i still have some work to do on the bumper though
0208121715-1-.jpg  
brady1604 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2012, 11:11 PM   #8069
ejschultz
Web Wheeler
 
ejschultz's Avatar
1997 ZJ 
 
Join Date: Feb 2010
Location: Crown Point, Indiana
Posts: 3,167
Quote:
Originally Posted by 95_ZJ_Limited View Post
Checked and filled my blinker fluid
My VIC has been beeping because of this for weeks now...
__________________
97 ZJ - 5.2L, 242, 4" IRO lift w/short arms & adj. TBs, JKS Discos/BPEs, DT3000s, Aussie'd 44A, sliders, OEM skids/hooks/hitch, 31" Duratracs on 15x8s
14 JKU Sport S - Stock
Build
ejschultz is offline   Reply With Quote Quick reply to this message
Unread 02-09-2012, 12:10 AM   #8070
Jared_bc
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Logan Lake, BC
Posts: 22
Fought with my Zj again, if any one wants to be a hero, Now is the time!!

http://www.jeepforum.com/forum/f13/z...-fuel-1326397/
Jared_bc is offline   Reply With Quote Quick reply to this message
Reply

Tags
door latch , lift + spacers

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.