What did you do to your ZJ today? - Page 518 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > What did you do to your ZJ today?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 01-28-2012, 11:17 AM   #7756
Blackspike85
Registered User
1995 ZJ 
 
Join Date: Apr 2006
Location: Western NJ
Posts: 299
no, its pretty easy to do.
http://tija.org/writeups/PinionReplacement.html

__________________
1995 ZJ Limited 4.0 Bored Throttle Body, High Flow Cat, Thrush Welded Muffler, V8 Tail Pipe, Cobra 25 CB, 4' FireStik Antenna
Blackspike85 is offline   Reply With Quote
Unread 01-28-2012, 11:26 AM   #7757
ejschultz
Web Wheeler
 
ejschultz's Avatar
1997 ZJ 
 
Join Date: Feb 2010
Location: Crown Point, Indiana
Posts: 3,036
Sweet! Thanks. Looks easy enough. For future reference, is the rear that easy too?
__________________
97 ZJ - 5.2/242, 4" lift, 31s, locked, armored
14 JKU Sport S - Stock
ejschultz is offline   Reply With Quote
Unread 01-28-2012, 11:46 AM   #7758
csouers
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2008
Location: Bloomington, Indiana
Posts: 2,027
Quote:
Originally Posted by biebs53 View Post
Took a video of my weak starter a few days ago. Surprisingly, it sounds even worse now, the warmer, the worse it sounds.
Have you tried swapping in a known good battery that has a solid charge? Sounds similar, but worse, than my 5.9 when it sits in <30* weather for a week.

It sure sounds like an electrical problem to me. If the battery theory is, for sure mythbusted, clean the terminals. You may even want to replace the cables with something heavy duty, which might be a worth upgrade anyways. Our Red 5.2 starts like crap and I'm pretty damn sure it's due to the amount of corrosion on the positive wire and terminal.
__________________
1998 Bright Platinum ZJ 5.9 Limited - 5.9l, 46RE, NV-242, D30/44a (Trac-Loc) w/3.73s - The DD
1999 White XJ Sport - 4.0l, AW4, NP-231, D30/8.25 w/3.55s - The Rig

My Photography
csouers is offline   Reply With Quote
Unread 01-28-2012, 11:46 AM   #7759
Blackspike85
Registered User
1995 ZJ 
 
Join Date: Apr 2006
Location: Western NJ
Posts: 299
yes sir
__________________
1995 ZJ Limited 4.0 Bored Throttle Body, High Flow Cat, Thrush Welded Muffler, V8 Tail Pipe, Cobra 25 CB, 4' FireStik Antenna
Blackspike85 is offline   Reply With Quote
Unread 01-28-2012, 12:01 PM   #7760
Midnightluckey
Registered User
1995 ZJ 
 
Join Date: May 2009
Location: Houston, TX, Tx
Posts: 1,271
Quote:
Originally Posted by biebs53

Link to lights?
http://www.jeepforum.com/forum/f67/o...ights-1243906/

Omelet's rock light thread. He has a link to the ebay ad in the first post.
__________________
95 Limited Chargold ZJ 5.2L -5.5" lift (IRO, Ironman, and RC parts), 33" BFG M/T's, 15x8 procomp crawlers, 242 swap, 2 12" subs, 1000w amp, cherry bomb, full skid package, Kevins rear stealth bumper clone w 3/4" D rings, Rlcwelding front bumper w 3/8" D rings, XRC-8, front tow hooks, 2 daylighter fairlead lights, 2 daylighter windsheild lights, 2 55w driving lights, OBA, Cobra 18 CB, dual 4' whips, RC disconnects, smittybuilt jack, optima yellowtop.
Built not bought #512
Midnightluckey is offline   Reply With Quote
Unread 01-28-2012, 12:06 PM   #7761
Midnightluckey
Registered User
1995 ZJ 
 
Join Date: May 2009
Location: Houston, TX, Tx
Posts: 1,271
Quote:
Originally Posted by aircruiser
Alright so ever since the tranny line blew off and dumped out all my fluid, I refilled it and it was driving fine but lately if I slowly accelerate, it wont start going til 1,000rpms and then it goes to around 1,300 and back to 1,000 and then grabs again and it is fine through all the gears. But if I give it half pedal or more, it's fine. Could there be air in the lines or something? I will check fluid tomorrow but last I checked it was in the middle of OK. Also, when I shift from reverse to drive, it dies. But if I shift from reverse, then to neutraul, then to drive, it is usually ok.

And last but not least, it likes to randomly bog at idle in gear and jump back up and keep doing that until I go or put it in neutral and even today it did it and died in gear. I have just been limping it along until I get my truck and then I can fix all the stuff wrong with it and be done. Just curious if anyone has any ideas. Thanks
Sounds a bit like the torque converter. Thats my problen in the 94, the torque converter likes to stick, either making it slip and then jump, or killing it when i come to a stop.
__________________
95 Limited Chargold ZJ 5.2L -5.5" lift (IRO, Ironman, and RC parts), 33" BFG M/T's, 15x8 procomp crawlers, 242 swap, 2 12" subs, 1000w amp, cherry bomb, full skid package, Kevins rear stealth bumper clone w 3/4" D rings, Rlcwelding front bumper w 3/8" D rings, XRC-8, front tow hooks, 2 daylighter fairlead lights, 2 daylighter windsheild lights, 2 55w driving lights, OBA, Cobra 18 CB, dual 4' whips, RC disconnects, smittybuilt jack, optima yellowtop.
Built not bought #512
Midnightluckey is offline   Reply With Quote
Unread 01-28-2012, 02:37 PM   #7762
comptiger5000
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Stamford, CT / Rochester, NY
Posts: 4,275
You guys and your crappy gas mileage... I can get 18 - 19 on the highway, cruise set at 60. And I've got a cammed 5.9... It's still not exactly good mileage, but it could be worse.
comptiger5000 is offline   Reply With Quote
Unread 01-28-2012, 03:33 PM   #7763
TurboTPI
Registered User
1995 ZJ 
 
Join Date: Feb 2011
Location: Bensenville, Il
Posts: 568
I agree^ My turboed 4.0l gets over 20mpg on the highway on 33's.
__________________
02 WJ Limited 4.7l HO-stock (Hers)
95 ZJ 4.0 Turbo-up 5.5 on 33x12.5's, Ford 8.8 w/Artec truss (His)
92 Firebird Formula custom turbo setup (His)
09 Polaris Dragon 800 (His)
TurboTPI is offline   Reply With Quote
Unread 01-28-2012, 04:07 PM   #7764
biebs53
Registered User
1998 ZJ 
 
Join Date: Jan 2011
Location: Orange County, CA
Posts: 2,697
Quote:
Originally Posted by csouers

Have you tried swapping in a known good battery that has a solid charge? Sounds similar, but worse, than my 5.9 when it sits in <30* weather for a week.

It sure sounds like an electrical problem to me. If the battery theory is, for sure mythbusted, clean the terminals. You may even want to replace the cables with something heavy duty, which might be a worth upgrade anyways. Our Red 5.2 starts like crap and I'm pretty damn sure it's due to the amount of corrosion on the positive wire and terminal.
It starts very strong when cold. When warm, it sounds worse than the video. The battery is good. 6 months old, 850 CCA, tested 4 times on 4 different testers in the past 2 weeks, its always good
__________________
[CENTER][FONT="Franklin Gothic Medium"]1998 Jeep Grand Cherokee 5.9 Limited

Build thread: [url]http://www.jeepforum.com/forum/f197/project-raven-biebs53-build-thread-1215245/[/FONT][/url][/CENTER]
biebs53 is offline   Reply With Quote
Unread 01-28-2012, 04:55 PM   #7765
98zjkidd
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: south berwick, Me
Posts: 307
Finally got my IRO rear trac bar, too bad its raining out today. O well hope its nice out tomorrow
98zjkidd is offline   Reply With Quote
Unread 01-28-2012, 09:30 PM   #7766
Cameleer
Registered User
1998 ZJ 
 
Join Date: Jul 2011
Location: Ventura, California
Posts: 866
Took my new sliders out for a test run, they are still bare metal and I'm trying to decide on powder coating them black or hammered gray like the roof rack.

__________________
Only those who will risk going too far
can possibly find out how far one can go.
Cameleer is offline   Reply With Quote
Unread 01-28-2012, 09:36 PM   #7767
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,732
I like the grey.
PolkaPower is online now   Reply With Quote
Unread 01-28-2012, 09:38 PM   #7768
RedneckZJ
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: Madison TN, Wingate NC
Posts: 809
i think matching the roof rack...its subtle but i like it
__________________
'96 ZJ Orvis 5.2L (Mossy Oak Edit.)- UC+2" BB, Thrush Turbo, 2 12s, Lots Of Stickers
You drive a tj, we drive a zj. We have more power while you get more shower. We get the v8 while you get there too late. You have 2 doors well, we have 2 more. Ours costs a grand while yours has a price we cant stand.
RedneckZJ is offline   Reply With Quote
Unread 01-28-2012, 09:52 PM   #7769
Cameleer
Registered User
1998 ZJ 
 
Join Date: Jul 2011
Location: Ventura, California
Posts: 866
I tried changing it with Photoshop, didn't turn out all that well.
I don't like how the black looks.





__________________
Only those who will risk going too far
can possibly find out how far one can go.
Cameleer is offline   Reply With Quote
Unread 01-28-2012, 09:55 PM   #7770
Dyn0mitemat
Registered User
1998 ZJ 
 
Join Date: Dec 2010
Location: BC, Oh
Posts: 1,292
I think they'd look awesome either way, thats disgustingly clean ZJ haha

You have the whole blacked out look with just a touch of silver (rims, roof rack, license plate, roof rack, lights) I think they'd look good either way
__________________
98 ZJ: Built 44/88, long arm'd, locked, 35s, armour, blah blah blah
Build Thread: http://www.jeepforum.com/forum/f22/green-zj-aka-jolly-green-giant-1386118/
Dyn0mitemat is offline   Reply With Quote
Reply

Tags
door latch
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.