What did you do to your ZJ today? - Page 346 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > What did you do to your ZJ today?

End of Summer Sale, 20% OFF!2007 - 2011 Jeep JK Long Arm Lift KitsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 10-31-2011, 08:47 PM   #5176
merlot2twisty
Registered User
1997 ZJ 
 
Join Date: Nov 2008
Location: CensorNazi, Ohio
Posts: 143
What did I do to my ZJ Today?

Asmptotically approaching completion.

Installed new speakers to replace the infinicrap ones in there. Factory HU actually sounds good. Too bad it doesn't have BlueTooth, iPod control and MP3 Playback. But it will suffice for now.

Installed a new rear o2 sensor. I thought I had one in there already, but I apparently ordered a front one and figured that the reason the connector didn't click in was due to a manufacturing defect. Then I found out from this forum (thanks!) that the front and rear have different connectors, and what I had in the rear was a front O2. So, I installed it and immediately got a P1762 and an engine that would not idle. Hmm.. I had read that meant there was a short. So, I crawled under there to disconnect the o2 and decided I'd track down the short another time....but to my amazement, the damage to the harness was just a few inches back from the connector and I was able to cut out the bad wire and crimp it together, and no more code! Woot!

The other day, I put new plugs in the motor (Champion double platinums) and then I seafoamed it. After that, it started running badly and I had no idea why. I eventually narrowed it down to cyl #1, but it was clear that there was spark going from the distributor (as evidenced by the nasty shock I got when I pulled the wire off the plug when it was running.. YOUCH!). No real change. So then I thought it was an injector. I could remove the injector plug and there was NO change on #1. If I pulled the plug on any other injector, it ran worse. So, I bought a new injector. The problem was still there. So, I decided to check the only other thing. The brand new plug. I pulled it out and the anode had been crushed by something and it was touching the cathode. Hmm. I regapped the plug and put it in and everything was peachy. I can only assume that when I seafoamed the engine a big hunk of carbon broke of and got smashed against the plug. That, or when I slipped it into the hole between the valve cover and the AC compressor, I somehow caused the damage.. Point is, it's all good now. I'll keep an eye on it.

I also installed new rubber bumpers on the liftgate since the stockers were completely smashed.

Got more parts coming tomorrow. Mainly exhaust parts. My ZJ is gonna be NICE. The hood and RT fender are black because they are aftermarket, but I may get those painted in the spring. Aside from that, it's now in really good shape. I'll post pics once I get done with everything.

merlot2twisty is offline   Reply With Quote
Unread 10-31-2011, 09:04 PM   #5177
pincheburro956
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Brownsville, Tx
Posts: 950
I turned on my ZJ after a full weekend of no attention. poor things' lifters were rattling a bit. that to me was her crying for me abandoning her all weekend and going off with my WJ. poor thing...

but the WJ is preetier. so, go figure....
__________________
"Not a single **** shall be given."

99 WJ, 2" BB, 245/75/16 Falken Rocky Mountain ATS.
pincheburro956 is offline   Reply With Quote
Unread 10-31-2011, 09:14 PM   #5178
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc, WI
Posts: 532
Wow didn't think my custom, original taillights would cause such a ruckus. Bwahaha. I don't see why it's such a big deal, it isn't your truck, it's mine. Problem solved right??
TRAVASS is offline   Reply With Quote
Unread 10-31-2011, 09:19 PM   #5179
PurpleZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2010
Location: kansas city
Posts: 4,199
Quote:
Originally Posted by TRAVASS View Post
Wow didn't think my custom, original taillights would cause such a ruckus. Bwahaha. I don't see why it's such a big deal, it isn't your truck, it's mine. Problem solved right??
post up a pic of them "lit" up, until then i'll hold my ground that they are unsafe as hell. you could have gotten the same effect from tint spray with still having light transfer, and it would have been a better idea to do so.
__________________
1996 ZJ- 4.0, [COLOR="Purple"]AX-15 5SPD/NP242[/COLOR], RE 4.5" lift, 36x12.50x16.5 Goodyear military surplus tires, Longarms/Tri-4 link/one ton axle build/swap in progress, arb bumper, a bunch of other goodies
1995 XJ- 4.0 HO, ax-15(stolen for swap), stock
2001 GMC Sonoma-RIP...
2002 GMC Sierra 1500 ECSB-roadtrip/long haul vehicle
[CENTER][COLOR="Blue"]RIP Troy (bigbluezj94) you wont be forgotten[/COLOR]

[COLOR="Purple"]December 2010 GCOTM[/COLOR]

5spd ZJ Club Member 001
[/CENTER]

[QUOTE=bddisi;6376248]Glad you are ok. If you were a cat, you would be down to 8.:D[/QUOTE]


[QUOTE=Greengc4x4;10782815]Everything looks great, Hellen Keller! :D[/QUOTE]


[QUOTE=rritch;10960201]plastic + Fuel + Ignition = "Bubba wake up this is gonna be good" :rofl:[/QUOTE]


[CENTER][COLOR="Purple"]RIP William Anthony Kolich(DAD)
you were the best father i could have wished for. I'll always miss you
04/28/58-2/13/11[/COLOR][/CENTER]
PurpleZJ is offline   Reply With Quote
Unread 10-31-2011, 09:30 PM   #5180
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc, WI
Posts: 532
Quote:
Originally Posted by PurpleZJ

post up a pic of them "lit" up, until then i'll hold my ground that they are unsafe as hell. you could have gotten the same effect from tint spray with still having light transfer, and it would have been a better idea to do so.
Sry not trying to sound like a dick but it doesn't matter. It's my truck. Not yours. It was my choice. And as far as the fronts go, it's not permanent. I'm replacing both assemblies with 1 piece. Drop it man
TRAVASS is offline   Reply With Quote
Unread 10-31-2011, 09:45 PM   #5181
PurpleZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2010
Location: kansas city
Posts: 4,199
well for future reference if you do a mod thats stupid as hell and unsafe, dont be surprised when you get negative feedback on it. gtfo noob
__________________
1996 ZJ- 4.0, [COLOR="Purple"]AX-15 5SPD/NP242[/COLOR], RE 4.5" lift, 36x12.50x16.5 Goodyear military surplus tires, Longarms/Tri-4 link/one ton axle build/swap in progress, arb bumper, a bunch of other goodies
1995 XJ- 4.0 HO, ax-15(stolen for swap), stock
2001 GMC Sonoma-RIP...
2002 GMC Sierra 1500 ECSB-roadtrip/long haul vehicle
[CENTER][COLOR="Blue"]RIP Troy (bigbluezj94) you wont be forgotten[/COLOR]

[COLOR="Purple"]December 2010 GCOTM[/COLOR]

5spd ZJ Club Member 001
[/CENTER]

[QUOTE=bddisi;6376248]Glad you are ok. If you were a cat, you would be down to 8.:D[/QUOTE]


[QUOTE=Greengc4x4;10782815]Everything looks great, Hellen Keller! :D[/QUOTE]


[QUOTE=rritch;10960201]plastic + Fuel + Ignition = "Bubba wake up this is gonna be good" :rofl:[/QUOTE]


[CENTER][COLOR="Purple"]RIP William Anthony Kolich(DAD)
you were the best father i could have wished for. I'll always miss you
04/28/58-2/13/11[/COLOR][/CENTER]
PurpleZJ is offline   Reply With Quote
Unread 10-31-2011, 09:49 PM   #5182
biebs53
Registered User
1998 ZJ 
 
Join Date: Jan 2011
Location: Orange County, CA
Posts: 2,679
Quote:
Originally Posted by PurpleZJ
well for future reference if you do a mod thats stupid as hell and unsafe, dont be surprised when you get negative feedback on it. gtfo noob
__________________
[CENTER][FONT="Franklin Gothic Medium"]1998 Jeep Grand Cherokee 5.9 Limited

Build thread: [url]http://www.jeepforum.com/forum/f197/project-raven-biebs53-build-thread-1215245/[/FONT][/url][/CENTER]
biebs53 is offline   Reply With Quote
Unread 10-31-2011, 09:51 PM   #5183
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc, WI
Posts: 532
1 not stupid to me. 2. Didn't ask for ANY feedback at all ***. 3. Someone requested pics of my blacked out jeep. 4. It's mostly a fun truck as in minimally used for DD. Not like I'm driving this thing home from the bar at 2am. No reason for you to be an ***, keep your negativity to yourself.
TRAVASS is offline   Reply With Quote
Unread 10-31-2011, 10:04 PM   #5184
tonymartin
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2010
Location: United Arab Emirates, Abu Dhabi
Posts: 1,038
Now now children, play nice! If he wants to do his lights like that, then so be it. Also, if somebody gives you feedback and you don't like it.... so be it! We all have our opinions on things and some agree, some don't. The point is he did it and some don't liek it. Ahh well, life is what it is!

BAck to topic. I think I have a failing alternator as my battery won't charge. It charges fine if I hook up the wires to my mitsubishi but will not idle AT ALL!!! I can only guess that it's the alternator as the battery will charge from another vehicle but not from the power of the ZJ. Any thoughts?
__________________
93 Renegade|Home made add a leaf (by PO, changing out soon)|Rancho adjustable shocks|31x15 BFG AT's|15" GT alloys|AFE Headers|Red SpiderWebShade Trail Cage|Free Sense of Adventure
tonymartin is offline   Reply With Quote
Unread 10-31-2011, 10:06 PM   #5185
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc, WI
Posts: 532
Quote:
Originally Posted by tonymartin
Now now children, play nice! If he wants to do his lights like that, then so be it. Also, if somebody gives you feedback and you don't like it.... so be it! We all have our opinions on things and some agree, some don't. The point is he did it and some don't liek it. Ahh well, life is what it is!

BAck to topic. I think I have a failing alternator as my battery won't charge. It charges fine if I hook up the wires to my mitsubishi but will not idle AT ALL!!! I can only guess that it's the alternator as the battery will charge from another vehicle but not from the power of the ZJ. Any thoughts?
Alternator would be my first thought
TRAVASS is offline   Reply With Quote
Unread 10-31-2011, 10:08 PM   #5186
RedneckZJ
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: Madison TN, Wingate NC
Posts: 804
Quote:
Originally Posted by TRAVASS View Post
Alternator would be my first thought
same here...or maybe a loose connection to the alternator or battery, corroded terminals, etc. check all the electrical connections, if they all look good then it say its alternator pretty much 100%
__________________
'96 ZJ Orvis 5.2L (Mossy Oak Edit.)- UC+2" BB, Thrush Turbo, 2 12s, Lots Of Stickers
You drive a tj, we drive a zj. We have more power while you get more shower. We get the v8 while you get there too late. You have 2 doors well, we have 2 more. Ours costs a grand while yours has a price we cant stand.
RedneckZJ is offline   Reply With Quote
Unread 10-31-2011, 10:13 PM   #5187
tonymartin
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2010
Location: United Arab Emirates, Abu Dhabi
Posts: 1,038
The terminals are new, the wires are all tight as far as can see and there is no loose grounds anywhere on the ZJ from what I've seen. All the wiring seems fine except for a little break in the plastic casing on the positive cable, but the actual cable is fine. I have replacement battery cables there anyway so when I do the alt I may as well do the cables too eh?
__________________
93 Renegade|Home made add a leaf (by PO, changing out soon)|Rancho adjustable shocks|31x15 BFG AT's|15" GT alloys|AFE Headers|Red SpiderWebShade Trail Cage|Free Sense of Adventure
tonymartin is offline   Reply With Quote
Unread 10-31-2011, 10:14 PM   #5188
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc, WI
Posts: 532
Agreed Tony
TRAVASS is offline   Reply With Quote
Unread 10-31-2011, 10:14 PM   #5189
RedneckZJ
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: Madison TN, Wingate NC
Posts: 804
Quote:
Originally Posted by tonymartin View Post
The terminals are new, the wires are all tight as far as can see and there is no loose grounds anywhere on the ZJ from what I've seen. All the wiring seems fine except for a little break in the plastic casing on the positive cable, but the actual cable is fine. I have replacement battery cables there anyway so when I do the alt I may as well do the cables too eh?
if you have em may just as well but id definitely keep em in the zj in case something ever happens where you would need them
__________________
'96 ZJ Orvis 5.2L (Mossy Oak Edit.)- UC+2" BB, Thrush Turbo, 2 12s, Lots Of Stickers
You drive a tj, we drive a zj. We have more power while you get more shower. We get the v8 while you get there too late. You have 2 doors well, we have 2 more. Ours costs a grand while yours has a price we cant stand.
RedneckZJ is offline   Reply With Quote
Unread 10-31-2011, 10:15 PM   #5190
badbird17x
Web Wheeler
 
badbird17x's Avatar
1994 ZJ 
 
Join Date: Jul 2011
Location: lisbon, nd
Posts: 3,988
Did a little cutting. And yes it's getting a cage to stiffen it back up

Sent from my iPhone using JeepForum
image-1274805596.jpg   image-2699241165.jpg  
__________________
94 jz, bruiser, la, cage,5.3 ls, 36 swampers 98 jz, the mutt, 3.5 iro, 33 swampers, avalanche conversion, 02 north face avalanche blacked out work truck, 06 rhino R1 engine, 4x4, Leeroy's custom paint, 04 escalade wifes truck 22s, 03 duramax 18s, completely blacked out, efilive by nick, wicked wicked truck, 39 chop chevy rod, aluminum 5.3 ls, 08 apex, 310hp mcx turbo, holz 162, completely black, CCM built.
badbird17x is offline   Reply With Quote
Reply

Tags
door latch
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.