What did you do to your ZJ today? - Page 2195 - JeepForum.com

 88Likes
 
LinkBack Thread Tools
post #32911 of 44557 Old 06-17-2014, 09:28 PM
SchizophrenicMC
Registered User
2016 JK Wrangler 
 
Join Date: May 2012
Location: Arlington
Posts: 3,727
Quote:
Originally Posted by 95knight View Post
So got in it after work today turn the key nothing but guages. Back to off then start and it starts and everything is fine.

Question is should i be worried? Or just a glitch or something?
Ignition switch problems. You sure it's not a GM?


1998 Grand Cherokee 5.9 Limited
2016 Wrangler Unlimited Sahara Edition

Signature rules are dumb
SchizophrenicMC is offline  
Sponsored Links
Advertisement
 
post #32912 of 44557 Old 06-17-2014, 09:53 PM
95knight
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Waukesha
Posts: 495
Quote:
Originally Posted by SchizophrenicMC View Post

Ignition switch problems. You sure it's not a GM?
I'm glad my gm car is a transponder with the resistor lol
95knight is offline  
post #32913 of 44557 Old 06-17-2014, 10:00 PM
Glued2aPost
Registered User
1998 ZJ 
 
Join Date: May 2011
Location: Wasilla
Posts: 370
Quote:
Originally Posted by Myusername1674
Are you talking about the input shaft? Because almost everyone has to swap that, but the tailcone is completely different
I dunno. My case went right in. Spline counts were the same, shafts were the same, just has to move the speedo and gear sensor from the 249. The only remaining mystery is how people got their 249linkage adjusted to fit the shorter tab on the 242. I gave up and found a guy that has a linkage for a 242 that I'll grab tomorrow.

My ZJ has never been stuck, it was just taking a break from being so awesome!
Glued2aPost is offline  
post #32914 of 44557 Old 06-17-2014, 10:18 PM
JColee
Registered User
1997 ZJ 
 
Join Date: Oct 2011
Location: Logansport
Posts: 625
Quote:
Originally Posted by Glued2aPost View Post

I dunno. My case went right in. Spline counts were the same, shafts were the same, just has to move the speedo and gear sensor from the 249. The only remaining mystery is how people got their 249linkage adjusted to fit the shorter tab on the 242. I gave up and found a guy that has a linkage for a 242 that I'll grab tomorrow.
Yeah, I don't remember how I got mine to work. Just that it did, and still does. I just had to adjust it a bit.

1997 Limited Jeep Grand Cherokee, 2.25" 4-Wheel Customs BB, Bilstein 5100's, NP242 Swap
JColee is offline  
post #32915 of 44557 Old 06-18-2014, 02:49 AM
ejschultz
Web Wheeler
 
ejschultz's Avatar
1997 ZJ 
 
Join Date: Feb 2010
Location: Crown Point
Posts: 3,419
My external slip yoke 242 swapped perfectly into my ZJ that had an internal slip yoke 249 without issue. My stock driveshaft worked after I trimmed about an inch off slip yoke section of it. As far as the linkage goes, the 249 linkage works perfectly with the 242 after you properly adjust it.

97 ZJ - 5.2L, 242, 4" IRO lift w/short arms & adj. TBs, JKS Discos/BPEs, DT3000s, Aussie'd 44A, sliders, bumpers, bunch o' skids, 31" Duratracs on 15x8s
Build
ejschultz is offline  
post #32916 of 44557 Old 06-18-2014, 09:30 AM
SchizophrenicMC
Registered User
2016 JK Wrangler 
 
Join Date: May 2012
Location: Arlington
Posts: 3,727
I installed fuel injectors in the niner. And now, it runs the same, only when I unplug all 8 injectors, it runs the same as always. Before, if I unplugged any injector aside from #5, it would get worse.

I need to buy an OBD2 interface tool and see if any data from that will be useful. I'm too used to Nissans, where unplugging a fuel injector always means the cylinder receives no fuel.

1998 Grand Cherokee 5.9 Limited
2016 Wrangler Unlimited Sahara Edition

Signature rules are dumb
SchizophrenicMC is offline  
post #32917 of 44557 Old 06-18-2014, 09:34 AM
comptiger5000
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Rochester, NY
Posts: 4,556
Quote:
Originally Posted by SchizophrenicMC View Post
I installed fuel injectors in the niner. And now, it runs the same, only when I unplug all 8 injectors, it runs the same as always. Before, if I unplugged any injector aside from #5, it would get worse.

I need to buy an OBD2 interface tool and see if any data from that will be useful. I'm too used to Nissans, where unplugging a fuel injector always means the cylinder receives no fuel.
Unplugging any injector will completely cut the fuel to that cylinder (in any port injection setup, Jeeps included). If it's running badly and misfiring all the time, it might be ignition related. Check the plugs, make sure they're not fouled and the gap is correct. If that checks out, suspect the coil, cap, rotor and wires. You can swap any of those from your 5.2 for testing if needed.
comptiger5000 is offline  
post #32918 of 44557 Old 06-18-2014, 10:08 AM
McCloudsZJ
Because RaceJeep
 
McCloudsZJ's Avatar
1998 ZJ 
 
Join Date: Sep 2011
Location: Roanoke
Posts: 2,729
Quote:
Originally Posted by SchizophrenicMC View Post
I installed fuel injectors in the niner. And now, it runs the same, only when I unplug all 8 injectors, it runs the same as always. Before, if I unplugged any injector aside from #5, it would get worse.

I need to buy an OBD2 interface tool and see if any data from that will be useful. I'm too used to Nissans, where unplugging a fuel injector always means the cylinder receives no fuel.
Are you saying you can completely unplug all eight injectors simultaneously and it still runs?

And as far as OBD2 interfaces, I've always been a fan of the UltraGauge. Better readout than the Scangauge, and half the price of a OBD2 handheld from Advance Auto or somewhere.

March 2014 GCOTM. 1998 Deep Slate 5.9
On the Jeep:Hot intake, 52mm TB, Summit 8mm wires, catch can, 703s, insulated fuel rails, indexed Champions, Bilstein 4600s, Eibach lowering springs, Moog SS, Ironman mounts, Lotek 2GP, lots of gauges, sparkly paint.
In the garage: M1 4bbl
In the works: Addco/Hellwig sway bars, nitrous, full polly bushings, full exhaust, data logging, billet UD pulleys
McCloudsZJ is offline  
post #32919 of 44557 Old 06-18-2014, 10:25 AM
smccloud
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: Becker, MN
Posts: 417
Quote:
Originally Posted by McCloudsZJ View Post
Are you saying you can completely unplug all eight injectors simultaneously and it still runs?

And as far as OBD2 interfaces, I've always been a fan of the UltraGauge. Better readout than the Scangauge, and half the price of a OBD2 handheld from Advance Auto or somewhere.
I just use Torque on my phone and a $15 OBDII Bluetooth adapter from eBay, total cost $20 and lets me do everything I need to on my Jeep.
smccloud is offline  
post #32920 of 44557 Old 06-18-2014, 10:38 AM
xrunndonex
Registered User
1994 ZJ 
 
Join Date: Dec 2012
Location: coffeyville
Posts: 2,886
Quote:
Originally Posted by Midnightluckey View Post
So I've been driving for two days with no speedometer and therefore no overdrive, so on my lunch break today I pulled the vss apart and found this:

Yeah, that's my speedo gear shaved almost smooth. What the hell could cause that? I have a spare at home I could swap in, but damn.
Well there is you're problem
xrunndonex is offline  
post #32921 of 44557 Old 06-18-2014, 10:43 AM
SchizophrenicMC
Registered User
2016 JK Wrangler 
 
Join Date: May 2012
Location: Arlington
Posts: 3,727
Quote:
Originally Posted by McCloudsZJ View Post
Are you saying you can completely unplug all eight injectors simultaneously and it still runs?

And as far as OBD2 interfaces, I've always been a fan of the UltraGauge. Better readout than the Scangauge, and half the price of a OBD2 handheld from Advance Auto or somewhere.
It was this morning. But now it only works when all 4 injectors on bank 1 are unplugged. And even with all 4 of them plugged in, unplugging 1 injector on bank 2 has no effect, but 2 injectors worsens the issue. And it's still running like it's on 7 cylinders, regardless of any of this.

The worst thing about this Jeep is, every time I re-evaluate it, the problem condition changes. It's hard to narrow any one thing down to repeat itself. I'm gonna go ahead and replace all 8 injectors and pore through the entire ignition system this afternoon, after my job interview. And I'll probably pay the FSM a nice long visit while I'm at it.

As far as OBD2 stuff goes, I'm a big fan of a bluetooth dongle and a smartphone with Torque installed, but I'd really like a multi-thousand-dollar technician-grade scanner interface...

1998 Grand Cherokee 5.9 Limited
2016 Wrangler Unlimited Sahara Edition

Signature rules are dumb
SchizophrenicMC is offline  
post #32922 of 44557 Old 06-18-2014, 10:44 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,371
Quote:
Originally Posted by smccloud View Post
I just use Torque on my phone and a $15 OBDII Bluetooth adapter from eBay, total cost $20 and lets me do everything I need to on my Jeep.
This is the least expensive way to read codes and get some engine intel. Works good for me too.
PolkaPower is offline  
post #32923 of 44557 Old 06-18-2014, 10:51 AM
xrunndonex
Registered User
1994 ZJ 
 
Join Date: Dec 2012
Location: coffeyville
Posts: 2,886
Looked in the mirror and noticed one of my eyes were light green and on was brown. Cool it must be that ones in a shadow and ones in sunlight
xrunndonex is offline  
post #32924 of 44557 Old 06-18-2014, 10:53 AM
xrunndonex
Registered User
1994 ZJ 
 
Join Date: Dec 2012
Location: coffeyville
Posts: 2,886
Quote:
Originally Posted by SchizophrenicMC View Post

It was this morning. But now it only works when all 4 injectors on bank 1 are unplugged. And even with all 4 of them plugged in, unplugging 1 injector on bank 2 has no effect, but 2 injectors worsens the issue. And it's still running like it's on 7 cylinders, regardless of any of this.

The worst thing about this Jeep is, every time I re-evaluate it, the problem condition changes. It's hard to narrow any one thing down to repeat itself. I'm gonna go ahead and replace all 8 injectors and pore through the entire ignition system this afternoon, after my job interview. And I'll probably pay the FSM a nice long visit while I'm at it.

As far as OBD2 stuff goes, I'm a big fan of a bluetooth dongle and a smartphone with Torque installed, but I'd really like a multi-thousand-dollar technician-grade scanner interface...
Is there a crack in the hg?
xrunndonex is offline  
post #32925 of 44557 Old 06-18-2014, 10:53 AM
xrunndonex
Registered User
1994 ZJ 
 
Join Date: Dec 2012
Location: coffeyville
Posts: 2,886
Quote:
Originally Posted by PolkaPower View Post

This is the least expensive way to read codes and get some engine intel. Works good for me too.
Lies. Auto zone is free ninety free
xrunndonex is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 37 04-29-2016 10:36 PM
Let me tell you what I did not do today husker_zj ZJ Grand Cherokee Forum 9 03-19-2013 01:09 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM
Have you had your V-8 today?? Myrtle Beach ZJ Grand Cherokee Forum 12 04-30-2005 01:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome