What did you do to your ZJ today? - Page 2097 - JeepForum.com
 64Likes
 
LinkBack Thread Tools
post #31441 of 44095 Old 04-02-2014, 06:02 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,241
Quote:
Originally Posted by ErikTheRad View Post
Replaced both front lower control arms on my 160k 93 5.2. Unfortunately, this didn't eliminate the odd banging sound from the right front when hitting bumps and ruts. I've now replaced coil springs (w OME 2" lifted springs), new shocks (pro-comp) and now new lower CA's and still the noise persists. Guess I'll be doing the uppers soon too. If that doesn't fix it, I'm out of ideas.
What about the brakes, ball joints, or sway bar endlinks?

PolkaPower is online now  
Sponsored Links
Advertisement
 
post #31442 of 44095 Old 04-02-2014, 06:42 AM
McCloudsZJ
Because RaceJeep
 
McCloudsZJ's Avatar
1998 ZJ 
 
Join Date: Sep 2011
Location: Roanoke
Posts: 2,729
Scored an unlocked Xcalibrator 2 (9550) for a cool $150 with some files on it. One step closer...

March 2014 GCOTM. 1998 Deep Slate 5.9
On the Jeep:Hot intake, 52mm TB, Summit 8mm wires, catch can, 703s, insulated fuel rails, indexed Champions, Bilstein 4600s, Eibach lowering springs, Moog SS, Ironman mounts, Lotek 2GP, lots of gauges, sparkly paint.
In the garage: M1 4bbl
In the works: Addco/Hellwig sway bars, nitrous, full polly bushings, full exhaust, data logging, billet UD pulleys
McCloudsZJ is offline  
post #31443 of 44095 Old 04-02-2014, 07:04 AM
comptiger5000
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Rochester, NY
Posts: 4,556
Quote:
Originally Posted by ErikTheRad View Post
Replaced both front lower control arms on my 160k 93 5.2. Unfortunately, this didn't eliminate the odd banging sound from the right front when hitting bumps and ruts. I've now replaced coil springs (w OME 2" lifted springs), new shocks (pro-comp) and now new lower CA's and still the noise persists. Guess I'll be doing the uppers soon too. If that doesn't fix it, I'm out of ideas.
Check your ball joints and sway bar links.
comptiger5000 is offline  
post #31444 of 44095 Old 04-02-2014, 07:36 AM
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 845
Quote:
Originally Posted by ErikTheRad View Post
Replaced both front lower control arms on my 160k 93 5.2. Unfortunately, this didn't eliminate the odd banging sound from the right front when hitting bumps and ruts. I've now replaced coil springs (w OME 2" lifted springs), new shocks (pro-comp) and now new lower CA's and still the noise persists. Guess I'll be doing the uppers soon too. If that doesn't fix it, I'm out of ideas.
My clunk is from my passenger's side upper control arm on the body side.
The arm is crumbling at that end and is just floating around banging on the mounts.
Look there as well.

'93 V8 ZJ Mountain Goat Edition.
'95 V8 ZJ Limited, '97 4.0L ZJ TSi
'96 4.0L 2wd XJ, '88 4.2L YJ
Maine1994ZJ is offline  
post #31445 of 44095 Old 04-02-2014, 07:40 AM
ejschultz
Web Wheeler
 
ejschultz's Avatar
1997 ZJ 
 
Join Date: Feb 2010
Location: Crown Point
Posts: 3,417
Quote:
Originally Posted by Maine1994ZJ View Post
My clunk is from my passenger's side upper control arm on the body side.
The arm is crumbling at that end and is just floating around banging on the mounts.
Look there as well.
http://m.summitracing.com/parts/rnb-520-337/overview/

$30 a piece for a part that sounds like it's in need of immediate repair... I wouldn't be driving my ZJ like that.

97 ZJ - 5.2L, 242, 4" IRO lift w/short arms & adj. TBs, JKS Discos/BPEs, DT3000s, Aussie'd 44A, sliders, bumpers, bunch o' skids, 31" Duratracs on 15x8s
Build
ejschultz is offline  
post #31446 of 44095 Old 04-02-2014, 07:41 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,241
Quote:
Originally Posted by ejschultz View Post
http://m.summitracing.com/parts/rnb-520-337/overview/

$30 a piece for a part that sounds like it's in need of immediate repair... I wouldn't be driving my ZJ like that.
True. It puts a bunch more wear on the other 3 arms if they are even good still. Nothing like driving around with a floaty axle.
PolkaPower is online now  
post #31447 of 44095 Old 04-02-2014, 09:02 AM
Darkrocker
Registered User
1998 ZJ 
 
Join Date: Sep 2012
Location: Vassalboro
Posts: 354
Quote:
Originally Posted by ErikTheRad View Post
Replaced both front lower control arms on my 160k 93 5.2. Unfortunately, this didn't eliminate the odd banging sound from the right front when hitting bumps and ruts. I've now replaced coil springs (w OME 2" lifted springs), new shocks (pro-comp) and now new lower CA's and still the noise persists. Guess I'll be doing the uppers soon too. If that doesn't fix it, I'm out of ideas.
Had a clunk from the same area and for me it was my endlinks. I say replace them for the hell of it. It's a quick job and you can get a pair for like $20 off of ebay.

Also I gotta say, the 99+ intake manifold swap is absolutely worth it. There is a noticeable improvement in acceleration but one thing that nobody would be able to deny is the improvement going uphill. No more downshifting uphill and I don't need to give it more and more gas to maintain my speed, hell I can even accelerate without it downshifting. As far as the exhaust manifold no complaints but in reality all I did was move all that noise and escaping pressure to my cracking/holy muffler. So I didn't fix my exhaust leak, I just moved it back about 6 or so feet .

1994 ZJ Laredo, Jenny: 4.0l - NP231 - 9/2012 to 12/2013 - 183k to 203k miles R.I.P.
1998 ZJ Laredo, Judy: 4.0l - NP242 - 1/2014 to present - My Daily
Darkrocker is offline  
post #31448 of 44095 Old 04-02-2014, 09:45 AM
smccloud
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: Becker, MN
Posts: 417
Bent up one of my running boards this morning while parking it. The ice was a little harder than I though when the passenger front tire dropped off it.
smccloud is offline  
post #31449 of 44095 Old 04-02-2014, 11:45 AM
Myusername1674
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Chattanooga
Posts: 2,310
Welded my exhaust on, nice to have a muffler again, i got tired of that damn straight pipe.

95 FiveTwo ZJ, DD, Lifted, Locked on 35s, Build (in progress)

My 5.9 swap (in progress)

Want your zj to be doorless in 60 seconds?
Myusername1674 is offline  
post #31450 of 44095 Old 04-02-2014, 12:20 PM
RemingtonRifles
Registered User
1998 ZJ 
 
Join Date: Mar 2014
Location: Frankfort
Posts: 131
measured for a double din and only got 5 inches before hitting vents -.-
RemingtonRifles is offline  
post #31451 of 44095 Old 04-02-2014, 03:27 PM
Myusername1674
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Chattanooga
Posts: 2,310
Started tearing down the 5.9, damn this thing is diiirrty. Gonna need some hardcore cleaning and examining before re-assembly.


95 FiveTwo ZJ, DD, Lifted, Locked on 35s, Build (in progress)

My 5.9 swap (in progress)

Want your zj to be doorless in 60 seconds?
Myusername1674 is offline  
post #31452 of 44095 Old 04-02-2014, 03:58 PM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078


Gave her a much deserved, and needed bath. Wax is coming after the sun goes down a little.
zj97ltd is offline  
post #31453 of 44095 Old 04-02-2014, 04:18 PM
mikebontoft
Registered User
1998 ZJ 
 
Join Date: Feb 2014
Location: Murray
Posts: 245
Finally got my plates after driving for about three week on an expired temp tag. I was waiting for the dealer to mail me the title like they said they would. Waited long enough and gave em a call. "Oh we don't mail those anymore. It's just been sitting on a desk over at accounting"

Didn't bother to call me? Nice.
mikebontoft is offline  
post #31454 of 44095 Old 04-02-2014, 06:49 PM
98GCLimited
Registered User
1998 ZJ 
 
Join Date: Jun 2009
Location: LHC
Posts: 512
Quote:
Originally Posted by ErikTheRad View Post
Replaced both front lower control arms on my 160k 93 5.2. Unfortunately, this didn't eliminate the odd banging sound from the right front when hitting bumps and ruts. I've now replaced coil springs (w OME 2" lifted springs), new shocks (pro-comp) and now new lower CA's and still the noise persists. Guess I'll be doing the uppers soon too. If that doesn't fix it, I'm out of ideas.
Make sure your trackbar bolt on the axle side is tight and not wallowed out, it is located on front right like your noise so that is a possibility.

What fixed my front end noise on bumps was new swaybar bushings, not the end links, but the bushings that the bar goes through and bolt to the frame. Replaced those, much more solid feeling in the front and doesnt make noise every time I hit a bump. $10 fix
98GCLimited is offline  
post #31455 of 44095 Old 04-02-2014, 08:48 PM
95knight
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Waukesha
Posts: 495
Quote:
Originally Posted by Myusername1674 View Post
Started tearing down the 5.9, damn this thing is diiirrty. Gonna need some hardcore cleaning and examining before re-assembly.
How straight foward is a swap from a 5.2 to a 5.9? Considering i have a 98 with a 5.2.
95knight is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 4 (3 members and 1 guests)
cgcarpenter , harme6 , tjcustomranger
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 37 04-29-2016 10:36 PM
Let me tell you what I did not do today husker_zj ZJ Grand Cherokee Forum 9 03-19-2013 01:09 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM
Have you had your V-8 today?? Myrtle Beach ZJ Grand Cherokee Forum 12 04-30-2005 01:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome