What did you do to your ZJ today? - Page 1770 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > What did you do to your ZJ today?

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 10-26-2013, 11:43 AM   #26536
AnotherRedZj
Registered User
1997 ZJ 
 
Join Date: Feb 2012
Location: fort walton beach, fl
Posts: 1,625
Quote:
Originally Posted by smccloud View Post

I'm jealous of that. If you happen to find another one grab it for me. I want to get my damn spare out of the cargo area.....
Me too!

Love that look! Awsome a score! Oh and.....

images.jpeg

__________________
5.2 crate - fourwheelcustoms 2.25 BB - 31x10.50 BFG at-ko's 249/242 swap - front drive shaft upgrade by driveshaftspecialistincorporated - jcr off-road front bumper - engo 12k lbs winch......
AnotherRedZj is offline   Reply With Quote
Unread 10-26-2013, 12:52 PM   #26537
Hytek
Senior Member
1998 ZJ 
 
Join Date: Aug 2012
Location: Romeoville, IL
Posts: 791
Finished up installing my Bilsteins. Front was easier that the rear, I think only because one of the rear shock mounts got bent on a rock. What a big difference in ride quality over the hydro shocks. I love them. Thanks again HighLonesome for the good deal!

Hydro shocks for sale in classifieds.
__________________
98 5.9 Limited - IRO 3.5", IRO short arms track bars Bilsteins, Addco, JK wheels, 255-75/17 BFG, Magnaflow, Flowmaster
04 Limited 4.7H.O QD, UC+BB, Bilsteins, 245/75-16 Duratracs Addco sway bar
Hytek is offline   Reply With Quote
Unread 10-26-2013, 01:55 PM   #26538
somebody5788
Registered User
1994 ZJ 
 
Join Date: Aug 2008
Location: Warsaw, Indiana
Posts: 1,018
Ordered Bilstein 5100's, Rubicon Express 4.5" springs, RE SS lines, Rough Country Long Arm "upgrade" kit, Summit Racing 15x8 with 3.75 backspacing including a spare.

Already have my Flatland 4x4 bumpers cut out of some 3/16" steel, just need to weld them up install them.

$2150 overall, I don't think that's that bad at all. The 31" tires don't count as I got them a year ago and my old tires were shot.

Once the X-Flex joints in the RC long arms go out I'll get some Currie Johnny Joints to replace them.
__________________
2006 Honda 919 - Summer Daily
1994 Jeep ZJ - RC Long Arms | RE 4.5" springs | Bilstein 5100's | RE SS brake lines | Falken 31x10.5-15 tires | Flatland 4x4 bumpers | Summit Soft 8's 15x8 3.75 BS wheels
somebody5788 is offline   Reply With Quote
Unread 10-26-2013, 02:56 PM   #26539
95GCL
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: catharpin, VIRGINIA
Posts: 231
Past event for context:
Put fuel pump in 5gal bcket of gas, tested it. Good fuel pressure and truck ran after resetting alarm system.

*Long time later after getting a very bad bolt out and new bumper bar + bracket *

Finally, got the tank fully up and mounted. Battery used to be ok and wasnt draining but now loses its charge basically in 2-4hrs (dont know when that started occuring).
Tried starting it. Keeps failing and doesnt want to run really. Not getting any fuel pressure at engine.

Very annoyed since it should be working. It worked like 2months ago. Tried resetting alarm system but couldnt at all. Still not sure why im not getting fuel pressure, but battery is suspect even though it was hooked up to a charger doing 60amp 12v while trying to start. Ideas?

Also discovered my VC is actually working when previously thought it was broken
95GCL is offline   Reply With Quote
Unread 10-26-2013, 02:58 PM   #26540
WJ4x4LIFE
Registered User
 
Join Date: Sep 2012
Posts: 574
Quote:
Originally Posted by 95GCL View Post
Past event for context:
Put fuel pump in 5gal bcket of gas, tested it. Good fuel pressure and truck ran after resetting alarm system.

*Long time later after getting a very bad bolt out and new bumper bar + bracket *

Finally, got the tank fully up and mounted. Battery used to be ok and wasnt draining but now loses its charge basically in 2-4hrs (dont know when that started occuring).
Tried starting it. Keeps failing and doesnt want to run really. Not getting any fuel pressure at engine.

Very annoyed since it should be working. It worked like 2months ago. Tried resetting alarm system but couldnt at all. Still not sure why im not getting fuel pressure, but battery is suspect. Ideas?

Also discovered my VC is actually working when previously thought it was broken

ASD relay seems to be stuck open, causing power to run to your fuel system and causing issues. Both run together. CHECK IT OUT
WJ4x4LIFE is offline   Reply With Quote
Unread 10-26-2013, 03:04 PM   #26541
David97
Registered User
1995 ZJ 
 
Join Date: Dec 2012
Location: Wisconsin Dells, Wisconsin
Posts: 468
Spent $150 at O'Reillys lol

Sent from my SCH-I535 using JeepForum
David97 is offline   Reply With Quote
Unread 10-26-2013, 03:08 PM   #26542
WJ4x4LIFE
Registered User
 
Join Date: Sep 2012
Posts: 574
Quote:
Originally Posted by David97 View Post
Spent $150 at O'Reillys lol

Sent from my SCH-I535 using JeepForum
------------

Did you get those $5 back!
WJ4x4LIFE is offline   Reply With Quote
Unread 10-26-2013, 03:23 PM   #26543
David97
Registered User
1995 ZJ 
 
Join Date: Dec 2012
Location: Wisconsin Dells, Wisconsin
Posts: 468
Quote:
Originally Posted by WJ4x4LIFE View Post

------------

Did you get those $5 back!
I did.

My exhaust just broke too... so atm I'm running open headers till I can fix it

Sent from my SCH-I535 using JeepForum
David97 is offline   Reply With Quote
Unread 10-26-2013, 03:31 PM   #26544
Platinum5nine
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: Middle Island, NY
Posts: 510
All on my 97 5.2

Infinity kappa 3 way front speakers, Infinity reference 2 way rear speakers, bypassed the stock amp, kenwood radio, jbl amp, old school rockford xlc 10s, replaced the blower motor resistor module, painted the chrome grill flat black.
__________________
Platinum 5.9 2.25" engine pipes 3" Magnaflow cat, 3" Hooker Aerochamber, 3" tail pipe, Ported kegger, 52MM Throttle Body, 24lb injectors, K&N drop in filter, Cast JEEP valve covers, MSD coil and wires, All new 6 piece clear light kit, 255/65/16 General Grabber HTS, 242 conversion, XJ u-joint front axle shafts
Platinum5nine is offline   Reply With Quote
Unread 10-26-2013, 03:34 PM   #26545
David97
Registered User
1995 ZJ 
 
Join Date: Dec 2012
Location: Wisconsin Dells, Wisconsin
Posts: 468
Despite my exhaust breaking and falling off where my y-pipe joins, I got all the stuff I need for a oil change and tune up. Next week will be Tcase and diffs.

David97 is offline   Reply With Quote
Unread 10-26-2013, 03:48 PM   #26546
Hytek
Senior Member
1998 ZJ 
 
Join Date: Aug 2012
Location: Romeoville, IL
Posts: 791
Went to discount tire to get a tire swapped but they didn't have time. So went for a cruise instead. Really loving the new Bilsteins.
__________________
98 5.9 Limited - IRO 3.5", IRO short arms track bars Bilsteins, Addco, JK wheels, 255-75/17 BFG, Magnaflow, Flowmaster
04 Limited 4.7H.O QD, UC+BB, Bilsteins, 245/75-16 Duratracs Addco sway bar
Hytek is offline   Reply With Quote
Unread 10-26-2013, 03:56 PM   #26547
95GCL
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: catharpin, VIRGINIA
Posts: 231
Quote:
Originally Posted by WJ4x4LIFE View Post
ASD relay seems to be stuck open, causing power to run to your fuel system and causing issues. Both run together. CHECK IT OUT
Relays appear OK. Also were checked in the past and all were ok. Disconnected ground once battery had some charge. Will look tomorrow to see if it lost any of its charge
95GCL is offline   Reply With Quote
Unread 10-26-2013, 04:26 PM   #26548
smccloud
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: Becker, MN
Posts: 410
Quote:
Originally Posted by Platinum5nine View Post
All on my 97 5.2

Infinity kappa 3 way front speakers, Infinity reference 2 way rear speakers, bypassed the stock amp, kenwood radio, jbl amp, old school rockford xlc 10s, replaced the blower motor resistor module, painted the chrome grill flat black.
Got a diagram for bypassing the stock amp?
smccloud is offline   Reply With Quote
Unread 10-26-2013, 04:39 PM   #26549
Platinum5nine
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: Middle Island, NY
Posts: 510
Been installing stereos for 14 years so i do it with my eyes closed lol. I can write one up for you though, i just have to open the harness up again and pull the radio out quick. Gime a day or two.
__________________
Platinum 5.9 2.25" engine pipes 3" Magnaflow cat, 3" Hooker Aerochamber, 3" tail pipe, Ported kegger, 52MM Throttle Body, 24lb injectors, K&N drop in filter, Cast JEEP valve covers, MSD coil and wires, All new 6 piece clear light kit, 255/65/16 General Grabber HTS, 242 conversion, XJ u-joint front axle shafts
Platinum5nine is offline   Reply With Quote
Unread 10-26-2013, 04:41 PM   #26550
DeansWings
Registered User
1996 ZJ 
 
Join Date: Jul 2009
Location: Fort Worth, TX
Posts: 946
Wheeled it! Started an annual Grand Slam in Texas

__________________
'96 ZJ 4.0 NP242 5.5" Iron Rock Off Road Critical Path Long Arm sitting on 33x12.5x15 Goodyear Duratracs

'06 WK 3.7 2wd stock as a rock.

The Build:
[url]http://www.jeepforum.com/forum/f22/96-zj-build-1262449/[/url]

North Texas Grands:
[url]http://www.jeepforum.com/forum/f348/north-texas-grands-1323367/[/url]

Youtube wheeling vids (mostly from Bridgeport):
[url]http://www.youtube.com/user/MrDeanswings?feature=guide[/url]

Grand Slam Texas!:
[url]http://www.jeepforum.com/forum/f197/grand-slam-texas-1419143/index19.html[/url]
DeansWings is offline   Reply With Quote
Reply

Tags
door latch
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.