49Likes
 
LinkBack Thread Tools
post #21031 of Old 03-19-2013, 07:40 AM
OldManTan
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: TWIN PEAKS
Posts: 340
Quote:
Originally Posted by jeepgoonie View Post
Did you spray paint the Bezels? Looks awesome. I might have to do that soon.
Yupp
Painted the wood grain with plastidip. Looks factory.
The door trim is plastic welded in and you will have to drill out the welds. I used a soldering iron to melt the plastic tabs back together when I was re attaching them. worked great

Attached Thumbnails
pd.JPG  
OldManTan is offline  
post #21032 of Old 03-19-2013, 07:52 AM
riot1987
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Posts: 5,036
Quote:
Originally Posted by ejschultz View Post
Maybe I'll look into an LSD for the front in time then rather than the lunchbox locker. E-lockers are out of my price range so I won't be going that route.
I would run an LSD in front and lock the rear if I did it again. Or an air locked up front if i had the monies

http://www.jeepforum.com/forum/f22/riots-97-grand-1436100/

Build thread^^
riot1987 is offline  
post #21033 of Old 03-19-2013, 08:46 AM
95knight
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Waukesha
Posts: 495
Quote:
Originally Posted by comptiger5000 View Post

I'm guessing it's slipping?

So far, my stock 46RE is still going strong with no signs of giving up at 148k. No slippage at all, barks the tires into 2nd at WOT on dry pavement, shifts like a champ. It's been dealing with more than stock power for 29k now, and it's had a shift kit for 28k. I'll be turning up the line pressure a bit when I swap trans pans over the summer. I'm actually impressed with how well it's doing. It's got a big cooler on it, but I'm not exactly gentle with it. I drive it fairly hard on the street, I've drag raced it, towed with it and generally beaten on it and it just comes back asking for more.
Yaa she stuters, slips, and shifts hard...:-(

Sent from no where using JeepForum
95knight is offline  
post #21034 of Old 03-19-2013, 08:51 AM
970001zj
Registered User
1997 ZJ 
 
Join Date: Feb 2012
Posts: 2,596
tried to take off the passenger hub to replace the cv shaft and hub

got stuck on the 13mm's

291 k miles worth of rust fml
970001zj is offline  
post #21035 of Old 03-19-2013, 08:52 AM
95knight
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Waukesha
Posts: 495
Also anyone know why once in a while ill be going and unless and get it above 2500 rpms it doesnt want to shifts and then stutters between power and no power?? Is the wierdest thing to me and I dont have a clue on what it could be.

Happens only when warmed up 5 mins or already driven (never when bone cold then doesnt shift from third) but any temp and 1-2 and 2-3 and sometimes 3-4 but thats rare.

Its one of those annoying things.

Sent from no where using JeepForum
95knight is offline  
post #21036 of Old 03-19-2013, 09:00 AM
comptiger5000
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Rochester, NY
Posts: 4,556
Quote:
Originally Posted by 95knight View Post
Also anyone know why once in a while ill be going and unless and get it above 2500 rpms it doesnt want to shifts and then stutters between power and no power?? Is the wierdest thing to me and I dont have a clue on what it could be.

Happens only when warmed up 5 mins or already driven (never when bone cold then doesnt shift from third) but any temp and 1-2 and 2-3 and sometimes 3-4 but thats rare.

Its one of those annoying things.

Sent from no where using JeepForum
Check the adjustment of your TV cable. That being set wrong can cause the trans to do screwy stuff.
comptiger5000 is offline  
post #21037 of Old 03-19-2013, 09:03 AM
sevenscrew
Registered User
1997 ZJ 
 
Join Date: Mar 2011
Location: Hopatcong
Posts: 2,730
Last night I pulled a neighbor up a hill in the icy blizzard like condition we had

He gave me 50 bucks

My jeep didnt even spin the tires at all couldn't even tell he was back there lol

1997 Limited 5.2L Nelly - SOLD
1997 Limited 5.2L - new project
sevenscrew is offline  
post #21038 of Old 03-19-2013, 09:05 AM
95knight
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Waukesha
Posts: 495
Quote:
Originally Posted by comptiger5000 View Post

Check the adjustment of your TV cable. That being set wrong can cause the trans to do screwy stuff.
Well thats the cable coming off the throttle bracket correct? It did it sense i bought it but my dad broke the cable end...so gotta go to the stealership and pay $250.

Replacing those easy? Hard?

Sent from no where using JeepForum
95knight is offline  
post #21039 of Old 03-19-2013, 09:06 AM
S8NNG8
Web Wheeler
 
S8NNG8's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2012
Location: Helena
Posts: 7,752
Quote:
Originally Posted by 95knight View Post
Also anyone know why once in a while ill be going and unless and get it above 2500 rpms it doesnt want to shifts and then stutters between power and no power?? Is the wierdest thing to me and I dont have a clue on what it could be.

Happens only when warmed up 5 mins or already driven (never when bone cold then doesnt shift from third) but any temp and 1-2 and 2-3 and sometimes 3-4 but thats rare.

Its one of those annoying things.

Sent from no where using JeepForum
Your belts are slipping when they've expanded from the heat

D3<!L!>3D
S8NNG8 is offline  
post #21040 of Old 03-19-2013, 09:09 AM
comptiger5000
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Rochester, NY
Posts: 4,556
Quote:
Originally Posted by 95knight View Post
Well thats the cable coming off the throttle bracket correct? It did it sense i bought it but my dad broke the cable end...so gotta go to the stealership and pay $250.

Replacing those easy? Hard?

Sent from no where using JeepForum
I dunno how hard the whole thing is to replace, I've never done it. I've only had to adjust them.


Quote:
Originally Posted by S8NNG8 View Post
Your belts are slipping when they've expanded from the heat
No. First of all, V8 ZJs have auto-tensioners, so unless the tensioner is shot, the belt shouldn't slip. Also, that wouldn't cause what he's describing. At this point, with some of the other stupid crap you've said in here lately (unibody strength differences, etc.), I'm not sure if you're a troll or just an idiot.
comptiger5000 is offline  
post #21041 of Old 03-19-2013, 09:14 AM
nickpequignot
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: columbia city
Posts: 2,829
Rotated the tires.

96 limited build thread-http://www.jeepforum.com/forum/f13/96-limited-build-1351732/
nickpequignot is offline  
post #21042 of Old 03-19-2013, 09:25 AM
S8NNG8
Web Wheeler
 
S8NNG8's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2012
Location: Helena
Posts: 7,752
Quote:
Originally Posted by comptiger5000 View Post

I dunno how hard the whole thing is to replace, I've never done it. I've only had to adjust them.

No. First of all, V8 ZJs have auto-tensioners, so unless the tensioner is shot, the belt shouldn't slip. Also, that wouldn't cause what he's describing. At this point, with some of the other stupid crap you've said in here lately (unibody strength differences, etc.), I'm not sure if you're a troll or just an idiot.
The trolls and idiots are those of you I watch after. You sound surprisingly unsure of your own advice... idiot

D3<!L!>3D
S8NNG8 is offline  
post #21043 of Old 03-19-2013, 09:36 AM
nickpequignot
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: columbia city
Posts: 2,829
Quote:
Originally Posted by S8NNG8

The trolls and idiots are those of you I watch after. You sound surprisingly unsure of your own advice... idiot
I'm sure he knows a hell of alot more about these jeeps than you do if you think a slipping belt causes the tranny to shift weird...

96 limited build thread-http://www.jeepforum.com/forum/f13/96-limited-build-1351732/
nickpequignot is offline  
post #21044 of Old 03-19-2013, 09:44 AM
S8NNG8
Web Wheeler
 
S8NNG8's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2012
Location: Helena
Posts: 7,752
Quote:
Originally Posted by nickpequignot View Post

I'm sure he knows a hell of alot more about these jeeps than you do if you think a slipping belt causes the tranny to shift weird...
Actually, I don't really give a ****! That's why I got a 5spd I don't have any of the problems you have.

D3<!L!>3D
S8NNG8 is offline  
post #21045 of Old 03-19-2013, 09:54 AM
nickpequignot
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: columbia city
Posts: 2,829
Quote:
Originally Posted by S8NNG8

Actually, I don't really give a ****! That's why I got a 5spd I don't have any of the problems you have.
I don't have any problems...

96 limited build thread-http://www.jeepforum.com/forum/f13/96-limited-build-1351732/
nickpequignot is offline  
Reply


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
bojang
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 37 Yesterday 10:36 PM
Let me tell you what I did not do today husker_zj ZJ Grand Cherokee Forum 9 03-19-2013 01:09 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM
Have you had your V-8 today?? Myrtle Beach ZJ Grand Cherokee Forum 12 04-30-2005 01:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome