49Likes
 
LinkBack Thread Tools
post #18766 of Old 01-04-2013, 10:05 PM
thathubcapguy
Registered User
1996 ZJ 
 
Join Date: May 2012
Location: beverly
Posts: 164
finally found a junked black limited that wasn't smashed so i got my factory black grille!

thathubcapguy is offline  
post #18767 of Old 01-04-2013, 10:15 PM
98GCLimited
Registered User
1998 ZJ 
 
Join Date: Jun 2009
Location: LHC
Posts: 512
Quote:
Originally Posted by Okie_Rider View Post
Swapped in 703's. I love it
Nice. I am doing this myself soon just gathering a few more parts to tackle everything at once.

New exhaust manifold, gasket, driver side motor mount, 703s, possibly a 99+ intake mani.
98GCLimited is offline  
post #18768 of Old 01-05-2013, 02:20 AM
TRAVASS
Registered User
1996 ZJ 
 
Join Date: Aug 2011
Location: Oconomowoc
Posts: 531
Yesterday I replaced the Master Cylinder, drivers front hub and drivers front u-joint. I have a full brake pedal again! Woo Hoo!

But question. I had quite the front end wobble. The hub and u-joint took care of most of it. But I still get a slight wobble right near 40mph. And thats it. Under 35 nothing, over 45 nothing. Anyone had this before? Ideas?
TRAVASS is offline  
post #18769 of Old 01-05-2013, 02:42 AM
KillNThrill24
Registered User
1993 ZJ 
 
Join Date: Dec 2012
Location: Berea
Posts: 71
Quote:
Originally Posted by BigJohn96ZJ View Post
Just finsihed my sub install. Dual 10" pioneers pushed by a 1600 watt Boss amp. Im liking it so far. Only problem I had were with the remote wire there was no power on my radio harness so I picked an ignition fuse and ran it straight from the fuse box to the amp. also had to tear the dash apart to run my rca cables.
Yupp when I saw the compartment for the radio I started cussin lol. I knew the damn dash was comin off. What a PITA. To make matters worse the head unit I installed (Kenwood KVT-617) has a external hideaway unit that you have to run a monitor wire, radio antenna wire, and all the power/ground/ignition/speaker wires. It was such a freakin pain it took me almost 3 hours to get every little wire shortened, attached, and hidden. And I gave up on completely hiding everything lol I have about 5ft of 12 different wires all wound up under my passenger seat. NEVER again lol.

OT: I smacked the dang over head display a bunch of times trying to get it to turn on, and it didn't work. Also I burned through another quarter tank of gas in very few miles. The joys of terrible mileage. O well, nothin beats being in a vehicle that everyone on the road stops to look at
KillNThrill24 is offline  
post #18770 of Old 01-05-2013, 09:46 AM
virtuaopolis
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: calgary
Posts: 5
just picked up some oem stabilizer link bars. nothing major.
virtuaopolis is offline  
post #18771 of Old 01-05-2013, 11:45 AM
Midnightluckey
Registered User
1995 ZJ 
 
Join Date: May 2009
Location: Houston, TX
Posts: 1,324
Quote:
Originally Posted by TRAVASS
Yesterday I replaced the Master Cylinder, drivers front hub and drivers front u-joint. I have a full brake pedal again! Woo Hoo!

But question. I had quite the front end wobble. The hub and u-joint took care of most of it. But I still get a slight wobble right near 40mph. And thats it. Under 35 nothing, over 45 nothing. Anyone had this before? Ideas?
If you have a wobble that only shows itself in about a 10mph range, it usually has to do with an out of balance or out of round tire. I had out of round bfg's that did this. I'd start there.

95 Limited Chargold ZJ 5.2L -5.5" lift (IRO, Ironman, and RC parts), 33" BFG M/T's, 15x8 procomp crawlers, 242 swap, 2 12" subs, 1000w amp, cherry bomb, full skid package, Kevins rear stealth bumper clone w 3/4" D rings, Rlcwelding front bumper w 3/8" D rings, XRC-8, front tow hooks, 2 daylighter fairlead lights, 2 daylighter windsheild lights, 2 55w driving lights, OBA, Cobra 18 CB, dual 4' whips, RC disconnects, smittybuilt jack, optima yellowtop.
Built not bought #512
Midnightluckey is offline  
post #18772 of Old 01-05-2013, 02:23 PM
squazz
Web Wheeler
1993 ZJ 
 
Join Date: Jan 2010
Location: South Central
Posts: 2,200
many of you may remember this from a few years back



well today she decided to do it again



this time it was a KJ's fault not a taxi ............
squazz is offline  
post #18773 of Old 01-05-2013, 02:35 PM
JColee
Registered User
1997 ZJ 
 
Join Date: Oct 2011
Location: Logansport
Posts: 602
Drove four hours round trip to pick up my new daily driver for school. Hello twice the gas mileage!

JColee is offline  
post #18774 of Old 01-05-2013, 02:35 PM
txbass06
Registered User
1998 ZJ 
 
Join Date: Dec 2012
Location: Texarkana
Posts: 602
Drove it to grab a bite to eat and sat in the driveway for about an hour thinking about how I want to wire up my lights, where I wanted to mount the switch and if I really wanted to spend more money on a 5th hella
txbass06 is offline  
post #18775 of Old 01-05-2013, 03:20 PM
RJZJ
Registered User
1993 ZJ 
 
Join Date: May 2011
Location: Robinson Creek
Posts: 78
Did the tj gas filler with locking cap. BTW that is fresh bedliner is why it so shiny
Attached Thumbnails
ForumRunner_20130105_171850.jpg  

93 ZJ, 3.5 RC lift, 31x10.50x15, 3/4 coil spacers, bilstein 5100's, Kolak 2.5 exhaust, 703 injectors, bedliner paint job, clear front lights , Black Magic's on bumper and a pillars
RJZJ is offline  
post #18776 of Old 01-05-2013, 05:49 PM
LordHobbit
Registered User
1993 ZJ 
 
Join Date: Aug 2009
Location: Oregon
Posts: 2,029
I really really wanted cleaner looking turn signal lenses so I slid into an exploder in the hardware store parking lot and broke the drivers side.



Lady was in her exploder, and was so kind. It was a very slow bump and no damage otherwise, so she shrugged it off and left. Still upset about it. Ordered new ones from ebay.

93 red ZJ 190k 4.0. Spent more money than I should have ...

Isn't red the only color a vehicle should be?
If at first you don't succeed, use more speed.
LordHobbit is offline  
post #18777 of Old 01-05-2013, 05:58 PM
AnotherRedZj
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: fort walton beach
Posts: 2,344
Quote:
Originally Posted by Roskoe View Post
172 on the clock
Right about where mine was when the timing chain exploded! My the jeep gods keep you safe!

96 ZJ sittin up 6" on 35's with 4:56's and a 12k winch. Cuz...why the hell not!?
AnotherRedZj is offline  
post #18778 of Old 01-05-2013, 06:05 PM
noodles5124
Registered User
 
Join Date: Feb 2011
Location: danbury
Posts: 723
Blew up my 10" type r so I went and bought a 12" Polk dxi 112. Wired to an alpine mono 500w and grabbed another alpine 4 channel for the speakers...sounds excellent
noodles5124 is offline  
post #18779 of Old 01-05-2013, 06:09 PM
txbass06
Registered User
1998 ZJ 
 
Join Date: Dec 2012
Location: Texarkana
Posts: 602
Got the first of many boxes of parts for it today. Swapping headlights in the am

txbass06 is offline  
post #18780 of Old 01-05-2013, 06:12 PM
jeepgoonie
Registered User
2008 XK Commander 
 
Join Date: Nov 2011
Location: Hawthorne
Posts: 437
Dropped the trans, brought it to a Trans shop. Was helping the guy take it apart and wow, so many broken gears, cracked drum, solenoids shot.. Getting it rebuilt and new torque converter. Gonna upgrade the gears in the axle in the coming weeks to put less stress on the damn trans. Luckily the guy isn't charging me full price. so should be putting the drivetrain back in by Tuesday and other things like rear main, both pan gaskets, motor and Trans mount, new starter meanwhile there's space under the truck

Just Empty Every Pocket
jeepgoonie is offline  
Reply


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
GOLDWING
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 37 Yesterday 10:36 PM
Let me tell you what I did not do today husker_zj ZJ Grand Cherokee Forum 9 03-19-2013 01:09 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM
Have you had your V-8 today?? Myrtle Beach ZJ Grand Cherokee Forum 12 04-30-2005 01:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome