werid sound coming from engine - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 02-16-2006, 04:48 PM Thread Starter
grandsteel98
Registered User
 
Join Date: Nov 2005
Location: columbus, ohio
Posts: 23
werid sound coming from engine

there is constant ting sound coming from my engine when im drive and when im idoling it sound like the sound the car makes when you turn it off and it is cooling down. does anyone what the problem could be? thanks

grandsteel98 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-16-2006, 05:05 PM
360limited
Registered User
 
Join Date: Feb 2006
Location: Milwaukee, WI
Posts: 70
could be detonation what motor do you have?
360limited is offline  
post #3 of 6 Old 02-16-2006, 06:17 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
What is the frequency of the sound? Is it rpm related or does it happen like every five seconds? Does it happen all of the time or only at idle?

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #4 of 6 Old 02-16-2006, 06:18 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
oh yea ... what freckin engine do you have ???

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #5 of 6 Old 02-17-2006, 10:28 PM Thread Starter
grandsteel98
Registered User
 
Join Date: Nov 2005
Location: columbus, ohio
Posts: 23
i have a 4.0L, it happens all the time idoling and driving, i think it is the water pump.
grandsteel98 is offline  
post #6 of 6 Old 02-17-2006, 10:33 PM
BradBurdett
Registered User
 
Join Date: Nov 2004
Location: Bay Area
Posts: 214
did you pop the hood while in park to see where the noise is comming from...if its acutally the engine because mine makes ticking sounds at idle and its the evap purge solinoid not the engine on my 4.0L

1995 ZJ 4X4
command-trac (NP231) with SYE
K&N FIPK intake
RE 6.5in lift with 33X12.5 BFG MT and no Rear Sway bar
4.56 gears--axle swap soon
BradBurdett is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
'94 Grand Cherokee chirping sound coming from engine? 81Euro ZJ Grand Cherokee Forum 9 07-31-2010 07:54 AM
My ZJ has a bad 'rattling' sound coming from the rear... athomas08 ZJ Grand Cherokee Forum 1 03-07-2009 11:15 PM
whirling sound coming from front end 2000 wj ZJ Grand Cherokee Forum 15 10-25-2007 07:49 PM
squeaking sound coming from right front wheel? RMF001 ZJ Grand Cherokee Forum 13 09-27-2007 01:17 PM
slight growling sound coming from front end cliff WK Grand Cherokee & XK Commander Forum 3 10-20-2006 08:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome