Well crap lol - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 06-09-2010, 11:55 AM Thread Starter
kentever
Registered User
2000 WJ 
 
Join Date: Aug 2002
Location: Texas
Posts: 44
Well crap lol

Ok this morning going to work my jeep ran fine but died right before i turned into the parking lot, it started right back up and everything under the hood looked fine. When I left it started fine and drove like normal. Engine temp. oil pressure and everything normal the whole way home until I was about to take my exit. It started tapping and then died right before I got pulled over and would not start back up. I checked the radiator and the cap was cool enough to take off and my overflow tank is still full. I put some water in and it poured straight out the bottom when I got underneath I notice my drain valve is now missing. So I lost all my water and I guess the engine overheated but going by the guage inside it never even got to normal running temp so i didnt know until it started knocking. I tryed to jump it off just so I could get it the 1/2 block to my house and would not even turn over. I let it cool down and started it, runs horrible but I got it into my driveway now. So obviously I need to fix/replace the radiator but what damage is done to my engine and whats making the noise? There is no water in the oil that I can see and the level is fine and not leaking anything underneath except water. Any thoughts?


2000 Grand Cherokee Limited 4.7 V8
Heater Treater fixed!!
kentever is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-09-2010, 11:58 AM
JJAMISON_
Registered User
2015 JK Wrangler 
 
Join Date: Dec 2009
Location: Tuscaloosa
Posts: 1,524
your engine temp sensor works off of the water temp basically so no water= no temp. I would go change the oil for GP, check the belts, maybe even check all the hoses. running out of water shouldn't make it run that bad unless the computer caught it and the code is in there. ???? i dunno.

__________________
JJAMISON_ is offline  
post #3 of 3 Old 06-09-2010, 12:10 PM Thread Starter
kentever
Registered User
2000 WJ 
 
Join Date: Aug 2002
Location: Texas
Posts: 44
Raining now so ill wait till later yeah that makes sence about the temp but my temp didnt drop it was just a little below normal when it died. No lights on the dash ever came on and i just checked there are no codes in it now.

2000 Grand Cherokee Limited 4.7 V8
Heater Treater fixed!!
kentever is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
ah crap...what did i do trailblaze WJ Grand Cherokee Forum 7 03-25-2010 08:42 PM
intake crap. trailblaze ZJ Grand Cherokee Forum 0 02-22-2009 08:12 PM
Oh crap, I think I'm screwed! Shinner ZJ Grand Cherokee Forum 26 08-21-2008 09:15 PM
Done With K&N Crap wjs81866 ZJ Grand Cherokee Forum 13 10-17-2006 04:04 PM
what the crap ?! randyszj94 ZJ Grand Cherokee Forum 20 01-14-2006 01:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome