Reply
 
LinkBack Thread Tools
post #1 of Old 04-16-2009, 12:26 AM Thread Starter
Got2HaveLights
Registered User
 
Join Date: Jan 2006
Location: Norwich, CT
Posts: 85
Weird sound coming from pass side dash (possible heater core issue?)

I have had my 02 WJ for about a year and a half now, and half been lucky enough not to have any problems until now. When I start my jeep I hear what sounds like fluid rushing through my dash (mostly on the pass side, maybe behind my glove box). When I step on the gas, it sounds like the fluid is rushing faster, and about a min or two later it is gone. It seems to only do it after the jeep has been sitting for a while like overnight or when I get out of work. I have no leaks inside or on the ground under the jeep. My heat and AC both work fine. I am completely stumped on this, and thoughts would be very helpful. Oh, and I have the 4.7l motor with the standard heating controls.

Thanks
Ray

Got2HaveLights is offline  
post #2 of Old 04-16-2009, 01:09 AM
sandman
Registered User
1993 ZJ 
 
Join Date: Apr 2007
Location: Wilsonville, Oregon
Posts: 5,354
could be a heater core leak or could be a leak anywhere in the system. i would start by finding the leak with some dye. a small leak wont leave a puddle.

1993 Jeep ZJ. 4.0
sandman is offline  
post #3 of Old 04-16-2009, 02:20 AM
jeepheller98
Registered User
1998 ZJ 
 
Join Date: Mar 2008
Location: park ridge
Posts: 1,089
check you coolant level, i know that exact sound, my sisters got the same jeep

98 ZJ 3" lift homemade snorkel. JKS quicker disco 5.2L 150,000, 31x10.5 pro comp muds
jeepheller98 is offline  
post #4 of Old 04-16-2009, 07:57 AM
Airborne Lee
Registered User
 
Airborne Lee's Avatar
2013 JK Wrangler 
 
Join Date: Sep 2005
Location: Lee's Summit
Posts: 1,151
Welcome to my world. This is exactly my issue.

http://www.jeepforum.com/forum/f13/missing-leak-751373/

I DO NOT have ANY indication of a leak. there is ZERO under the WJ sitting idle or after driving down the road. I had a presure check done and still NO indication of a leak. Still I have a 1-2 quart drop in fluid every few days.

I am certain it is the core because I have had a leak in everything else and replaced everything else over the years and this is different. Radiator, hoses, block, all left puddles and were easy to find.

please buy this NEW IN BOX:JK Rugged Ridge Light Bar
2013 JK Rubicon, Commando Green, CB, GPS, KC lites
KC Jeep Club Info - M416 Trailer Project
3 Previous Jeeps - 01 WJ Ltd, QD & UC - 01 WJ Ltd, QT II - 98 XJ Ltd
Airborne Lee is offline  
post #5 of Old 04-16-2009, 04:53 PM Thread Starter
Got2HaveLights
Registered User
 
Join Date: Jan 2006
Location: Norwich, CT
Posts: 85
Thanks for all the quick replies. I have always kept a eye on all my fluid levels, and my coolant is one fluid that I have never had to top off. It is exactly at the full mark. Does anyone else have any ideas??
Got2HaveLights is offline  
post #6 of Old 04-16-2009, 06:24 PM
XrynoX
Registered User
2002 WJ 
 
Join Date: Jan 2009
Location: Northern Ontairo
Posts: 130
bump cause i have the same noise!! my coolant is never low. i had the leak dye put in and tested with no results. only difference is i have the automatic climate control. blend doors were replaced before i purchased it. i'm at a loss, everything works. maybe just turn your radio up, always works for me...
XrynoX is offline  
post #7 of Old 04-16-2009, 07:11 PM
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 4,569
Hmmm...
Radiator cap is leaking might not show up in a pressure test. The resulting dye going all over the underside of the hood and around the radiator should tell the story though, right?

or
When y'all are adding water back to the system, are you using the overflow tank or filling through the radiator cap?

Have you also checked under the carpet on the passenger side for any wet areas? Got any oily film on the inside of the windshield?

2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline  
post #8 of Old 04-16-2009, 07:19 PM
SAR-Swimmer
Senior Member
1997 ZJ 
 
Join Date: Apr 2009
Location: Mission
Posts: 903
I get the same noise in my 95 5.2 zj, no other simptoms of leaking or anything else though.
SAR-Swimmer is offline  
post #9 of Old 04-16-2009, 08:37 PM
XrynoX
Registered User
2002 WJ 
 
Join Date: Jan 2009
Location: Northern Ontairo
Posts: 130
Quote:
Originally Posted by Double E View Post
Got any oily film on the inside of the windshield?
yep, just went out and checked, my buddy mentioned that to me the other day, oily film just on the passenger side. shouldn't the dealer have caught this?
XrynoX is offline  
post #10 of Old 04-17-2009, 06:41 AM Thread Starter
Got2HaveLights
Registered User
 
Join Date: Jan 2006
Location: Norwich, CT
Posts: 85
Ok, so this oily film on my windshield, is it going to be on the inside or outside of my jeep? If I have this film, what does it mean? One other symptom I forgot to mention is when I have the heat on Vent, I get this clicking sound from the pass side dash. I have no clue if this is related, but I thought that I would throw it out there. Oh, I have check my pass carpet, and they are completely dry.
Got2HaveLights is offline  
post #11 of Old 04-17-2009, 07:55 AM
ZJ_Papa
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Location: Hudson, MA
Posts: 105
Yea mine had a bad cap got the beast refilled air bubbled out and replaced the cap and she's good

"Any man can be a father it takes a real man to be a dad!!"

1997 Jeep Grand Cherokee 4.0L Stocker: My DD
2002 Toyota Camry: R.I.P It was a great car
ZJ_Papa is offline  
post #12 of Old 04-17-2009, 05:55 PM
1998JEEPZJ
Registered User
 
Join Date: Apr 2009
Location: Cumberland RI
Posts: 76
Same issues with my Jeep no signs of anything that would cause concern, sound only started after I changed the radiator, cap was changed as well. Might be air in the system.
1998JEEPZJ is offline  
post #13 of Old 04-17-2009, 10:33 PM
sandman
Registered User
1993 ZJ 
 
Join Date: Apr 2007
Location: Wilsonville, Oregon
Posts: 5,354
Quote:
Originally Posted by Got2HaveLights View Post
Ok, so this oily film on my windshield, is it going to be on the inside or outside of my jeep? If I have this film, what does it mean? One other symptom I forgot to mention is when I have the heat on Vent, I get this clicking sound from the pass side dash. I have no clue if this is related, but I thought that I would throw it out there. Oh, I have check my pass carpet, and they are completely dry.
oily on inside, means leaky heater core. as for the noise, search blend doors, that may be your problem.

1993 Jeep ZJ. 4.0
sandman is offline  
post #14 of Old 04-20-2009, 09:40 PM
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 4,569
Mine took a couple of weeks after replacing the radiator to purge the air out. I did it all so my purge efforts probably did not follow the book.

For you cats that have the film on the inside of the windshield, it's likely a heater core issue and you need to fix it soon as you can. Once ethelyene glycol gets into the human body some bad shiznit happens. Google, discuss or look it up in a part store MSDS if you need but get it fixed after you do....ok?

2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline  
post #15 of Old 03-07-2013, 09:46 AM
wpatters1229
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2011
Location: Martinez
Posts: 65
how do you purge the air out of the heater system?

I read all these sysptms about hear rushing water when the system is cold but how do you purge the air out of the system? I replaced a bad water pump. New hoses but no leaks or having to add water. The sound goes away after the water is fully heated and the heater is turned on.
wpatters1229 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Weird heater issue-question lma1973 ZJ Grand Cherokee Forum 2 03-03-2009 08:20 PM
94 laredo, radio went out,clicking sound on pass. side, please help z4two0 ZJ Grand Cherokee Forum 1 11-26-2008 11:56 AM
Driver side stereo sound quieter than pass. side mrbell83 ZJ Grand Cherokee Forum 0 05-20-2008 06:45 PM
Wet pass side floor mat?? (98 GC) TransAm87WS6 ZJ Grand Cherokee Forum 4 06-10-2006 09:33 AM
Heater Issue...Got the right side..no left 383Z28 ZJ Grand Cherokee Forum 3 10-29-2005 08:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome