Weird OD problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 02-24-2008, 07:26 PM Thread Starter
Mustang5ohhh
Registered User
 
Join Date: Aug 2002
Posts: 10
Weird OD problem

I think I already know the answer but wanted to see if it could be something else.

My 95 GC on the highway ... all of a sudden loses OD, the speedo goes to 0 and then within a matter of seconds ... the speedo jumps back to speed and the OD kicks back in.

In my experience ... this would be a VSS. Could it be something else ? Doesn't do it in any other gear ... that I've noticed.

Thanks in advance.

Rich

Mustang5ohhh is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-24-2008, 07:59 PM
95ZJ-tilshedies
Registered User
1995 ZJ 
 
Join Date: Mar 2007
Location: Georgia
Posts: 78
Does the engine actually stop running, or do the gages just quit?

-Steve
'95 ZJ -- 4.0L Selec-Trac stocker (~150,000) -- SOLD '08
'93 XJ --- RIP '04
"Excellence that must be proclaimed, by the mere fact of its proclamation, admits the doubt of its existence”
95ZJ-tilshedies is offline  
post #3 of 5 Old 02-24-2008, 08:32 PM Thread Starter
Mustang5ohhh
Registered User
 
Join Date: Aug 2002
Posts: 10
No ... just drops a gear.
Mustang5ohhh is offline  
post #4 of 5 Old 02-24-2008, 08:39 PM
Virmagicus
Moderator
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,440
I would also say vehicle speed sensor. Have you pulled the DTC's ?
Virmagicus is offline  
post #5 of 5 Old 02-24-2008, 08:43 PM
Virmagicus
Moderator
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,440
See if you get a code 13.
Virmagicus is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Weird Problem hunchback ZJ Grand Cherokee Forum 3 08-09-2009 11:09 AM
weird AC problem... Dillonzj ZJ Grand Cherokee Forum 4 08-06-2008 11:51 AM
Weird Problem hunchback ZJ Grand Cherokee Forum 2 05-01-2008 08:45 AM
'93 zj weird problem grosdeutschland ZJ Grand Cherokee Forum 4 12-29-2007 04:06 PM
My weird problem with GC CRD 2007OVERLANDCRD WK Grand Cherokee & XK Commander Forum 12 10-08-2007 07:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome