Weird Engine Bog - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Weird Engine Bog

Clayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank SkidTJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 05-23-2011, 09:34 PM   #1
Cutlass
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: , New York
Posts: 282
Weird Engine Bog

Okay so for a while now when i turn hard right or left my engine bogs feels like the transmission wont get in gear but it also feels like its gonna stall. Ive replaced the engine so it really cant be that and i dont see why my tranny would do that only when i turn??? ANYONE HAVE A CLUE

Ohh its a 4.0 I6

Cutlass is offline   Reply With Quote
Unread 05-23-2011, 10:13 PM   #2
Cutlass
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: , New York
Posts: 282
grrrr anyone haha
Cutlass is offline   Reply With Quote
Unread 05-23-2011, 11:08 PM   #3
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,193
have you looked at your engine and tranny mounts yet ???
phitmein is offline   Reply With Quote
Unread 05-23-2011, 11:18 PM   #4
Cutlass
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: , New York
Posts: 282
well the engine mounts are good havnt checked tranny mountsss
Cutlass is offline   Reply With Quote
Unread 05-24-2011, 01:52 AM   #5
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,193
The reason I asked was I wondered if something in the drivetrain was shifting and binding when you are turning ...

or maybe the power steering pump straining the motor at full turns ???

Just some thoughts ...
phitmein is offline   Reply With Quote
Unread 05-24-2011, 06:02 AM   #6
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,796
low trans fluid level.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Unread 05-24-2011, 10:32 PM   #7
Cutlass
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: , New York
Posts: 282
alright il check all this out tomorrow thanks guys anyone else have this issue though?
Cutlass is offline   Reply With Quote
Unread 05-25-2011, 03:55 PM   #8
Cutlass
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: , New York
Posts: 282
bummmmmmmmmmmmmmmmmmmmmmmmmp
Cutlass is offline   Reply With Quote
Unread 05-25-2011, 07:09 PM   #9
Erek.Smith
Registered User
1995 ZJ 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 355
I think I'm experiencing the same thing. It'll be nice to find a solution.
__________________
White 2WD 1995 ZJ 4.0
Jesus the Christ is my Lord and Savior. I know Him, do you?
Future Mods: get it working correctly
Essential gear for America's heroes
Erek.Smith is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.