weird 5.2 problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 08-14-2013, 10:09 AM Thread Starter
loodi
Registered User
 
Join Date: Jul 2013
Location: labinci
Posts: 56
weird 5.2 problem

happened 4 times since yesterday. driving 40-50mph in a straight line on LPG, suddenly a very short, half a second stuttering occurs, gas needle drops to min and nothing else happens. i try to switch from lpg to gasoline back and forth a few times, it just runs normally on both. no changes at all.
so nothing bad except this weird short hiccup and the needle drops down to 0.

all 4 times it was like this for about 5mins drive and then it just gradually starts to rise again.

any ideas?

loodi is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-14-2013, 10:12 AM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
You're running on LP? That's awesome. No idea though, sorry.
zj97ltd is offline  
post #3 of 5 Old 08-14-2013, 10:49 AM
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 6,772
Electrical for sure.

Fuel pump ground or 12v? That would explain the stutter and the gauge dropping.

Verify the fuel pump and ASD relays.
HighLonesome is online now  
post #4 of 5 Old 08-14-2013, 10:51 AM Thread Starter
loodi
Registered User
 
Join Date: Jul 2013
Location: labinci
Posts: 56
Asd?
loodi is offline  
post #5 of 5 Old 08-14-2013, 12:04 PM
sebian
Registered User
1995 ZJ 
 
Join Date: Sep 2009
Location: Austin
Posts: 1,511
I am not read up on the LPG conversions, but I thought the LPG and Petrol had different tanks, which would require separate pumps?

As Highlonesome said, it probably is a bad ground somewhere. Do they share a common ground, or power source?

Edit: ASD is the auto shut-down relay. When it goes out, Jeep doesn't start.

1995 ZJ 5.2L V8 318. 230,000 miles and still rollin.

List of parts not replaced yet:
...
sebian is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome