VIC and Tranny problem - seem to be connected - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > VIC and Tranny problem - seem to be connected

Labor day sale @ rockridge 4wd! 8/29-9/1 site wide..promo Rough Country Deals at JeepHut.comShocktober is here! Get new shocks for your Jeep!!!!

Reply
Unread 07-18-2013, 02:13 PM   #1
CaseyC
Registered User
1994 ZJ 
 
Join Date: Jun 2006
Location: Houston, Texas
Posts: 127
VIC and Tranny problem - seem to be connected

94 ZJ 4.0 42RE trans
Intermittently (3 times sofar this year) the transmission fails to shift into overdrive. One, two, three shifts are working ok. I get a trouble code of 23 when this happens. At the same time, about 15 seconds after starting the engine, the VIC resets and starts flashing. Problem occured yesterday and I drove around most of the morning today and it would not go into OD. This afternoon started working again, and the VIC is not resetting anymore.

Can anyone help with suggestions as to what I should look at?

Thanks.......

CaseyC is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.