VIC engine symbol? - Page 2 - JeepForum.com

 1Likes
Reply
 
LinkBack Thread Tools
post #16 of 19 Old 09-20-2013, 09:17 AM
Aceladriver
Member
 
Join Date: Sep 2006
Location: Boston
Posts: 407
Good tips on the VIC fix ^


Quote:
Originally Posted by e46fanatic View Post
I just bought a ZJ a few weeks ago and I have a question about the VIC. It said my coolant temp sensor was bad, but I replaced the sensor and it went away. ?
VIC warnings are only for the level in the reservoir - but you already figured that out I guess


Quote:
Originally Posted by zjosh93 View Post
The engine also lights up for low oil if you have the oil level sensor but it also usually says "Engine Oil Low" or "Check Engine Oil" or something like that. ......
Pretty sure 93 is the only year with the oil level sensor. I think it went away for 94 or 95


Happiness is clear in the cab and 150 over 150.
Aceladriver is offline  
Sponsored Links
Advertisement
 
post #17 of 19 Old 05-23-2016, 07:10 AM
MikeiVan
Registered User
 
Join Date: May 2016
Location: De Witt
Posts: 2
97 ZJ VIC and Cluster Issues

All, Recently bought a 97 grand Cherokee for my son, 79000 miles. We see a lot of the same issues with flashing VIC, engine coolant and washer fluid indicators on the VIC even though they are full. So, when people say bad solder joints, are we talking bad solder joints in the connector at the end sensor, or in the VIC?

Also, we have a deal where we will be driving down the road, and every gauge in the cluster drops to zero. We drive like that with no gauges for a few minutes, then everything comes to life, all dummy light s flash as if you just turned the ignition on, and it goes back to normal. Any ideas on this one> Other than the intermittent coolant and washer level indicators, no other faults or lights. Thanks in advance!
MikeiVan is offline  
post #18 of 19 Old 05-23-2016, 03:50 PM
kg6mov
Hears the voices
 
kg6mov's Avatar
1996 ZJ 
 
Join Date: Nov 2012
Location: Cupertino
Posts: 11,392
Yes, solder joints inside the VIC.

Cluster issues could be confusion from a dying VIC on the CCD bus or just a drop in power. Does the overhead trip computer die when the cluster does?

1996 ZJ Green Laredo V8, 2.5" OME and Bilsteins, 33's, Holes drilled in the roof.
1998 ZJ 5.9 - Junked
1984 F250, 460 BB, T19, work truck/future tow pig
1987 Mercedes 300D Turbo, the diesel daily, 30mpg in style

Quote:
Originally Posted by Texas ZJ1 View Post
I heard someone yell "mall crawler" from the back porch. I'll go see who said that. Be right back.
kg6mov is online now  
post #19 of 19 Old 06-08-2016, 02:29 PM
MikeiVan
Registered User
 
Join Date: May 2016
Location: De Witt
Posts: 2
Thanks,I guess we didn't notice what the overhead was doing, will need to watch for that.
MikeiVan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome