vent or vacum problem?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > vent or vacum problem??

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineHalloween Savings to die for!We have Engo 10k Synthetic IN STOCK!!! Hurry while supplie

Reply
Unread 07-19-2012, 10:51 AM   #1
unkleabe55
Registered User
 
Join Date: Jul 2012
Location: raytown, mo
Posts: 3
vent or vacum problem??

hi
i have a 96 Grand Cherokee Laradeo 6 banger
when i accelerate my vent doors slam shut and the defrost doors open
when i let off the gas they go back to normal
it also has developed a slight miss also
any ideas???????????

unkleabe55 is offline   Reply With Quote Quick reply to this message
Unread 07-19-2012, 12:04 PM   #2
youngjeepr
Registered User
1988 YJ Wrangler 
 
Join Date: Aug 2009
Location: layton UT
Posts: 2,249
Does it do it when you rev the engine or just when you move?
__________________
88 YJ- 4.7l stroker, AW4, SOA, 8.8, hp D30 powertrax no slip,3" front stretch with waggy springs, stock replacement springs in the rear, 35/12.5 r15 goodyear kevlars

Utah Jeep Crew



Build Thread
youngjeepr is offline   Reply With Quote Quick reply to this message
Unread 07-19-2012, 12:33 PM   #3
unkleabe55
Registered User
 
Join Date: Jul 2012
Location: raytown, mo
Posts: 3
when i accelerate
unkleabe55 is offline   Reply With Quote Quick reply to this message
Unread 07-19-2012, 12:38 PM   #4
youngjeepr
Registered User
1988 YJ Wrangler 
 
Join Date: Aug 2009
Location: layton UT
Posts: 2,249
If its only when you start to move then It would be a vent problem.. If it does it when the engine RPM goes up whether your moving or not it could be vacuum.
__________________
88 YJ- 4.7l stroker, AW4, SOA, 8.8, hp D30 powertrax no slip,3" front stretch with waggy springs, stock replacement springs in the rear, 35/12.5 r15 goodyear kevlars

Utah Jeep Crew



Build Thread
youngjeepr is offline   Reply With Quote Quick reply to this message
Unread 07-20-2012, 12:06 AM   #5
camelracer
Registered User
1951 CJ3A 
 
Join Date: Jun 2012
Location: Goleta, Ca
Posts: 27
You've got a vacuum leak somewhere or a bad check valve.
camelracer is offline   Reply With Quote Quick reply to this message
Unread 07-21-2012, 07:49 AM   #6
unkleabe55
Registered User
 
Join Date: Jul 2012
Location: raytown, mo
Posts: 3
i also need a map sensor does anybody know what parts cross reference for a 96 GC laradeo 6cyl??
unkleabe55 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.