Vehicle Display Screen - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Vehicle Display Screen

Jeep LED Light Lights! OCONEE OFF-ROAD 706-534-9955Ledlight bar light locks @ oconee off road 706 534 9955Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 01-02-2009, 01:00 PM   #1
dpoane
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: kennesaw
Posts: 7
Vehicle Display Screen

I have a 95 grand cherokee ltd and the original vehicle display doesnt work or atleast i thought it didnt. So i went and bought a new one n put it in, and it still doesnt work. Could it be the wiring or something else.

dpoane is offline   Reply With Quote
Unread 01-02-2009, 01:02 PM   #2
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
Search VIC. See what you can find, what type do you have? The one with the jeep in the center of off to the side?
JeepOrvis97 is offline   Reply With Quote
Unread 01-02-2009, 01:49 PM   #3
dpoane
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: kennesaw
Posts: 7
The jeep is off to the side
dpoane is offline   Reply With Quote
Unread 01-02-2009, 01:50 PM   #4
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
It doesn't come on at all? could just be a fuse.
JeepOrvis97 is offline   Reply With Quote
Unread 01-02-2009, 02:03 PM   #5
dpoane
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: kennesaw
Posts: 7
yea it doesnt come on at all. Where would that fuse be located?
dpoane is offline   Reply With Quote
Unread 01-02-2009, 02:05 PM   #6
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
Passenger side kick panel. It may be linked to something else so check the owner's manual. The little sticker on the back of the fuse panel door isn't informative enough.
JeepOrvis97 is offline   Reply With Quote
Unread 01-02-2009, 02:50 PM   #7
MAUSS
Registered User
1996 ZJ 
 
Join Date: Aug 2005
Location: Charlottesville, Virginia
Posts: 786
If it's like the '96, it's Fuse 20 (15 Amp). The only thing it feeds is the VIC.
__________________
'93 Limited (sold), '96 Laredo
MAUSS is offline   Reply With Quote
Unread 01-03-2009, 01:28 PM   #8
dpoane
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: kennesaw
Posts: 7
Thanks for the help everyone PROBLEM IS SOLVED!
dpoane is offline   Reply With Quote
Unread 01-03-2009, 01:39 PM   #9
spife7980
Registered User
1997 ZJ 
 
Join Date: Nov 2007
Location: Central Texas
Posts: 3,144
well what was it? the fuse?
__________________
-James
Got to love an ORVIS guy...
IRO 5.5", Front LA & Double Sheer TB, Rear Adj SA and TB, JKS Quick Discos, Bilstein 5125, 265/75/16 Nitto Terra's, Cragar 16x& Soft 8s 4" bs
JCR Stage 2 Sliders, IRO Trans Skid, Carolina Drive shaft, IRO exhaust
spife7980 is offline   Reply With Quote
Unread 01-03-2009, 11:22 PM   #10
dpoane
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: kennesaw
Posts: 7
Yea it was the fuse. But now when i turn on my headlights the VIC flashes rear lamp failure, i checked the lamps and they all work whats wrong now?
dpoane is offline   Reply With Quote
Unread 01-03-2009, 11:29 PM   #11
madrabbitt
Registered User
 
Join Date: Feb 2004
Location: Albuquerque
Posts: 8,822
you have 2 dual intensity bulbs, two 5w marker lights, and either two or three 16 watt bulbs in the center brake light.

Even one of these out will cause the indicator.

Usually its both of the 5 watters, and since they're both out, you dont notice.
__________________
Installing HID's in stock housings is bad. Here is why.

"When you see someone who needs help, help them. When you see someone who needs a hug, hug them... Help those who can't help themselves." -Sgt Andrew Tingwall, NMSP. End of watch 6-10-2009
madrabbitt is offline   Reply With Quote
Unread 01-03-2009, 11:48 PM   #12
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
That sucks that you bought a new one when it was just the fuse. Oh well, at least it works now.
JeepOrvis97 is offline   Reply With Quote
Unread 01-03-2009, 11:51 PM   #13
madrabbitt
Registered User
 
Join Date: Feb 2004
Location: Albuquerque
Posts: 8,822
Well, if he's smart, he'll sell one of 'em.
__________________
Installing HID's in stock housings is bad. Here is why.

"When you see someone who needs help, help them. When you see someone who needs a hug, hug them... Help those who can't help themselves." -Sgt Andrew Tingwall, NMSP. End of watch 6-10-2009
madrabbitt is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.