Usual oil leak spots in a 5.2? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 04-17-2013, 11:34 AM Thread Starter
Ket72
Registered User
1998 ZJ 
 
Join Date: Mar 2011
Location: Benton
Posts: 259
Usual oil leak spots in a 5.2?

I'm looking at a 98 5.2 and i noticed it had a oil leak underneath and was wet around the back of the engine and the front of the engine. Where are the usual spots the 5.2 would leak from and would they be easy to fix? It also has 146k miles on it.

Ket72 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-17-2013, 11:40 AM
Rich93ZJ
Registered User
1993 ZJ 
 
Join Date: Sep 2012
Location: Richland
Posts: 461
Valve covers and rear main seal.
Rich93ZJ is offline  
post #3 of 7 Old 04-17-2013, 11:55 AM Thread Starter
Ket72
Registered User
1998 ZJ 
 
Join Date: Mar 2011
Location: Benton
Posts: 259
Ight Thanks. I will double check that when i go back to look at it. Anywhere else i should look?
Ket72 is offline  
post #4 of 7 Old 04-17-2013, 12:00 PM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
How many miles? Oil pan gasket too. But valve cover gaskets normally last 100k miles. Maybe longer, depends on how long you put it off.

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
post #5 of 7 Old 04-17-2013, 12:04 PM Thread Starter
Ket72
Registered User
1998 ZJ 
 
Join Date: Mar 2011
Location: Benton
Posts: 259
It has 146k miles. I know I will need to change out atleast 1 cv and steering stabilizer. Other then that and the oil leaks the jeep is in pretty good condition. I had a 4.0 but i'm not entirely sure where all to look on a 5.2 and its a 98 if theres anything else i need to check.
Ket72 is offline  
post #6 of 7 Old 04-17-2013, 01:09 PM
analogkid
Registered User
1995 ZJ 
 
Join Date: Mar 2010
Location: Kansas City
Posts: 2
Check the oil pressure sending unit. I bought a 95 and it had a oil leak the PO couldn't find. I had to replace the valve cover gaskets that was easy. Then it ran out of oil when to pressure sending unit finished cracking and became a fountain. You need to buy the special socket $10 and the unit was $25. It took 10 minutes.
analogkid is offline  
post #7 of 7 Old 04-17-2013, 02:04 PM Thread Starter
Ket72
Registered User
1998 ZJ 
 
Join Date: Mar 2011
Location: Benton
Posts: 259
Right on. Thanks. I will check it out when i go look again. Lemme know if theres anything else about a 5.2 i need to check.
Ket72 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome