Using 10w-40 due to low oil pressure? - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Using 10w-40 due to low oil pressure?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineBaseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiSpartan Locker Special Forum Prices Dana 30 44 60 Ford 8.8

Reply
Unread 12-18-2012, 03:40 PM   #16
streetzj
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: minnesota
Posts: 266
It is a ticking I realized, and it seems to be coming from the top. A jeep guy I know immediately said it was a lifter.

streetzj is offline   Reply With Quote
Unread 12-19-2012, 12:39 AM   #17
BigJohn96ZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: farmersville, Texas
Posts: 286
I switched to 10w40 in my jeep for the same reason, it has never ran smoother, no ticks, no cold knock. Then again I live down south so it might effect yours more than mine.
__________________
96 ZJ Laredo 4x4, 5.2l, 2.25" budget boost, 31 bfg m/t KM2
BigJohn96ZJ is offline   Reply With Quote
Unread 12-19-2012, 07:56 AM   #18
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,067
Quote:
Originally Posted by BigJohn96ZJ View Post
I switched to 10w40 in my jeep for the same reason, it has never ran smoother, no ticks, no cold knock. Then again I live down south so it might effect yours more than mine.
a 40W is great for older motors with loose tolerances. The oil helps take up the slack.
__________________
1998 5.9
Originally Posted by jabba974
"And yes, there is always a torque spec...but its not necessary...and takes way to much time...."
PolkaPower is online now   Reply With Quote
Unread 12-19-2012, 05:35 PM   #19
Coastaljag98
Registered User
1995 ZJ 
 
Join Date: Oct 2012
Location: Apalachicola, FL
Posts: 34
OMG man I've always had Mobil 1 10-30 or 10-40 Synthetic in mine since it came from the Factory. 170K miles original engine no issues!
Coastaljag98 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.