Using 10w-40 due to low oil pressure? - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 19 Old 12-18-2012, 03:40 PM Thread Starter
streetzj
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: minnesota
Posts: 380
It is a ticking I realized, and it seems to be coming from the top. A jeep guy I know immediately said it was a lifter.

streetzj is offline  
Sponsored Links
Advertisement
 
post #17 of 19 Old 12-19-2012, 12:39 AM
BigJohn96ZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: farmersville
Posts: 286
I switched to 10w40 in my jeep for the same reason, it has never ran smoother, no ticks, no cold knock. Then again I live down south so it might effect yours more than mine.

96 ZJ Laredo 4x4, 5.2l, 2.25" budget boost, 31 bfg m/t KM2
BigJohn96ZJ is offline  
post #18 of 19 Old 12-19-2012, 07:56 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,371
Quote:
Originally Posted by BigJohn96ZJ View Post
I switched to 10w40 in my jeep for the same reason, it has never ran smoother, no ticks, no cold knock. Then again I live down south so it might effect yours more than mine.
a 40W is great for older motors with loose tolerances. The oil helps take up the slack.
PolkaPower is offline  
post #19 of 19 Old 12-19-2012, 05:35 PM
Coastaljag98
Registered User
1995 ZJ 
 
Join Date: Oct 2012
Location: Apalachicola
Posts: 34
OMG man I've always had Mobil 1 10-30 or 10-40 Synthetic in mine since it came from the Factory. 170K miles original engine no issues!
Coastaljag98 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome