Turn Signals, Hazards, dome lights, radio out - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 07-14-2015, 03:51 AM Thread Starter
jcloldjeep
Registered User
1997 ZJ 
 
Join Date: Jul 2015
Location: Hi Nella
Posts: 1
Turn Signals, Hazards, dome lights, radio out

I have a 97 Grand Cherokee. Recently the turn signals, hazards dome light and radio stopped working.

With the engine on there is no power across the associated fuses. Fuse in the power distribution center is good. I switched the turn signal switch and flasher relay with no success.

When the headlights are on and the multifunction switch is pulled back and held back to turn on the high beams. As long as the switch is pulled back and the hazard switch is activated the hazards work. If the lever is down the left turn signals work and up the right turn signals work. Also the radio and the inside overhead lights only work with the lever pulled back. Just when you turn on the high beams not when you pull it back to turn them off.

If anyone could give me some direction where to check next it would be greatly appreciated.

jcloldjeep is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-18-2016, 10:48 PM
Heep_Jeep
Registered User
 
Join Date: Sep 2016
Location: Decorah
Posts: 3
I have the same problem with my 1996 ZJ! We just pulled it out of storage replaced the axles-- it dives fine but I never check any of the lights or anything before we started (just didnt think of it, I guess?) and I never noticed the dome lights in the light of day. PLEASE share if you've found a solution! I've checked *ALL* fuses, relays, and tested the battery, entire fuse box, etc. I cant come up with anything right now. Been looking for 3 days!
Heep_Jeep is offline  
post #3 of 4 Old 09-20-2016, 09:40 AM
95_ZJ_Limited
Registered User
1995 ZJ 
 
Join Date: Sep 2010
Location: Orlando
Posts: 683
Happens in my 1995 when someone presses the rear overhead dome lights. My problem is always one 20amp fuse in the engine compartment fuse box. I don't question it, just change it

1995 ZJ Limited. Lifted, AW4 & 4X4 swapped
Build Thread: Jeep Grand Hilton
Built Not Bought # 529
95_ZJ_Limited is offline  
post #4 of 4 Old 09-20-2016, 09:41 AM
95_ZJ_Limited
Registered User
1995 ZJ 
 
Join Date: Sep 2010
Location: Orlando
Posts: 683
If the quick fixes don't work. i.e. fuses etc. you probly have a bad ground on possibly a bad BCM

1995 ZJ Limited. Lifted, AW4 & 4X4 swapped
Build Thread: Jeep Grand Hilton
Built Not Bought # 529
95_ZJ_Limited is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome