turn signal relay fell out.... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > turn signal relay fell out....

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Nitro Gear Packages Now Available at Rockridge 4wdGear Packages Available! Your # 1 Diff Shop is ROCKRIDGE 4

Reply
Unread 07-27-2009, 05:26 PM   #1
wickerham
Registered User
1993 ZJ 
 
Join Date: Jul 2009
Location: PA
Posts: 810
turn signal relay fell out....

....again!!!

I asked questions about my signals not working, solved the problem (relay fell out) and posted it. But now, it fell out again. Any reason it would keep falling out? This makes twice and I've owed my ZJ less than a month. Think if I bend the metal prongs out a bit (like you would with a house wall outlet type plug) it would stay in better? Would this harm the relay?

wickerham is offline   Reply With Quote
Unread 07-27-2009, 05:46 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,463
Quote:
Originally Posted by wickerham View Post
....again!!!

I asked questions about my signals not working, solved the problem (relay fell out) and posted it. But now, it fell out again. Any reason it would keep falling out? This makes twice and I've owed my ZJ less than a month. Think if I bend the metal prongs out a bit (like you would with a house wall outlet type plug) it would stay in better? Would this harm the relay?
Try disconnecting the battery and using an awl or similar tool to GENTLY pry the socket contacts together. Use a good light to see how the contacts are assembled before you start.
ZeeJay1997 is online now   Reply With Quote
Unread 07-28-2009, 06:59 PM   #3
wickerham
Registered User
1993 ZJ 
 
Join Date: Jul 2009
Location: PA
Posts: 810
"crawled" up in there yesterday, flashlight in mouth! Found the previous owners duct tape still there (I see how they kept 'em in) I re-taped them. Works for now.
wickerham is offline   Reply With Quote
Unread 07-28-2009, 07:52 PM   #4
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City, Missouri
Posts: 1,491
I think this might be a common problem. My previous owner had tape around the flasher also.
__________________
99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.